bugfix, wrong command name
[nodeimage.git] / bootstrapfs.spec
index 9b01791..083edf1 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name bootstrapfs-%{nodefamily}
 %define version 2.0
-%define taglevel 12
+%define taglevel 13
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -84,13 +84,13 @@ pushd bootstrapfs/nodeconfig/yum
 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
 for fcdistro in $(ls); do
     [ -d $fcdistro ] || continue
-    # get kexcludes for that distro
-    KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
+    # get packages to exclude on nodes for that fcdistro/pldistro
+    NODEYUMEXCLUDE="exclude=$(../../../build/nodeyumexclude.sh $fcdistro $pldistro)"
     pushd $fcdistro/yum.myplc.d
-    echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
+    echo "* Handling NODEYUMEXCLUDE in yum repo for $fcdistro/$pldistro ($NODEYUMEXCLUDE)"
     for filein in $(find . -name '*.in') ; do
        file=$(echo $filein | sed -e "s,\.in$,,")
-       sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
+       sed -e "s,@NODEYUMEXCLUDE@,$NODEYUMEXCLUDE,g" $filein > $file
     done
     rm -f stock.repo
     cat *.repo > stock.repo
@@ -152,6 +152,10 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 
 %changelog
+* Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
+- plc.d/packages: rewrote comments about some corner cases where it fails
+- plc.d/packages: marginally more robust
+
 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
 - minor tweak in plc.d/packages