bugfix, wrong command name
[nodeimage.git] / bootstrapfs.spec
index f67f367..083edf1 100644 (file)
@@ -5,12 +5,18 @@
 
 %define name bootstrapfs-%{nodefamily}
 %define version 2.0
-%define taglevel 7
+%define taglevel 13
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
+# we don't really need the standard postinstall process from rpm that
+# strips files and byte-compiles python files. all files in this
+# package are comming from other rpm files and they've already went
+# through this post install processing. - baris
+%define __os_install_post %{nil}
+
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
@@ -28,6 +34,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
 
 Requires: tar, gnupg, sharutils, bzip2
+# this is for plc.d/packages that uses ed for hacking yumgroups.xml
+Requires: ed
 
 # 5.0 now has 3-fold nodefamily
 %define obsolete_nodefamily %{pldistro}-%{_arch}
@@ -76,13 +84,13 @@ pushd bootstrapfs/nodeconfig/yum
 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
 for fcdistro in $(ls); do
     [ -d $fcdistro ] || continue
-    # get kexcludes for that distro
-    KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
+    # get packages to exclude on nodes for that fcdistro/pldistro
+    NODEYUMEXCLUDE="exclude=$(../../../build/nodeyumexclude.sh $fcdistro $pldistro)"
     pushd $fcdistro/yum.myplc.d
-    echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
+    echo "* Handling NODEYUMEXCLUDE in yum repo for $fcdistro/$pldistro ($NODEYUMEXCLUDE)"
     for filein in $(find . -name '*.in') ; do
        file=$(echo $filein | sed -e "s,\.in$,,")
-       sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
+       sed -e "s,@NODEYUMEXCLUDE@,$NODEYUMEXCLUDE,g" $filein > $file
     done
     rm -f stock.repo
     cat *.repo > stock.repo
@@ -144,6 +152,25 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 
 %changelog
+* Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
+- plc.d/packages: rewrote comments about some corner cases where it fails
+- plc.d/packages: marginally more robust
+
+* Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
+- minor tweak in plc.d/packages
+
+* Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
+- sl6 templates
+
+* Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
+- bugfix for multi-flavour deployments
+
+* Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
+- for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
+
+* Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
+- no semantic change - attempt to speed up build
+
 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
 - yum repo template for f14 nodes
 - tweaks the way /etc/plc.d/packages works