remove install deadlock
[nodeimage.git] / bootstrapfs.spec
index 4463cc4..9cfd9af 100644 (file)
@@ -3,11 +3,12 @@
 #
 %define url $URL$
 
-%define nodefamily %{pldistro}-%{_arch}
+%define nodefamily %{pldistro}-%{distroname}-%{_arch}
+%define extensionfamily %{distroname}-%{_arch}
 
 %define name bootstrapfs-%{nodefamily}
-%define version 1.0
-%define taglevel 8
+%define version 2.0
+%define taglevel 2
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -31,6 +32,10 @@ BuildArch: noarch
 
 Requires: tar, gnupg, sharutils, bzip2
 
+# 5.0 now has 3-fold nodefamily
+%define obsolete_nodefamily %{pldistro}-%{_arch}
+Obsoletes: bootstrapfs-%{obsolete_nodefamily}
+
 AutoReqProv: no
 %define debug_package %{nil}
 
@@ -45,50 +50,94 @@ Group: System Environment/Base
 %description plain
 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
 
+%package -n nodeyum
+Summary: the MyPLC-side utilities for tweaking nodes yum configs
+Group: System Environment/Base
+%description -n nodeyum 
+Utility scripts for configuring node updates. This package is designed
+for the MyPLC side.
+
 %prep
 %setup -q
 
 %build
+
+############################## node-side
 pushd BootstrapFS
 ./build.sh %{pldistro} 
-popd BootstrapFS
+popd
+
+############################## server-side
+pushd BootstrapFS/nodeconfig/yum
+# scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
+for fcdistro in $(ls); do
+    [ -d $fcdistro ] || continue
+    # get kexcludes for that distro
+    KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
+    pushd $fcdistro/yum.myplc.d
+    echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
+    for filein in $(find . -name '*.in') ; do
+       file=$(echo $filein | sed -e "s,\.in$,,")
+       sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
+    done
+    rm -f stock.repo
+    cat *.repo > stock.repo
+    popd
+done
+popd
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+############################## node-side
 pushd BootstrapFS
-arch=$(uname -i)
+#arch=$(uname -i)
 
-install -D -m 644 bootstrapfs-%{pldistro}-${arch}.tar.bz2 \
-       $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{pldistro}-${arch}.tar.bz2
-install -D -m 644 bootstrapfs-%{pldistro}-${arch}.tar \
-       $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{pldistro}-${arch}.tar
+install -D -m 644 bootstrapfs-%{nodefamily}.tar.bz2 \
+       $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar.bz2
+install -D -m 644 bootstrapfs-%{nodefamily}.tar \
+       $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{nodefamily}.tar
 
 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
     NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
-    install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-${arch}.tar.bz2 \
-               $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-${arch}.tar.bz2 
-    install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-${arch}.tar \
-               $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-${arch}.tar 
+    install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 \
+               $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar.bz2 
+    install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-%{extensionfamily}.tar \
+               $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-%{extensionfamily}.tar 
 done
+popd
 
+############################## server-side
+# xxx unfinished business here
+# xxx in a multi-flavour myplc, we should ship for all fcdistros
+# and let the php scripts do the right thing
+pushd BootstrapFS
+echo "* Installing MyPLC-side nodes yum config utilities"
+echo "* Multi-fcdistro yum stuff"
+mkdir -p $RPM_BUILD_ROOT/var/www/html/yum/
+rsync -av ./nodeconfig/yum/                                                $RPM_BUILD_ROOT/var/www/html/yum/
+echo "* Legacy (single fcdistro) yum stuff"
+# expose (fixed) myplc.repo.php as                                         https://<plc>/yum.legacy/myplc.repo.php
+install -D -m 644 ./nodeconfig/yum/myplc.repo.php                          $RPM_BUILD_ROOT/var/www/html/yum.legacy/myplc.repo.php
+# expose the fcdistro-dependant yum.conf as                                https://<plc>/yum.legacy/yum.conf
+install -D -m 644 ./nodeconfig/yum/%{distroname}/yum.conf                  $RPM_BUILD_ROOT/var/www/html/yum.legacy/yum.conf
+# expose the (fcdistro-dependant) stock.repo as                                    https://<plc>/yum.legacy/stock.repo
+install -D -m 644 ./nodeconfig/yum/%{distroname}/yum.myplc.d/stock.repo            $RPM_BUILD_ROOT/var/www/html/yum.legacy/stock.repo
+
+# Install initscripts
+echo "* Installing plc.d initscripts"
+find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
+chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
+
+echo "* Installing db-config.d files"
+mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
+cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
+chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
 popd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-# If run under sudo
-if [ -n "$SUDO_USER" ] ; then
-    # Allow user to delete the build directory
-    chown -h -R $SUDO_USER .
-    # Some temporary cdroot files like /var/empty/sshd and
-    # /usr/bin/sudo get created with non-readable permissions.
-    find . -not -perm +0600 -exec chmod u+rw {} \;
-    # Allow user to delete the built RPM(s)
-    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
-fi
-
-%post
 
 %files
 %defattr(-,root,root,-)
@@ -98,7 +147,32 @@ fi
 %defattr(-,root,root,-)
 /var/www/html/boot/bootstrapfs*.tar
 
+%files -n nodeyum
+%defattr(-,root,root,-)
+/var/www/html/yum
+/var/www/html/yum.legacy
+/etc/planetlab/db-config.d
+/etc/plc.d
+
 %changelog
+* Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
+- new slicerepo package for exposing stuff to slivers
+
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
+- first working version of 5.0:
+- pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
+- nodefailiy is 3-fold with pldistro-fcdistro-arch
+- new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
+
+* Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
+- for building on fedora12
+
+* Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
+- cosmetic change in message at build-time
+
+* Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
+- can use groups in the pkgs file with +++ for space
+
 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
 - bugfix for when a .post script is not needed
 
@@ -135,3 +209,5 @@ fi
 
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.
+
+%define module_current_branch 1.0