add a config_file to have /etc/dnf/dnf.conf point at /etc/yum.myplc.d as /etc/yum...
[nodeimage.git] / noderepo.spec
index 1388457..ed8beed 100644 (file)
@@ -8,7 +8,7 @@
 
 %define name noderepo-%{nodefamily}
 %define version 5.2
-%define taglevel 1
+%define taglevel 4
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -75,7 +75,15 @@ rm -rf $RPM_BUILD_ROOT
 # as noderepo might get installed before myplc gets even started 
 # this however exhibit a deadlock, as rpm --almatches -e gpg-pubkey waits for transaction lock
 # that is help by the calling yum/rpm
-service plc start packages
+if [ ! -e /bin/systemctl ] ; then
+   echo "Systemd is not there. Just starting PLC to handle packages (may fail if PLC is not configured) ..."
+   service plc start packages
+elif /bin/systemctl status plc >/dev/null ; then
+   echo "Restarting PLC to handle packages ..."
+   service plc restart packages
+else
+   echo "PLC is not running. Skipping a restart ..."
+fi
 
 %files
 %defattr(-,root,root,-)
@@ -84,6 +92,19 @@ service plc start packages
 %config(noreplace) /var/www/html/install-rpms/%{nodefamily}/yumgroups.xml
 
 %changelog
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
+- minor change; start plc packages only at run-time, not build-time
+- only available on systems that have systemctl
+
+* Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-4
+- Post-install fix: trying to start PLC only when it is running, in order to avoid false-positive error message during build.
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
+- template for f20 yum config
+
+* Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
+- more timestamps during build
+
 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
 - add support for f18 yum config