add a config_file to have /etc/dnf/dnf.conf point at /etc/yum.myplc.d as /etc/yum...
[nodeimage.git] / noderepo.spec
index ba730f1..ed8beed 100644 (file)
@@ -8,7 +8,7 @@
 
 %define name noderepo-%{nodefamily}
 %define version 5.2
-%define taglevel 3
+%define taglevel 4
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -76,13 +76,13 @@ rm -rf $RPM_BUILD_ROOT
 # this however exhibit a deadlock, as rpm --almatches -e gpg-pubkey waits for transaction lock
 # that is help by the calling yum/rpm
 if [ ! -e /bin/systemctl ] ; then
-   echo "Systemd is not there. Just starting PLC to handle packages (may fail of PLC is not configured) ..."
+   echo "Systemd is not there. Just starting PLC to handle packages (may fail if PLC is not configured) ..."
    service plc start packages
 elif /bin/systemctl status plc >/dev/null ; then
    echo "Restarting PLC to handle packages ..."
    service plc restart packages
 else
-   echo "The PLC is not running. Skipping a restart ..."
+   echo "PLC is not running. Skipping a restart ..."
 fi
 
 %files
@@ -92,6 +92,10 @@ fi
 %config(noreplace) /var/www/html/install-rpms/%{nodefamily}/yumgroups.xml
 
 %changelog
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
+- minor change; start plc packages only at run-time, not build-time
+- only available on systems that have systemctl
+
 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-4
 - Post-install fix: trying to start PLC only when it is running, in order to avoid false-positive error message during build.