yum to use http to fetch myplc rpms as they are GPG checked anyway
[nodeimage.git] / slicerepo.spec
index 080e297..60783a8 100644 (file)
 
 %define name slicerepo-%{nodefamily}
 %define version 2.0
-%define taglevel 0
+%define taglevel 2
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
-Vendor: PlanetLab
-Packager: PlanetLab Central <support@planet-lab.org>
+Vendor: OneLab
+Packager: PlanetLab Europe <build@onelab.eu>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
-Summary: The initial content of the yum repository for nodes
+Summary: The yum repository for slices, to be installed on the myplc-side
 Name: %{name}
 Version: %{version}
 Release: %{release}
@@ -38,14 +38,10 @@ BuildArch: noarch
 BuildRequires: rsync 
 Requires: myplc
 
-# 5.0 now has 3-fold nodefamily
-%define obsolete_nodefamily %{pldistro}-%{_arch}
-Obsoletes: slicerepo-%{obsolete_nodefamily}
-
 %define debug_package %{nil}
 
 %description
-This rpm contains all the rpms designed for running on a PlanetLab node
+This rpm contains all the rpms that might ship on a sliver image
 they come organized into a yum repository 
 
 %prep
@@ -79,3 +75,6 @@ service plc start packages
 %config(noreplace) /var/www/html/install-rpms/slice-%{nodefamily}/yumgroups.xml
 
 %changelog
+* Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
+- new slicerepo package for exposing stuff to slivers
+