0760bb03e8658ccccd4f88981f60b6d6f6dee649
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.0
5 %define taglevel 34
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # old name
27 #Obsoletes: sidewinder, sidewinder-common
28
29 # Uses function decorators
30 Requires: python >= 2.4
31 # connecting PLC
32 Requires: python-pycurl
33 # Signed tickets
34 Requires: gnupg
35 # vuseradd, vuserdel
36 Requires: sliceimage-%{slicefamily}
37 # our interface to the vserver patch
38 Requires: util-vserver >= 0.30.208-17
39 # vserver.py
40 Requires: util-vserver-python > 0.3-16
41 # sioc/plnet
42 Requires: pyplnet >= 4.3
43
44 %description
45 The PlanetLab Node Manager manages all aspects of PlanetLab node and
46 slice management once the node has been initialized and configured by
47 the Boot Manager. It periodically contacts its management authority
48 for configuration updates. It provides an XML-RPC API for performing
49 local operations on slices.
50
51 %prep
52 %setup -q
53
54 %build
55 # make manages the C and Python stuff
56 %{__make} %{?_smp_mflags}
57
58 %install
59 # make manages the C and Python stuff
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
62
63 # install the sliver initscript (that triggers the slice initscript if any)
64 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
67
68 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
69 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
70 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
71
72 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
73
74 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132
133 %changelog
134 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
135 - Added memory scheduling to core scheduler
136 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
137
138 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
139 - tweaked log policy for the core scheduler
140 - curlwrapper has an optional verbose mode
141
142 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
143 - fixes for hmac and omf_control tags
144 - optional besteffort flag to core scheduler
145 - logrotate entry for /var/log/nodemanager.daemon
146 - a template for bash initscripts
147
148 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
149 - rename initscript_body into initscript_code
150 - fix generic vinit for broken bash syntax &>>
151
152 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
153 - new initscript_body slice tag, with stop and restart
154 - generic vinit script live updated
155 - new coresched module
156 - protect against non-existing vsys scripts
157 - use Config. instead of globals
158
159 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
160 - more robust reservation plugin
161
162 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
163 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
164 - reservation plugin more robust
165
166 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
167 - pass device to bwlimit
168
169 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
170 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
171
172 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
173 - Catch all exceptions for sfa plugin
174
175 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
176 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
177
178 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
179 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
180
181 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
182 - plugins/sliverauth.py improvements
183
184 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
185 - Disable sfagids plugin
186
187 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
188 - Re-tag nodemanager to include conflicted commits
189
190 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
191 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
192 - sfagids plugin deleted
193 - band-aid patch for lack of GetSliceFamily removed
194
195 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
196
197 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
198 - revert curlwrapper to former forking-curl version
199 - fixes in the omf plugin for ssh key location and node hrn
200 - set umask 0022 in tools.daemon
201
202 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
203 - configure omf-resctl for keys
204
205 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
206 - fix key generation
207
208 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
209 - name changes and fix typos
210
211 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
212 - remove config and options parameters from start function
213
214 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
215 - working version of reservable nodes
216 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
217 - dismantled the -s|--startup option (no convincing need for that)
218 - simpler and more robust init.d/nm
219 - initscript content management through replace_file_with_string
220 - sliverauth uses replace_file_with_string
221 - curlwrapper has a debug mode
222
223 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
224 - pretty-printing/normalized python code - hopefully neutral
225
226 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
227 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
228 - that triggers /etc/init.d/vinit.slice if present and executable
229 - (2) install the slice-provided initscript (as per the initscript tag) as
230 - /etc/init.d/vinit.slice
231 - (3) as a result the initscript are now triggered by rc as part of the
232 - standard vserver .. start, properly attached to the vserver,
233 - and properly killed upon vserver .. stop
234 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
235
236 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
237 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
238 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
239 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
240 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
241 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
242 - cleanup: nodemanger now is a class; however plugins are still dumb modules
243 - cleanup: does not depend on obsolete Set
244
245 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
246 - tagging before RC
247
248 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
249 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
250 - Added some precautions to the slice id-saving code
251 - Added log message to code that records the slice id
252
253 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
254 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
255 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
256 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
257
258 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
259 - fix log_call in plugins/drl.py
260
261 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
262 - protect against nodes in migrated PLC's not having the hrn tag yet
263
264 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
265 - new omf-resctl and drl plugins
266 - specialaccount optimized to overwrite authorized keys only upon changes
267 - codemux plugin has support for a new 'ip' setting
268 - mainloop to display ordered modules&plugins at all times
269
270 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
271 - modules and plugins have a priority
272 - specialaccounts appears soon in the priority chain
273 - logger.log_call logs process output, and has a timeout
274 - vuser{add,del} run through bash -x
275 - nm initscript has support for 'service nm restartverbose'
276 - logs reviewed for consistency
277 - use hashlib module instead of sha when available
278
279 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
280 - first working version of 5.0:
281 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
282 - nodefamily is 3-fold with pldistro-fcdistro-arch
283 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
284 - (in addition to the 'vref' tag that's still exposed too)
285 - logging reviewed for more convenience
286 - support for 'service nm restartdebug'
287 - make sync knows how to publish uncommitted code on a test node
288
289 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
290 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
291
292 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
293 - support for f10 and f12 in the vref slice tag
294
295 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
296 - build on fedora12
297 - uses slicename 'sfacm' instead of 'genicw'
298
299 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
300 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
301 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
302 - days ago.
303
304 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
305 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
306 - self-contained. With this change, they will be able to refer to the attributes associated with a
307 - slice.
308
309 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
310 - fix for syntax error
311
312 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
313 - -fixed problem with sioc import at the build side
314 - -bwlimit.set() now accepts the device and does not asume that it is eth0
315
316 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
317 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
318
319 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
320 - The seed for random previously was the meaning of life (i.e., 42) but
321 - that resulted in a not so random choice for the hmac.  This
322 - implementation now uses a random.seed that is based on the current
323 - time.
324
325 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
326 - Minor fix such that sliverauth.py makes a more specific call to
327 - GetSliceTags that include that specific tagname it is looking for.
328
329 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
330 - Fix bug that prevented 'OVERRIDES' for working correctly.
331
332 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
333 - Increase disk limits to 10G per sliver
334 - Sanity check slice for home directory before starting (hack)
335 - Check codemux arguments
336
337 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
338 - * Fix Delegation
339 - * Move plcapi in plugin-api GetSlivers() calls.
340 - * Persistent Authcheck and resync session when auth failure
341
342 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
343 - Disabling sliverauth module.  Not ready for deployment.
344
345 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
346 - Fixing overrides semantics.
347
348 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
349 - Generalized plugins
350 - Fixed initscript start up bug.
351
352 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
353 - * Fix delegation authentication problem
354 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
355
356 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
357 - * Rerun initscripts when slice goes from disabled to enabled.
358
359 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
360 - * Update session key when out of synch with PLC
361 - * PLCDefaults uses tagname
362
363 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
364 - log invokations of vsys
365
366 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
367
368 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
369
370 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
371 - Codemux supports multiple hosts mapping to single slice
372 - Fixed bug in delegation support where tickets delivered weren't
373   being passed to sm.deliver_ticket().
374 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
375 - Codemux now configured via slice attribute (host,port)
376 - Support for multiple vserver reference images (including different archs)
377 - Mom BW emails are sent to list defined by MyPLC's config
378 - Sirius BW loans honored correctly.  Fixed.
379 - BW totals preserved for dynamic slices so as not to game the system.
380 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
381 - Configures vsys via vsys slice attribute {name: vsys, value: script}
382 - CPU reservations are now calculated via percentages instead of shares
383 - BW totals preserved for dynamic slices
384 - Closes bug where node cap sets off bw slice alarms for all slices.
385
386 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
387 - Switched to SVN.
388
389 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
390 - Initial build.
391
392 %define module_current_branch 1.8