Merge changeset 11123 from the trunk
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.7
10 %define taglevel 37
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # Old Node Manager
29 Obsoletes: sidewinder, sidewinder-common
30
31 # vuseradd, vuserdel
32 Requires: vserver-%{slicefamily}
33 Requires: util-vserver >= 0.30.208-17
34
35 # vserver.py
36 Requires: util-vserver-python
37
38 # Signed tickets
39 Requires: gnupg
40
41 # Contact API server
42 Requires: curl
43
44 # Uses function decorators
45 Requires: python >= 2.4
46
47 %description
48 The PlanetLab Node Manager manages all aspects of PlanetLab node and
49 slice management once the node has been initialized and configured by
50 the Boot Manager. It periodically contacts its management authority
51 for configuration updates. It provides an XML-RPC API for performing
52 local operations on slices.
53
54 %prep
55 %setup -q
56
57 %build
58 %{__make} %{?_smp_mflags}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
63
64 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
65 install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
66 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
67 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
68
69 %post
70 chkconfig --add conf_files
71 chkconfig conf_files on
72 chkconfig --add nm
73 chkconfig nm on
74 chkconfig --add fuse-pl
75 chkconfig fuse-pl on
76 if [ "$PL_BOOTCD" != "1" ] ; then
77         service nm restart
78         service fuse-pl restart
79 fi
80
81
82 %preun
83 # 0 = erase, 1 = upgrade
84 if [ $1 -eq 0 ] ; then
85     chkconfig fuse-pl off
86     chkconfig --del fuse-pl
87     chkconfig nm off
88     chkconfig --del nm
89     chkconfig conf_files off
90     chkconfig --del conf_files
91 fi
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(-,root,root,-)
98 %doc
99 %dir %{_datadir}/NodeManager
100 %dir %{_datadir}/NodeManager/plugins
101 %{_datadir}/NodeManager/*
102 %{_datadir}/NodeManager/plugins/*
103 %{_bindir}/forward_api_calls
104 %{_initrddir}/nm
105 %{_initrddir}/conf_files
106 %{_initrddir}/fuse-pl
107 %{_sysconfdir}/logrotate.d/nm
108
109 %changelog
110 * Tue Sep 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-37
111 - Slices are created 1 at a time to avoid race conditions.
112
113 * Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-36
114 - Internet2 clique flow classification is now setup by NM.
115
116 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-35
117 - Clique network shares don't exist.  Removed from bwmon.
118
119 * Fri Sep 12 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-34
120 - * Fixed slice restart via xmlrpc to actually set resources
121 - * Reverted bwmon to check current min/max limits before manipulating HTB.
122
123 * Wed Sep 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-33
124 - bwmon now has enable/disable flag to control throttling.
125
126 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-32
127 - always log message when expected vserver reference is missing
128
129 * Mon Aug 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-31
130 - Emails were only being sent of high bandwidth caps were being exceeded.  Fixed.
131
132 * Thu Aug 21 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-30
133 - bwmon:  Only mention the limit the slice went over.  Not both it and the second limit.
134
135 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-29
136 - Fixed KeyError in logging.
137
138 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-28
139 - Fixed syntax error in notify function call.  Also fixed values in email message and logging.
140
141 * Mon Aug 18 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-27
142 - Fix the FUSE initscript.
143
144 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-26
145 - FUSE support.
146
147 * Wed Aug 13 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-25
148 - Removed thread created for each sliver (!!!).
149 - Slivers now spawned out of main thread.
150 - This closes the Delegation bug and closes the recent rash of NM instabilities due to queue overflows. [ticket: 384]
151
152 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-24
153 - * Update bandwidth related attributes on every NM sync.  Bwlimit will check if values have changed.
154 - * Vsys supports local_ scripts and NM will disregard them.
155
156 * Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-23
157 - After removing the fork() to the slice's uid when writing .ssh/authorized_keys, .ssh had the wrong owner/group.  Fixed.
158
159 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-22
160 - Small change.  Change uid to slice owner of authorized_keys.
161
162 * Wed Jul 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-21
163 - Slices with initscripts kept restarting.  Fixed.
164 - Also removed unnecessary fork just to write .ssh/authorized keys for every slice.
165
166 * Tue Jul 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-20
167 - * Check slice is_running() every cycle.  If not, assume damaged and restart.
168
169 * Mon Jul 07 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-19
170 - chrooting is not thread-safe.
171
172 * Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-18
173 - Log disk init AFTER acquiring disk semaphore.
174
175 * Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-17
176 - unconditionnally passes node_id and slicefamily to conf_file scripts
177 - correctly set personality a sliver creation time (not yet used by util-vserver-pl though)
178
179 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-16
180
181 - enables a vsys slice attribute to end with 'a', 'c', or 'l' characters without
182 - NM going bonkers.
183
184
185 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-15
186
187 - enable restart if vsys.conf changes also.
188
189
190 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-14
191
192 - the _restart flag for vsys was getting lost when looking across multiple
193 - vservers.  adding the 'or' should preserve any 'True' returns from
194 - createVsysDir()
195
196
197 * Tue Jun 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-13
198
199 - Time out curl when no response for 90 seconds.
200
201
202 * Fri Jun 13 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-12
203 - Patch designed to work around the vsys-fail-to-restart problem with
204 - non-existent directories, and the vuseradd-fail-to-work on directories that
205 - do exist.  
206
207 - This patch will work in conjunction with the new vsys patch.
208
209
210 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-10
211 - fixed doc build by locating locally installed DTDs at build-time
212
213 * Fri May 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-9
214 - * Reverted vserver start to forking before VServer.start to avoid defunct procs.* House keeping in various places.
215
216 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-8
217 - merge changes for myplc-docs from trunk
218
219 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-7
220
221 - Set vcVHI_CONTEXT as slice_id for fprobe-ulog to mark packets with.
222
223
224 * Wed Apr 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-5 NodeManager-1.7-6
225
226 - * Codemux will use PLC_API_HOST when PLC_PLANETFLOW_HOST isn't defined.
227
228
229 * Fri Apr 04 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-4 NodeManager-1.7-5
230 - * vdu limitting when NM restarts and slices are re-init'ed
231 - * CoDemux config parser update.  Now tolerates spaces.
232
233 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
234 - Codemux supports multiple hosts mapping to single slice
235 - Fixed bug in delegation support where tickets delivered weren't
236   being passed to sm.deliver_ticket().
237 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
238 - Codemux now configured via slice attribute (host,port)
239 - Support for multiple vserver reference images (including different archs)
240 - Mom BW emails are sent to list defined by MyPLC's config
241 - Sirius BW loans honored correctly.  Fixed.
242 - BW totals preserved for dynamic slices so as not to game the system.
243 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
244 - Configures vsys via vsys slice attribute {name: vsys, value: script}
245 - CPU reservations are now calculated via percentages instead of shares
246 - BW totals preserved for dynamic slices
247 - Closes bug where node cap sets off bw slice alarms for all slices.
248
249 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
250 - Switched to SVN.
251
252 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
253 - Initial build.