various tricks and notes for smoother debugging
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.8
10 %define taglevel 23
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # Old Node Manager
32 Obsoletes: sidewinder, sidewinder-common
33
34 # vuseradd, vuserdel
35 Requires: vserver-%{slicefamily}
36 Requires: util-vserver >= 0.30.208-17
37
38 # vserver.py
39 Requires: util-vserver-python > 0.3-16
40
41 # Signed tickets
42 Requires: gnupg
43
44 # Contact API server
45 Requires: curl
46
47 # Uses function decorators
48 Requires: python >= 2.4
49
50 # sioc/plnet
51 Requires: pyplnet >= 4.3
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59
60 %prep
61 %setup -q
62
63 %build
64 # make manages the C and Python stuff
65 %{__make} %{?_smp_mflags}
66
67 %install
68 # make manages the C and Python stuff
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
71
72 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
73 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
74 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
75
76 install -D -m 644 logrotate/nm $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
77
78 %post
79 chkconfig --add conf_files
80 chkconfig conf_files on
81 chkconfig --add nm
82 chkconfig nm on
83 chkconfig --add fuse-pl
84 chkconfig fuse-pl on
85 if [ "$PL_BOOTCD" != "1" ] ; then
86         service nm restart
87         service fuse-pl restart
88 fi
89
90
91 %preun
92 # 0 = erase, 1 = upgrade
93 if [ $1 -eq 0 ] ; then
94     chkconfig fuse-pl off
95     chkconfig --del fuse-pl
96     chkconfig nm off
97     chkconfig --del nm
98     chkconfig conf_files off
99     chkconfig --del conf_files
100 fi
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(-,root,root,-)
107 %{_datadir}/NodeManager/
108 %{_bindir}/forward_api_calls
109 %{_initrddir}/
110 %{_sysconfdir}/logrotate.d/nm
111
112 %changelog
113 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
114 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
115
116 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
117 - support for f10 and f12 in the vref slice tag
118
119 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
120 - build on fedora12
121 - uses slicename 'sfacm' instead of 'genicw'
122
123 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
124 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
125 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
126 - days ago.
127
128 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
129 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
130 - self-contained. With this change, they will be able to refer to the attributes associated with a
131 - slice.
132
133 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
134 - fix for syntax error
135
136 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
137 - -fixed problem with sioc import at the build side
138 - -bwlimit.set() now accepts the device and does not asume that it is eth0
139
140 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
141 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
142
143 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
144 - The seed for random previously was the meaning of life (i.e., 42) but
145 - that resulted in a not so random choice for the hmac.  This
146 - implementation now uses a random.seed that is based on the current
147 - time.
148
149 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
150 - Minor fix such that sliverauth.py makes a more specific call to
151 - GetSliceTags that include that specific tagname it is looking for.
152
153 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
154 - Fix bug that prevented 'OVERRIDES' for working correctly.
155
156 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
157 - Increase disk limits to 10G per sliver
158 - Sanity check slice for home directory before starting (hack)
159 - Check codemux arguments
160
161 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
162 - * Fix Delegation
163 - * Move plcapi in plugin-api GetSlivers() calls.
164 - * Persistent Authcheck and resync session when auth failure
165
166 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
167 - Disabling sliverauth module.  Not ready for deployment.
168
169 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
170 - Fixing overrides semantics.
171
172 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
173 - Generalized plugins
174 - Fixed initscript start up bug.
175
176 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
177 - * Fix delegation authentication problem
178 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
179
180 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
181 - * Rerun initscripts when slice goes from disabled to enabled.
182
183 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
184 - * Update session key when out of synch with PLC
185 - * PLCDefaults uses tagname
186
187 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
188 - log invokations of vsys
189
190 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
191
192 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
193
194 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
195 - Codemux supports multiple hosts mapping to single slice
196 - Fixed bug in delegation support where tickets delivered weren't
197   being passed to sm.deliver_ticket().
198 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
199 - Codemux now configured via slice attribute (host,port)
200 - Support for multiple vserver reference images (including different archs)
201 - Mom BW emails are sent to list defined by MyPLC's config
202 - Sirius BW loans honored correctly.  Fixed.
203 - BW totals preserved for dynamic slices so as not to game the system.
204 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
205 - Configures vsys via vsys slice attribute {name: vsys, value: script}
206 - CPU reservations are now calculated via percentages instead of shares
207 - BW totals preserved for dynamic slices
208 - Closes bug where node cap sets off bw slice alarms for all slices.
209
210 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
211 - Switched to SVN.
212
213 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
214 - Initial build.