Setting release to the updated version.
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.8
10 %define taglevel 12
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 %define update 1
15 %define rpmrelease %{release}.%{update}
16
17 Summary: PlanetLab Node Manager
18 Name: %{name}
19 Version: %{version}
20 Release: %{rpmrelease}
21 License: PlanetLab
22 Group: System Environment/Daemons
23 Source0: %{name}-%{version}.tar.gz
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26 Vendor: PlanetLab
27 Packager: PlanetLab Central <support@planet-lab.org>
28 Distribution: PlanetLab %{plrelease}
29 URL: %(echo %{url} | cut -d ' ' -f 2)
30
31 BuildArch: noarch
32
33 # Old Node Manager
34 Obsoletes: sidewinder, sidewinder-common
35
36 # vuseradd, vuserdel
37 Requires: vserver-%{slicefamily}
38 Requires: util-vserver >= 0.30.208-17
39
40 # vserver.py
41 Requires: util-vserver-python > 0.3-16
42
43 # Signed tickets
44 Requires: gnupg
45
46 # Contact API server
47 Requires: curl
48
49 # Uses function decorators
50 Requires: python >= 2.4
51
52 # sioc/plnet
53 Requires: pyplnet >= 4.3
54
55 %description
56 The PlanetLab Node Manager manages all aspects of PlanetLab node and
57 slice management once the node has been initialized and configured by
58 the Boot Manager. It periodically contacts its management authority
59 for configuration updates. It provides an XML-RPC API for performing
60 local operations on slices.
61
62 %prep
63 %setup -q
64
65 %build
66 %{__make} %{?_smp_mflags}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
71
72 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
73 install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
74 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
75 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
76
77 %post
78 chkconfig --add conf_files
79 chkconfig conf_files on
80 chkconfig --add nm
81 chkconfig nm on
82 chkconfig --add fuse-pl
83 chkconfig fuse-pl on
84 if [ "$PL_BOOTCD" != "1" ] ; then
85         service nm restart
86         service fuse-pl restart
87 fi
88
89
90 %preun
91 # 0 = erase, 1 = upgrade
92 if [ $1 -eq 0 ] ; then
93     chkconfig fuse-pl off
94     chkconfig --del fuse-pl
95     chkconfig nm off
96     chkconfig --del nm
97     chkconfig conf_files off
98     chkconfig --del conf_files
99 fi
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(-,root,root,-)
106 %{_datadir}/NodeManager/
107 %{_bindir}/forward_api_calls
108 %{_initrddir}/nm
109 %{_initrddir}/conf_files
110 %{_initrddir}/fuse-pl
111 %{_sysconfdir}/logrotate.d/nm
112
113 %changelog
114 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
115 - Increase disk limits to 10G per sliver
116 - Sanity check slice for home directory before starting (hack)
117 - Check codemux arguments
118
119 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
120 - * Fix Delegation
121 - * Move plcapi in plugin-api GetSlivers() calls.
122 - * Persistent Authcheck and resync session when auth failure
123
124 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
125 - Disabling sliverauth module.  Not ready for deployment.
126
127 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
128 - Fixing overrides semantics.
129
130 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
131 - Generalized plugins
132 - Fixed initscript start up bug.
133
134 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
135 - * Fix delegation authentication problem
136 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
137
138 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
139 - * Rerun initscripts when slice goes from disabled to enabled.
140
141 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
142 - * Update session key when out of synch with PLC
143 - * PLCDefaults uses tagname
144
145 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
146 - log invokations of vsys
147
148 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
149
150 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
151
152 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
153 - Codemux supports multiple hosts mapping to single slice
154 - Fixed bug in delegation support where tickets delivered weren't
155   being passed to sm.deliver_ticket().
156 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
157 - Codemux now configured via slice attribute (host,port)
158 - Support for multiple vserver reference images (including different archs)
159 - Mom BW emails are sent to list defined by MyPLC's config
160 - Sirius BW loans honored correctly.  Fixed.
161 - BW totals preserved for dynamic slices so as not to game the system.
162 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
163 - Configures vsys via vsys slice attribute {name: vsys, value: script}
164 - CPU reservations are now calculated via percentages instead of shares
165 - BW totals preserved for dynamic slices
166 - Closes bug where node cap sets off bw slice alarms for all slices.
167
168 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
169 - Switched to SVN.
170
171 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
172 - Initial build.