Setting tag nodemanager-1.8-39
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.8
10 %define taglevel 39
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # Old Node Manager
32 Obsoletes: sidewinder, sidewinder-common
33
34 # vuseradd, vuserdel
35 Requires: vserver-%{slicefamily}
36 Requires: util-vserver >= 0.30.208-17
37
38 # vserver.py
39 Requires: util-vserver-python > 0.3-16
40
41 # Signed tickets
42 Requires: gnupg
43
44 # Contact API server
45 Requires: curl
46
47 # Uses function decorators
48 Requires: python >= 2.4
49
50 # sioc/plnet
51 Requires: pyplnet >= 4.3
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59
60 %prep
61 %setup -q
62
63 %build
64 %{__make} %{?_smp_mflags}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
69
70 # install the sliver initscript (that triggers the slice initscript if any)
71 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
72 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
73 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
74
75 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
76 install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
77 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
78 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
79
80 %post
81 chkconfig --add conf_files
82 chkconfig conf_files on
83 chkconfig --add nm
84 chkconfig nm on
85 chkconfig --add fuse-pl
86 chkconfig fuse-pl on
87 if [ "$PL_BOOTCD" != "1" ] ; then
88         service nm restart
89         service fuse-pl restart
90 fi
91
92
93 %preun
94 # 0 = erase, 1 = upgrade
95 if [ $1 -eq 0 ] ; then
96     chkconfig fuse-pl off
97     chkconfig --del fuse-pl
98     chkconfig nm off
99     chkconfig --del nm
100     chkconfig conf_files off
101     chkconfig --del conf_files
102 fi
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(-,root,root,-)
109 %{_datadir}/NodeManager/
110 %{_bindir}/forward_api_calls
111 %{_initrddir}/nm
112 %{_initrddir}/conf_files
113 %{_initrddir}/fuse-pl
114 %{_sysconfdir}/logrotate.d/nm
115
116 %changelog
117 * Wed May 02 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-1.8-39
118 - Merge changes to net.py from 2.0 branch
119
120 * Tue Apr 05 2011 S.Çağlar Onur <caglar@verivue.com> - nodemanager-1.8-38
121 - Add a logrotate entry for /var/log/nodemanager.daemon, which can get
122 - out-of-hand on some nodes filling up the root partition.
123
124 * Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - nodemanager-1.8-37
125 - Fix syntax error
126
127 * Fri Mar 18 2011 S.Çağlar Onur <caglar@verivue.com> - nodemanager-1.8-36
128 - use system-wide umask value otherwise all directories under /dev/cgroup and /vservers become world writable
129
130 * Fri Mar 18 2011 S.Çağlar Onur <caglar@verivue.com> - nodemanager-1.8-35
131 - cherry-pick initscripts changes from master
132
133 * Thu Jan 20 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-1.8-34
134
135 * Thu Jan 20 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-1.8-33
136 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
137
138 * Thu Jan 20 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-1.8-32
139 - Add required helper function
140
141 * Thu Jan 20 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-1.8-31
142 - Add missing vinit script
143
144 * Thu Jan 20 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-1.8-30
145 - backport required vinit support from master
146
147 * Tue Jul 27 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-1.8-29
148 - tagging to test module-tag on branch (no changes in nodemanager)
149
150 * Mon Jul 26 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - nodemanager-1.8-28
151 - Fix cciss LVM and partition detection.
152
153 * Fri Jul 23 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - nodemanager-1.8-27
154 - Write slice_id to the vserver configuration directory.
155 - Fix rawdisk for cciss.
156
157 * Tue Mar 09 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-1.8-26
158 - Support codemux's IP field
159 - Introduce DRL plugin
160
161 * Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-25
162 - Only call /etc/init.d/codemux if it is installed.
163
164 * Fri Feb 19 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.8-24
165 - Enable/disable the codemux service too.
166
167 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
168 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
169
170 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
171 - support for f10 and f12 in the vref slice tag
172
173 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
174 - build on fedora12
175 - uses slicename 'sfacm' instead of 'genicw'
176
177 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
178 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
179 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
180 - days ago.
181
182 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
183 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
184 - self-contained. With this change, they will be able to refer to the attributes associated with a
185 - slice.
186
187 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
188 - fix for syntax error
189
190 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
191 - -fixed problem with sioc import at the build side
192 - -bwlimit.set() now accepts the device and does not asume that it is eth0
193
194 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
195 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
196
197 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
198 - The seed for random previously was the meaning of life (i.e., 42) but
199 - that resulted in a not so random choice for the hmac.  This
200 - implementation now uses a random.seed that is based on the current
201 - time.
202
203 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
204 - Minor fix such that sliverauth.py makes a more specific call to
205 - GetSliceTags that include that specific tagname it is looking for.
206
207 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
208 - Fix bug that prevented 'OVERRIDES' for working correctly.
209
210 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
211 - Increase disk limits to 10G per sliver
212 - Sanity check slice for home directory before starting (hack)
213 - Check codemux arguments
214
215 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
216 - * Fix Delegation
217 - * Move plcapi in plugin-api GetSlivers() calls.
218 - * Persistent Authcheck and resync session when auth failure
219
220 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
221 - Disabling sliverauth module.  Not ready for deployment.
222
223 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
224 - Fixing overrides semantics.
225
226 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
227 - Generalized plugins
228 - Fixed initscript start up bug.
229
230 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
231 - * Fix delegation authentication problem
232 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
233
234 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
235 - * Rerun initscripts when slice goes from disabled to enabled.
236
237 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
238 - * Update session key when out of synch with PLC
239 - * PLCDefaults uses tagname
240
241 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
242 - log invokations of vsys
243
244 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
245
246 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
247
248 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
249 - Codemux supports multiple hosts mapping to single slice
250 - Fixed bug in delegation support where tickets delivered weren't
251   being passed to sm.deliver_ticket().
252 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
253 - Codemux now configured via slice attribute (host,port)
254 - Support for multiple vserver reference images (including different archs)
255 - Mom BW emails are sent to list defined by MyPLC's config
256 - Sirius BW loans honored correctly.  Fixed.
257 - BW totals preserved for dynamic slices so as not to game the system.
258 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
259 - Configures vsys via vsys slice attribute {name: vsys, value: script}
260 - CPU reservations are now calculated via percentages instead of shares
261 - BW totals preserved for dynamic slices
262 - Closes bug where node cap sets off bw slice alarms for all slices.
263
264 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
265 - Switched to SVN.
266
267 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
268 - Initial build.