more renamings
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 2.0
10 %define taglevel 8
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # old name
32 #Obsoletes: sidewinder, sidewinder-common
33
34 # Uses function decorators
35 Requires: python >= 2.4
36 # connecting PLC
37 Requires: python-pycurl
38 # Signed tickets
39 Requires: gnupg
40 # vuseradd, vuserdel
41 Requires: vserver-%{slicefamily}
42 # our interface to the vserver patch
43 Requires: util-vserver >= 0.30.208-17
44 # vserver.py
45 Requires: util-vserver-python > 0.3-16
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48
49 %description
50 The PlanetLab Node Manager manages all aspects of PlanetLab node and
51 slice management once the node has been initialized and configured by
52 the Boot Manager. It periodically contacts its management authority
53 for configuration updates. It provides an XML-RPC API for performing
54 local operations on slices.
55
56 %prep
57 %setup -q
58
59 %build
60 # make manages the C and Python stuff
61 %{__make} %{?_smp_mflags}
62
63 %install
64 # make manages the C and Python stuff
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
67
68 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
69 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
70 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
71
72 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
73
74 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.dat
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/nodemanager.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132
133 %changelog
134 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
135 - tagging before RC
136
137 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
138 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
139 - Added some precautions to the slice id-saving code
140 - Added log message to code that records the slice id
141
142 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
143 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
144 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
145 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
146
147 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
148 - fix log_call in plugins/drl.py
149
150 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
151 - protect against nodes in migrated PLC's not having the hrn tag yet
152
153 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
154 - new omf-resctl and drl plugins
155 - specialaccount optimized to overwrite authorized keys only upon changes
156 - codemux plugin has support for a new 'ip' setting
157 - mainloop to display ordered modules&plugins at all times
158
159 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
160 - modules and plugins have a priority
161 - specialaccounts appears soon in the priority chain
162 - logger.log_call logs process output, and has a timeout
163 - vuser{add,del} run through bash -x
164 - nm initscript has support for 'service nm restartverbose'
165 - logs reviewed for consistency
166 - use hashlib module instead of sha when available
167
168 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
169 - first working version of 5.0:
170 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
171 - nodefamily is 3-fold with pldistro-fcdistro-arch
172 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
173 - (in addition to the 'vref' tag that's still exposed too)
174 - logging reviewed for more convenience
175 - support for 'service nm restartdebug'
176 - make sync knows how to publish uncommitted code on a test node
177
178 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
179 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
180
181 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
182 - support for f10 and f12 in the vref slice tag
183
184 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
185 - build on fedora12
186 - uses slicename 'sfacm' instead of 'genicw'
187
188 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
189 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
190 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
191 - days ago.
192
193 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
194 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
195 - self-contained. With this change, they will be able to refer to the attributes associated with a
196 - slice.
197
198 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
199 - fix for syntax error
200
201 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
202 - -fixed problem with sioc import at the build side
203 - -bwlimit.set() now accepts the device and does not asume that it is eth0
204
205 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
206 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
207
208 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
209 - The seed for random previously was the meaning of life (i.e., 42) but
210 - that resulted in a not so random choice for the hmac.  This
211 - implementation now uses a random.seed that is based on the current
212 - time.
213
214 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
215 - Minor fix such that sliverauth.py makes a more specific call to
216 - GetSliceTags that include that specific tagname it is looking for.
217
218 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
219 - Fix bug that prevented 'OVERRIDES' for working correctly.
220
221 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
222 - Increase disk limits to 10G per sliver
223 - Sanity check slice for home directory before starting (hack)
224 - Check codemux arguments
225
226 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
227 - * Fix Delegation
228 - * Move plcapi in plugin-api GetSlivers() calls.
229 - * Persistent Authcheck and resync session when auth failure
230
231 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
232 - Disabling sliverauth module.  Not ready for deployment.
233
234 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
235 - Fixing overrides semantics.
236
237 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
238 - Generalized plugins
239 - Fixed initscript start up bug.
240
241 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
242 - * Fix delegation authentication problem
243 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
244
245 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
246 - * Rerun initscripts when slice goes from disabled to enabled.
247
248 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
249 - * Update session key when out of synch with PLC
250 - * PLCDefaults uses tagname
251
252 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
253 - log invokations of vsys
254
255 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
256
257 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
258
259 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
260 - Codemux supports multiple hosts mapping to single slice
261 - Fixed bug in delegation support where tickets delivered weren't
262   being passed to sm.deliver_ticket().
263 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
264 - Codemux now configured via slice attribute (host,port)
265 - Support for multiple vserver reference images (including different archs)
266 - Mom BW emails are sent to list defined by MyPLC's config
267 - Sirius BW loans honored correctly.  Fixed.
268 - BW totals preserved for dynamic slices so as not to game the system.
269 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
270 - Configures vsys via vsys slice attribute {name: vsys, value: script}
271 - CPU reservations are now calculated via percentages instead of shares
272 - BW totals preserved for dynamic slices
273 - Closes bug where node cap sets off bw slice alarms for all slices.
274
275 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
276 - Switched to SVN.
277
278 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
279 - Initial build.
280
281 %define module_current_branch 1.8