package details
[nodemanager.git] / NodeManager.spec
1 Summary: PlanetLab Node Manager
2 Name: NodeManager
3 Version: 0.1
4 Release: 1
5 License: PlanetLab
6 Group: System Environment/Daemons
7 URL: http://cvs.planet-lab.org/cvs/NodeManager
8 Source0: %{name}-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11 Obsoletes: sidewinder
12
13 # Uses function decorators
14 Requires: python >= 2.4
15
16 %description
17 The PlanetLab Node Manager manages all aspects of PlanetLab node and
18 slice management once the node has been initialized and configured by
19 the Boot Manager. It periodically contacts its management authority
20 for configuration updates. It provides an XML-RPC API for performing
21 local operations on slices.
22
23 %prep
24 %setup -q
25
26 %build
27 %{__make} %{?_smp_mflags}
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
32
33 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
34 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %files
40 %defattr(-,root,root,-)
41 %doc
42 %dir %{_datadir}/NodeManager
43 %{_datadir}/NodeManager/*
44 %{_bindir}/forward_api_calls
45 %{_initrddir}/nm
46
47 %changelog
48 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
49 - Initial build.
50