remove svn keywords
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.0
5 %define taglevel 36
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # old name
27 #Obsoletes: sidewinder, sidewinder-common
28
29 # Uses function decorators
30 Requires: python >= 2.4
31 # connecting PLC
32 Requires: python-pycurl
33 # Signed tickets
34 Requires: gnupg
35 # vserver-sliceimage or lxc-sliceimage to be added explicitly in nodeimage.pkgs
36 # we do need the slice images in any case
37 Requires: sliceimage-%{slicefamily}
38 # our interface to the vserver patch
39 Requires: util-vserver >= 0.30.208-17
40 # vserver.py
41 Requires: util-vserver-python > 0.3-16
42 # sioc/plnet
43 Requires: pyplnet >= 4.3
44
45 %description
46 The PlanetLab Node Manager manages all aspects of PlanetLab node and
47 slice management once the node has been initialized and configured by
48 the Boot Manager. It periodically contacts its management authority
49 for configuration updates. It provides an XML-RPC API for performing
50 local operations on slices.
51
52 %prep
53 %setup -q
54
55 %build
56 # make manages the C and Python stuff
57 %{__make} %{?_smp_mflags}
58
59 %install
60 # make manages the C and Python stuff
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
63
64 # install the sliver initscript (that triggers the slice initscript if any)
65 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
67 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
68
69 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
70 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
71 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
72
73 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
74
75 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
76
77 ##########
78 %post
79 # tmp - handle file renamings; old names are from 2.0-8
80 renamings="
81 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
82 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
83 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
84 /var/log/nm@/var/log/nodemanager
85 /var/log/nm.daemon@/var/log/nodemanager.daemon
86 /var/run/nm.pid@/var/run/nodemanager.pid
87 /tmp/sliver_mgr.api@/tmp/nodemanager.api
88 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
89 "
90 for renaming in $renamings; do
91   old=$(echo $renaming | cut -d@ -f1)
92   new=$(echo $renaming | cut -d@ -f2)
93   newdir=$(dirname $new)
94   if [ -e "$old" -a ! -e "$new" ] ; then
95       mkdir -p $newdir
96       mv -f $old $new
97   fi
98 done
99 #
100 chkconfig --add conf_files
101 chkconfig conf_files on
102 chkconfig --add nm
103 chkconfig nm on
104 chkconfig --add fuse-pl
105 chkconfig fuse-pl on
106 if [ "$PL_BOOTCD" != "1" ] ; then
107         service nm restart
108         service fuse-pl restart
109 fi
110
111 ##########
112 %preun
113 # 0 = erase, 1 = upgrade
114 if [ $1 -eq 0 ] ; then
115     chkconfig fuse-pl off
116     chkconfig --del fuse-pl
117     chkconfig nm off
118     chkconfig --del nm
119     chkconfig conf_files off
120     chkconfig --del conf_files
121 fi
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(-,root,root,-)
128 %{_datadir}/NodeManager/
129 %{_bindir}/forward_api_calls
130 %{_initrddir}/
131 %{_sysconfdir}/logrotate.d/nodemanager
132 /var/lib/
133
134 %changelog
135 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
136 - /var/log/nodemanager shows duration of mainloop
137
138 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
139 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
140
141 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
142 - Added memory scheduling to core scheduler
143 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
144
145 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
146 - tweaked log policy for the core scheduler
147 - curlwrapper has an optional verbose mode
148
149 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
150 - fixes for hmac and omf_control tags
151 - optional besteffort flag to core scheduler
152 - logrotate entry for /var/log/nodemanager.daemon
153 - a template for bash initscripts
154
155 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
156 - rename initscript_body into initscript_code
157 - fix generic vinit for broken bash syntax &>>
158
159 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
160 - new initscript_body slice tag, with stop and restart
161 - generic vinit script live updated
162 - new coresched module
163 - protect against non-existing vsys scripts
164 - use Config. instead of globals
165
166 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
167 - more robust reservation plugin
168
169 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
170 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
171 - reservation plugin more robust
172
173 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
174 - pass device to bwlimit
175
176 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
177 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
178
179 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
180 - Catch all exceptions for sfa plugin
181
182 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
183 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
184
185 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
186 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
187
188 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
189 - plugins/sliverauth.py improvements
190
191 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
192 - Disable sfagids plugin
193
194 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
195 - Re-tag nodemanager to include conflicted commits
196
197 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
198 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
199 - sfagids plugin deleted
200 - band-aid patch for lack of GetSliceFamily removed
201
202 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
203
204 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
205 - revert curlwrapper to former forking-curl version
206 - fixes in the omf plugin for ssh key location and node hrn
207 - set umask 0022 in tools.daemon
208
209 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
210 - configure omf-resctl for keys
211
212 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
213 - fix key generation
214
215 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
216 - name changes and fix typos
217
218 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
219 - remove config and options parameters from start function
220
221 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
222 - working version of reservable nodes
223 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
224 - dismantled the -s|--startup option (no convincing need for that)
225 - simpler and more robust init.d/nm
226 - initscript content management through replace_file_with_string
227 - sliverauth uses replace_file_with_string
228 - curlwrapper has a debug mode
229
230 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
231 - pretty-printing/normalized python code - hopefully neutral
232
233 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
234 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
235 - that triggers /etc/init.d/vinit.slice if present and executable
236 - (2) install the slice-provided initscript (as per the initscript tag) as
237 - /etc/init.d/vinit.slice
238 - (3) as a result the initscript are now triggered by rc as part of the
239 - standard vserver .. start, properly attached to the vserver,
240 - and properly killed upon vserver .. stop
241 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
242
243 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
244 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
245 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
246 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
247 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
248 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
249 - cleanup: nodemanger now is a class; however plugins are still dumb modules
250 - cleanup: does not depend on obsolete Set
251
252 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
253 - tagging before RC
254
255 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
256 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
257 - Added some precautions to the slice id-saving code
258 - Added log message to code that records the slice id
259
260 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
261 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
262 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
263 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
264
265 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
266 - fix log_call in plugins/drl.py
267
268 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
269 - protect against nodes in migrated PLC's not having the hrn tag yet
270
271 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
272 - new omf-resctl and drl plugins
273 - specialaccount optimized to overwrite authorized keys only upon changes
274 - codemux plugin has support for a new 'ip' setting
275 - mainloop to display ordered modules&plugins at all times
276
277 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
278 - modules and plugins have a priority
279 - specialaccounts appears soon in the priority chain
280 - logger.log_call logs process output, and has a timeout
281 - vuser{add,del} run through bash -x
282 - nm initscript has support for 'service nm restartverbose'
283 - logs reviewed for consistency
284 - use hashlib module instead of sha when available
285
286 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
287 - first working version of 5.0:
288 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
289 - nodefamily is 3-fold with pldistro-fcdistro-arch
290 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
291 - (in addition to the 'vref' tag that's still exposed too)
292 - logging reviewed for more convenience
293 - support for 'service nm restartdebug'
294 - make sync knows how to publish uncommitted code on a test node
295
296 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
297 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
298
299 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
300 - support for f10 and f12 in the vref slice tag
301
302 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
303 - build on fedora12
304 - uses slicename 'sfacm' instead of 'genicw'
305
306 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
307 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
308 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
309 - days ago.
310
311 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
312 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
313 - self-contained. With this change, they will be able to refer to the attributes associated with a
314 - slice.
315
316 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
317 - fix for syntax error
318
319 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
320 - -fixed problem with sioc import at the build side
321 - -bwlimit.set() now accepts the device and does not asume that it is eth0
322
323 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
324 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
325
326 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
327 - The seed for random previously was the meaning of life (i.e., 42) but
328 - that resulted in a not so random choice for the hmac.  This
329 - implementation now uses a random.seed that is based on the current
330 - time.
331
332 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
333 - Minor fix such that sliverauth.py makes a more specific call to
334 - GetSliceTags that include that specific tagname it is looking for.
335
336 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
337 - Fix bug that prevented 'OVERRIDES' for working correctly.
338
339 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
340 - Increase disk limits to 10G per sliver
341 - Sanity check slice for home directory before starting (hack)
342 - Check codemux arguments
343
344 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
345 - * Fix Delegation
346 - * Move plcapi in plugin-api GetSlivers() calls.
347 - * Persistent Authcheck and resync session when auth failure
348
349 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
350 - Disabling sliverauth module.  Not ready for deployment.
351
352 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
353 - Fixing overrides semantics.
354
355 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
356 - Generalized plugins
357 - Fixed initscript start up bug.
358
359 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
360 - * Fix delegation authentication problem
361 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
362
363 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
364 - * Rerun initscripts when slice goes from disabled to enabled.
365
366 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
367 - * Update session key when out of synch with PLC
368 - * PLCDefaults uses tagname
369
370 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
371 - log invokations of vsys
372
373 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
374
375 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
376
377 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
378 - Codemux supports multiple hosts mapping to single slice
379 - Fixed bug in delegation support where tickets delivered weren't
380   being passed to sm.deliver_ticket().
381 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
382 - Codemux now configured via slice attribute (host,port)
383 - Support for multiple vserver reference images (including different archs)
384 - Mom BW emails are sent to list defined by MyPLC's config
385 - Sirius BW loans honored correctly.  Fixed.
386 - BW totals preserved for dynamic slices so as not to game the system.
387 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
388 - Configures vsys via vsys slice attribute {name: vsys, value: script}
389 - CPU reservations are now calculated via percentages instead of shares
390 - BW totals preserved for dynamic slices
391 - Closes bug where node cap sets off bw slice alarms for all slices.
392
393 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
394 - Switched to SVN.
395
396 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
397 - Initial build.