Fix module-tag mess.
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.8
10 %define taglevel 27
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # Old Node Manager
32 Obsoletes: sidewinder, sidewinder-common
33
34 # vuseradd, vuserdel
35 Requires: vserver-%{slicefamily}
36 Requires: util-vserver >= 0.30.208-17
37
38 # vserver.py
39 Requires: util-vserver-python > 0.3-16
40
41 # Signed tickets
42 Requires: gnupg
43
44 # Contact API server
45 Requires: curl
46
47 # Uses function decorators
48 Requires: python >= 2.4
49
50 # sioc/plnet
51 Requires: pyplnet >= 4.3
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59
60 %prep
61 %setup -q
62
63 %build
64 %{__make} %{?_smp_mflags}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
69
70 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
71 install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
72 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
73 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
74
75 %post
76 chkconfig --add conf_files
77 chkconfig conf_files on
78 chkconfig --add nm
79 chkconfig nm on
80 chkconfig --add fuse-pl
81 chkconfig fuse-pl on
82 if [ "$PL_BOOTCD" != "1" ] ; then
83         service nm restart
84         service fuse-pl restart
85 fi
86
87
88 %preun
89 # 0 = erase, 1 = upgrade
90 if [ $1 -eq 0 ] ; then
91     chkconfig fuse-pl off
92     chkconfig --del fuse-pl
93     chkconfig nm off
94     chkconfig --del nm
95     chkconfig conf_files off
96     chkconfig --del conf_files
97 fi
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files
103 %defattr(-,root,root,-)
104 %{_datadir}/NodeManager/
105 %{_bindir}/forward_api_calls
106 %{_initrddir}/nm
107 %{_initrddir}/conf_files
108 %{_initrddir}/fuse-pl
109 %{_sysconfdir}/logrotate.d/nm
110
111 %changelog
112 * Fri Jul 23 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - nodemanager-1.8-27
113 - Write slice_id to the vserver configuration directory.
114 - Fix rawdisk for cciss.
115
116 * Tue Mar 09 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-1.8-26
117 - Support codemux's IP field
118 - Introduce DRL plugin
119
120 * Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-25
121 - Only call /etc/init.d/codemux if it is installed.
122
123 * Fri Feb 19 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.8-24
124 - Enable/disable the codemux service too.
125
126 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
127 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
128
129 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
130 - support for f10 and f12 in the vref slice tag
131
132 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
133 - build on fedora12
134 - uses slicename 'sfacm' instead of 'genicw'
135
136 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
137 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
138 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
139 - days ago.
140
141 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
142 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
143 - self-contained. With this change, they will be able to refer to the attributes associated with a
144 - slice.
145
146 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
147 - fix for syntax error
148
149 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
150 - -fixed problem with sioc import at the build side
151 - -bwlimit.set() now accepts the device and does not asume that it is eth0
152
153 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
154 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
155
156 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
157 - The seed for random previously was the meaning of life (i.e., 42) but
158 - that resulted in a not so random choice for the hmac.  This
159 - implementation now uses a random.seed that is based on the current
160 - time.
161
162 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
163 - Minor fix such that sliverauth.py makes a more specific call to
164 - GetSliceTags that include that specific tagname it is looking for.
165
166 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
167 - Fix bug that prevented 'OVERRIDES' for working correctly.
168
169 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
170 - Increase disk limits to 10G per sliver
171 - Sanity check slice for home directory before starting (hack)
172 - Check codemux arguments
173
174 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
175 - * Fix Delegation
176 - * Move plcapi in plugin-api GetSlivers() calls.
177 - * Persistent Authcheck and resync session when auth failure
178
179 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
180 - Disabling sliverauth module.  Not ready for deployment.
181
182 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
183 - Fixing overrides semantics.
184
185 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
186 - Generalized plugins
187 - Fixed initscript start up bug.
188
189 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
190 - * Fix delegation authentication problem
191 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
192
193 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
194 - * Rerun initscripts when slice goes from disabled to enabled.
195
196 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
197 - * Update session key when out of synch with PLC
198 - * PLCDefaults uses tagname
199
200 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
201 - log invokations of vsys
202
203 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
204
205 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
206
207 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
208 - Codemux supports multiple hosts mapping to single slice
209 - Fixed bug in delegation support where tickets delivered weren't
210   being passed to sm.deliver_ticket().
211 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
212 - Codemux now configured via slice attribute (host,port)
213 - Support for multiple vserver reference images (including different archs)
214 - Mom BW emails are sent to list defined by MyPLC's config
215 - Sirius BW loans honored correctly.  Fixed.
216 - BW totals preserved for dynamic slices so as not to game the system.
217 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
218 - Configures vsys via vsys slice attribute {name: vsys, value: script}
219 - CPU reservations are now calculated via percentages instead of shares
220 - BW totals preserved for dynamic slices
221 - Closes bug where node cap sets off bw slice alarms for all slices.
222
223 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
224 - Switched to SVN.
225
226 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
227 - Initial build.