fix comments about requires in specfile
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.1
5 %define taglevel 0
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # old name
27 #Obsoletes: sidewinder, sidewinder-common
28
29 # Uses function decorators
30 Requires: python >= 2.4
31 # connecting PLC
32 Requires: python-pycurl
33 # Signed tickets
34 Requires: gnupg
35 # vserver-sliceimage or lxc-sliceimage to be added explicitly in nodeimage.pkgs
36 # we do need the slice images in any case
37 Requires: sliceimage-%{slicefamily}
38 # our interface to the vserver patch
39 Requires: util-vserver >= 0.30.208-17
40 # vserver.py
41 Requires: util-vserver-python > 0.3-16
42 # sioc/plnet
43 Requires: pyplnet >= 4.3
44
45 %description
46 The PlanetLab Node Manager manages all aspects of PlanetLab node and
47 slice management once the node has been initialized and configured by
48 the Boot Manager. It periodically contacts its management authority
49 for configuration updates. It provides an XML-RPC API for performing
50 local operations on slices.
51
52 %prep
53 %setup -q
54
55 %build
56 # make manages the C and Python stuff
57 %{__make} %{?_smp_mflags}
58
59 %install
60 # make manages the C and Python stuff
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
63
64 # install the sliver initscript (that triggers the slice initscript if any)
65 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
67 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
68
69 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
70 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
71 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
72
73 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
74
75 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
76
77 ##########
78 %post
79 # tmp - handle file renamings; old names are from 2.0-8
80 renamings="
81 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
82 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
83 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
84 /var/log/nm@/var/log/nodemanager
85 /var/log/nm.daemon@/var/log/nodemanager.daemon
86 /var/run/nm.pid@/var/run/nodemanager.pid
87 /tmp/sliver_mgr.api@/tmp/nodemanager.api
88 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
89 "
90 for renaming in $renamings; do
91   old=$(echo $renaming | cut -d@ -f1)
92   new=$(echo $renaming | cut -d@ -f2)
93   newdir=$(dirname $new)
94   if [ -e "$old" -a ! -e "$new" ] ; then
95       mkdir -p $newdir
96       mv -f $old $new
97   fi
98 done
99 #
100 chkconfig --add conf_files
101 chkconfig conf_files on
102 chkconfig --add nm
103 chkconfig nm on
104 chkconfig --add fuse-pl
105 chkconfig fuse-pl on
106 if [ "$PL_BOOTCD" != "1" ] ; then
107         service nm restart
108         service fuse-pl restart
109 fi
110
111 ##########
112 %preun
113 # 0 = erase, 1 = upgrade
114 if [ $1 -eq 0 ] ; then
115     chkconfig fuse-pl off
116     chkconfig --del fuse-pl
117     chkconfig nm off
118     chkconfig --del nm
119     chkconfig conf_files off
120     chkconfig --del conf_files
121 fi
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(-,root,root,-)
128 %{_datadir}/NodeManager/
129 %{_bindir}/forward_api_calls
130 %{_initrddir}/
131 %{_sysconfdir}/logrotate.d/nodemanager
132 /var/lib/
133
134 %changelog
135 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
136 - Added memory scheduling to core scheduler
137 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
138
139 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
140 - tweaked log policy for the core scheduler
141 - curlwrapper has an optional verbose mode
142
143 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
144 - fixes for hmac and omf_control tags
145 - optional besteffort flag to core scheduler
146 - logrotate entry for /var/log/nodemanager.daemon
147 - a template for bash initscripts
148
149 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
150 - rename initscript_body into initscript_code
151 - fix generic vinit for broken bash syntax &>>
152
153 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
154 - new initscript_body slice tag, with stop and restart
155 - generic vinit script live updated
156 - new coresched module
157 - protect against non-existing vsys scripts
158 - use Config. instead of globals
159
160 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
161 - more robust reservation plugin
162
163 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
164 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
165 - reservation plugin more robust
166
167 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
168 - pass device to bwlimit
169
170 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
171 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
172
173 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
174 - Catch all exceptions for sfa plugin
175
176 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
177 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
178
179 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
180 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
181
182 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
183 - plugins/sliverauth.py improvements
184
185 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
186 - Disable sfagids plugin
187
188 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
189 - Re-tag nodemanager to include conflicted commits
190
191 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
192 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
193 - sfagids plugin deleted
194 - band-aid patch for lack of GetSliceFamily removed
195
196 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
197
198 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
199 - revert curlwrapper to former forking-curl version
200 - fixes in the omf plugin for ssh key location and node hrn
201 - set umask 0022 in tools.daemon
202
203 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
204 - configure omf-resctl for keys
205
206 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
207 - fix key generation
208
209 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
210 - name changes and fix typos
211
212 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
213 - remove config and options parameters from start function
214
215 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
216 - working version of reservable nodes
217 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
218 - dismantled the -s|--startup option (no convincing need for that)
219 - simpler and more robust init.d/nm
220 - initscript content management through replace_file_with_string
221 - sliverauth uses replace_file_with_string
222 - curlwrapper has a debug mode
223
224 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
225 - pretty-printing/normalized python code - hopefully neutral
226
227 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
228 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
229 - that triggers /etc/init.d/vinit.slice if present and executable
230 - (2) install the slice-provided initscript (as per the initscript tag) as
231 - /etc/init.d/vinit.slice
232 - (3) as a result the initscript are now triggered by rc as part of the
233 - standard vserver .. start, properly attached to the vserver,
234 - and properly killed upon vserver .. stop
235 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
236
237 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
238 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
239 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
240 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
241 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
242 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
243 - cleanup: nodemanger now is a class; however plugins are still dumb modules
244 - cleanup: does not depend on obsolete Set
245
246 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
247 - tagging before RC
248
249 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
250 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
251 - Added some precautions to the slice id-saving code
252 - Added log message to code that records the slice id
253
254 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
255 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
256 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
257 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
258
259 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
260 - fix log_call in plugins/drl.py
261
262 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
263 - protect against nodes in migrated PLC's not having the hrn tag yet
264
265 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
266 - new omf-resctl and drl plugins
267 - specialaccount optimized to overwrite authorized keys only upon changes
268 - codemux plugin has support for a new 'ip' setting
269 - mainloop to display ordered modules&plugins at all times
270
271 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
272 - modules and plugins have a priority
273 - specialaccounts appears soon in the priority chain
274 - logger.log_call logs process output, and has a timeout
275 - vuser{add,del} run through bash -x
276 - nm initscript has support for 'service nm restartverbose'
277 - logs reviewed for consistency
278 - use hashlib module instead of sha when available
279
280 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
281 - first working version of 5.0:
282 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
283 - nodefamily is 3-fold with pldistro-fcdistro-arch
284 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
285 - (in addition to the 'vref' tag that's still exposed too)
286 - logging reviewed for more convenience
287 - support for 'service nm restartdebug'
288 - make sync knows how to publish uncommitted code on a test node
289
290 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
291 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
292
293 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
294 - support for f10 and f12 in the vref slice tag
295
296 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
297 - build on fedora12
298 - uses slicename 'sfacm' instead of 'genicw'
299
300 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
301 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
302 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
303 - days ago.
304
305 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
306 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
307 - self-contained. With this change, they will be able to refer to the attributes associated with a
308 - slice.
309
310 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
311 - fix for syntax error
312
313 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
314 - -fixed problem with sioc import at the build side
315 - -bwlimit.set() now accepts the device and does not asume that it is eth0
316
317 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
318 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
319
320 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
321 - The seed for random previously was the meaning of life (i.e., 42) but
322 - that resulted in a not so random choice for the hmac.  This
323 - implementation now uses a random.seed that is based on the current
324 - time.
325
326 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
327 - Minor fix such that sliverauth.py makes a more specific call to
328 - GetSliceTags that include that specific tagname it is looking for.
329
330 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
331 - Fix bug that prevented 'OVERRIDES' for working correctly.
332
333 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
334 - Increase disk limits to 10G per sliver
335 - Sanity check slice for home directory before starting (hack)
336 - Check codemux arguments
337
338 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
339 - * Fix Delegation
340 - * Move plcapi in plugin-api GetSlivers() calls.
341 - * Persistent Authcheck and resync session when auth failure
342
343 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
344 - Disabling sliverauth module.  Not ready for deployment.
345
346 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
347 - Fixing overrides semantics.
348
349 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
350 - Generalized plugins
351 - Fixed initscript start up bug.
352
353 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
354 - * Fix delegation authentication problem
355 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
356
357 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
358 - * Rerun initscripts when slice goes from disabled to enabled.
359
360 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
361 - * Update session key when out of synch with PLC
362 - * PLCDefaults uses tagname
363
364 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
365 - log invokations of vsys
366
367 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
368
369 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
370
371 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
372 - Codemux supports multiple hosts mapping to single slice
373 - Fixed bug in delegation support where tickets delivered weren't
374   being passed to sm.deliver_ticket().
375 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
376 - Codemux now configured via slice attribute (host,port)
377 - Support for multiple vserver reference images (including different archs)
378 - Mom BW emails are sent to list defined by MyPLC's config
379 - Sirius BW loans honored correctly.  Fixed.
380 - BW totals preserved for dynamic slices so as not to game the system.
381 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
382 - Configures vsys via vsys slice attribute {name: vsys, value: script}
383 - CPU reservations are now calculated via percentages instead of shares
384 - BW totals preserved for dynamic slices
385 - Closes bug where node cap sets off bw slice alarms for all slices.
386
387 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
388 - Switched to SVN.
389
390 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
391 - Initial build.