pass cacert and timeout to safexmlrpc init
[nodemanager.git] / NodeManager.spec
1 Summary: PlanetLab Node Manager
2 Name: NodeManager
3 Version: 1.1
4 Release: 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
5 License: PlanetLab
6 Group: System Environment/Daemons
7 URL: http://cvs.planet-lab.org/cvs/NodeManager
8 Source0: %{name}-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11 # Old Node Manager
12 Obsoletes: sidewinder, sidewinder-common
13
14 # vuseradd, vuserdel
15 Requires: vserver-reference
16 Requires: util-vserver
17
18 # vserver.py
19 Requires: util-vserver-python
20
21 # Signed tickets
22 Requires: gnupg
23
24 # Contact API server
25 Requires: curl
26
27 # Uses function decorators
28 Requires: python >= 2.4
29
30 %description
31 The PlanetLab Node Manager manages all aspects of PlanetLab node and
32 slice management once the node has been initialized and configured by
33 the Boot Manager. It periodically contacts its management authority
34 for configuration updates. It provides an XML-RPC API for performing
35 local operations on slices.
36
37 %prep
38 %setup -q
39
40 %build
41 %{__make} %{?_smp_mflags}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
46
47 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
48 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
49
50 %post
51 chkconfig --add nm
52 chkconfig nm on
53
54 %preun
55 # 0 = erase, 1 = upgrade
56 if [ $1 -eq 0 ] ; then
57     chkconfig nm off
58     chkconfig --del nm
59 fi
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(-,root,root,-)
66 %doc
67 %dir %{_datadir}/NodeManager
68 %{_datadir}/NodeManager/*
69 %{_bindir}/forward_api_calls
70 %{_initrddir}/nm
71 %{_sysconfdir}/logrotate.d/nm
72
73 %changelog
74 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
75 - Initial build.