Tagging module NodeManager - NodeManager-1.7-41
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.7
10 %define taglevel 41
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 BuildArch: noarch
29
30 # Old Node Manager
31 Obsoletes: sidewinder, sidewinder-common
32
33 # vuseradd, vuserdel
34 Requires: vserver-%{slicefamily}
35 Requires: util-vserver >= 0.30.208-17
36
37 # vserver.py
38 Requires: util-vserver-python
39
40 # Signed tickets
41 Requires: gnupg
42
43 # Contact API server
44 Requires: curl
45
46 # Uses function decorators
47 Requires: python >= 2.4
48
49 # sioc/plnet
50 Requires: pyplnet = 4.2
51
52 %description
53 The PlanetLab Node Manager manages all aspects of PlanetLab node and
54 slice management once the node has been initialized and configured by
55 the Boot Manager. It periodically contacts its management authority
56 for configuration updates. It provides an XML-RPC API for performing
57 local operations on slices.
58
59 %prep
60 %setup -q
61
62 %build
63 %{__make} %{?_smp_mflags}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
68
69 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
70 install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
71 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
72 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
73
74 %post
75 chkconfig --add conf_files
76 chkconfig conf_files on
77 chkconfig --add nm
78 chkconfig nm on
79 chkconfig --add fuse-pl
80 chkconfig fuse-pl on
81 if [ "$PL_BOOTCD" != "1" ] ; then
82         service nm restart
83         service fuse-pl restart
84 fi
85
86
87 %preun
88 # 0 = erase, 1 = upgrade
89 if [ $1 -eq 0 ] ; then
90     chkconfig fuse-pl off
91     chkconfig --del fuse-pl
92     chkconfig nm off
93     chkconfig --del nm
94     chkconfig conf_files off
95     chkconfig --del conf_files
96 fi
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(-,root,root,-)
103 %{_datadir}/NodeManager/
104 %{_bindir}/forward_api_calls
105 %{_initrddir}/nm
106 %{_initrddir}/conf_files
107 %{_initrddir}/fuse-pl
108 %{_sysconfdir}/logrotate.d/nm
109
110 %changelog
111 * Fri Jan 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-41
112 - Syntax fix.
113
114 * Fri Jan 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-40
115 - * Ensure RSPEC update on all account types per epoch.
116 - * BUGFIX:  HTBs were never being created when default slice's overrides weren'tset.
117
118 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-39
119 - Supports disabling of HTBs from PLC.
120
121 * Wed Dec 03 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-38
122 - Add support for plugins.
123 - Move network code to a separate module.
124 - Add AdminTicket API.
125 - Add support for sysctl slice attributes.
126
127 * Tue Sep 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-37
128 - Slices are created 1 at a time to avoid race conditions.
129
130 * Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-36
131 - Internet2 clique flow classification is now setup by NM.
132
133 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-35
134 - Clique network shares don't exist.  Removed from bwmon.
135
136 * Fri Sep 12 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-34
137 - * Fixed slice restart via xmlrpc to actually set resources
138 - * Reverted bwmon to check current min/max limits before manipulating HTB.
139
140 * Wed Sep 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-33
141 - bwmon now has enable/disable flag to control throttling.
142
143 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-32
144 - always log message when expected vserver reference is missing
145
146 * Mon Aug 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-31
147 - Emails were only being sent of high bandwidth caps were being exceeded.  Fixed.
148
149 * Thu Aug 21 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-30
150 - bwmon:  Only mention the limit the slice went over.  Not both it and the second limit.
151
152 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-29
153 - Fixed KeyError in logging.
154
155 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-28
156 - Fixed syntax error in notify function call.  Also fixed values in email message and logging.
157
158 * Mon Aug 18 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-27
159 - Fix the FUSE initscript.
160
161 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-26
162 - FUSE support.
163
164 * Wed Aug 13 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-25
165 - Removed thread created for each sliver (!!!).
166 - Slivers now spawned out of main thread.
167 - This closes the Delegation bug and closes the recent rash of NM instabilities due to queue overflows. [ticket: 384]
168
169 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-24
170 - * Update bandwidth related attributes on every NM sync.  Bwlimit will check if values have changed.
171 - * Vsys supports local_ scripts and NM will disregard them.
172
173 * Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-23
174 - After removing the fork() to the slice's uid when writing .ssh/authorized_keys, .ssh had the wrong owner/group.  Fixed.
175
176 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-22
177 - Small change.  Change uid to slice owner of authorized_keys.
178
179 * Wed Jul 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-21
180 - Slices with initscripts kept restarting.  Fixed.
181 - Also removed unnecessary fork just to write .ssh/authorized keys for every slice.
182
183 * Tue Jul 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-20
184 - * Check slice is_running() every cycle.  If not, assume damaged and restart.
185
186 * Mon Jul 07 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-19
187 - chrooting is not thread-safe.
188
189 * Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-18
190 - Log disk init AFTER acquiring disk semaphore.
191
192 * Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-17
193 - unconditionnally passes node_id and slicefamily to conf_file scripts
194 - correctly set personality a sliver creation time (not yet used by util-vserver-pl though)
195
196 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-16
197
198 - enables a vsys slice attribute to end with 'a', 'c', or 'l' characters without
199 - NM going bonkers.
200
201
202 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-15
203
204 - enable restart if vsys.conf changes also.
205
206
207 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-14
208
209 - the _restart flag for vsys was getting lost when looking across multiple
210 - vservers.  adding the 'or' should preserve any 'True' returns from
211 - createVsysDir()
212
213
214 * Tue Jun 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-13
215
216 - Time out curl when no response for 90 seconds.
217
218
219 * Fri Jun 13 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-12
220 - Patch designed to work around the vsys-fail-to-restart problem with
221 - non-existent directories, and the vuseradd-fail-to-work on directories that
222 - do exist.  
223
224 - This patch will work in conjunction with the new vsys patch.
225
226
227 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-10
228 - fixed doc build by locating locally installed DTDs at build-time
229
230 * Fri May 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-9
231 - * Reverted vserver start to forking before VServer.start to avoid defunct procs.* House keeping in various places.
232
233 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-8
234 - merge changes for myplc-docs from trunk
235
236 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-7
237
238 - Set vcVHI_CONTEXT as slice_id for fprobe-ulog to mark packets with.
239
240
241 * Wed Apr 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-5 NodeManager-1.7-6
242
243 - * Codemux will use PLC_API_HOST when PLC_PLANETFLOW_HOST isn't defined.
244
245
246 * Fri Apr 04 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-4 NodeManager-1.7-5
247 - * vdu limitting when NM restarts and slices are re-init'ed
248 - * CoDemux config parser update.  Now tolerates spaces.
249
250 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
251 - Codemux supports multiple hosts mapping to single slice
252 - Fixed bug in delegation support where tickets delivered weren't
253   being passed to sm.deliver_ticket().
254 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
255 - Codemux now configured via slice attribute (host,port)
256 - Support for multiple vserver reference images (including different archs)
257 - Mom BW emails are sent to list defined by MyPLC's config
258 - Sirius BW loans honored correctly.  Fixed.
259 - BW totals preserved for dynamic slices so as not to game the system.
260 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
261 - Configures vsys via vsys slice attribute {name: vsys, value: script}
262 - CPU reservations are now calculated via percentages instead of shares
263 - BW totals preserved for dynamic slices
264 - Closes bug where node cap sets off bw slice alarms for all slices.
265
266 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
267 - Switched to SVN.
268
269 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
270 - Initial build.