Merge branch 'master' into lxc_devel - changelog from 2.0-37
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.1
5 %define taglevel 1
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # old name
28 #Obsoletes: sidewinder, sidewinder-common
29
30 # Uses function decorators
31 Requires: python >= 2.4
32 # connecting PLC
33 Requires: python-pycurl
34 # Signed tickets
35 Requires: gnupg
36 # vserver-sliceimage or lxc-sliceimage to be added explicitly in nodeimage.pkgs
37 # we do need the slice images in any case
38 Requires: sliceimage-%{slicefamily}
39 # our interface to the vserver patch
40 #Requires: util-vserver >= 0.30.208-17
41 # vserver.py
42 #Requires: util-vserver-python > 0.3-16
43 # sioc/plnet
44 Requires: pyplnet >= 4.3
45
46 %description
47 The PlanetLab Node Manager manages all aspects of PlanetLab node and
48 slice management once the node has been initialized and configured by
49 the Boot Manager. It periodically contacts its management authority
50 for configuration updates. It provides an XML-RPC API for performing
51 local operations on slices.
52
53 %prep
54 %setup -q
55
56 %build
57 # make manages the C and Python stuff
58 %{__make} %{?_smp_mflags}
59
60 %install
61 # make manages the C and Python stuff
62 rm -rf $RPM_BUILD_ROOT
63 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
64 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
65
66 # install the sliver initscript (that triggers the slice initscript if any)
67 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
68 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
69 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
70
71 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
72 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
73 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
74
75 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
76
77 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
78 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
79 install -D -m 644 bwlimit.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/bwlimit.py
80
81 ##########
82 %post
83 # tmp - handle file renamings; old names are from 2.0-8
84 renamings="
85 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
86 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
87 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
88 /var/log/nm@/var/log/nodemanager
89 /var/log/nm.daemon@/var/log/nodemanager.daemon
90 /var/run/nm.pid@/var/run/nodemanager.pid
91 /tmp/sliver_mgr.api@/tmp/nodemanager.api
92 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
93 "
94 for renaming in $renamings; do
95   old=$(echo $renaming | cut -d@ -f1)
96   new=$(echo $renaming | cut -d@ -f2)
97   newdir=$(dirname $new)
98   if [ -e "$old" -a ! -e "$new" ] ; then
99       mkdir -p $newdir
100       mv -f $old $new
101   fi
102 done
103 #
104 chkconfig --add conf_files
105 chkconfig conf_files on
106 chkconfig --add nm
107 chkconfig nm on
108 chkconfig --add fuse-pl
109 chkconfig fuse-pl on
110 if [ "$PL_BOOTCD" != "1" ] ; then
111         service nm restart
112         service fuse-pl restart
113 fi
114
115 ##########
116 %preun
117 # 0 = erase, 1 = upgrade
118 if [ $1 -eq 0 ] ; then
119     chkconfig fuse-pl off
120     chkconfig --del fuse-pl
121     chkconfig nm off
122     chkconfig --del nm
123     chkconfig conf_files off
124     chkconfig --del conf_files
125 fi
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(-,root,root,-)
132 %{_datadir}/NodeManager/
133 %{_bindir}/forward_api_calls
134 %{_initrddir}/
135 %{_sysconfdir}/logrotate.d/nodemanager
136 /var/lib/
137 /bin/sshsh
138 %{python_sitearch}/bwlimit.py*
139
140 %changelog
141 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
142 - refactoring: isolate initscript functionality
143 - aimed at making initscript implementation with lxc straightforward
144 - show stack trace when module loading fails
145 - accounts.py renamed into account.py for consistency
146
147 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
148 - /var/log/nodemanager shows duration of mainloop
149
150 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
151 - first working draft for dealing with libvirt/lxc on f16 nodes
152 - not expected to work with mainline nodes (use 2.0 for that for now)
153
154 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
155 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
156
157 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
158 - Added memory scheduling to core scheduler
159 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
160
161 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
162 - tweaked log policy for the core scheduler
163 - curlwrapper has an optional verbose mode
164
165 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
166 - fixes for hmac and omf_control tags
167 - optional besteffort flag to core scheduler
168 - logrotate entry for /var/log/nodemanager.daemon
169 - a template for bash initscripts
170
171 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
172 - rename initscript_body into initscript_code
173 - fix generic vinit for broken bash syntax &>>
174
175 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
176 - new initscript_body slice tag, with stop and restart
177 - generic vinit script live updated
178 - new coresched module
179 - protect against non-existing vsys scripts
180 - use Config. instead of globals
181
182 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
183 - more robust reservation plugin
184
185 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
186 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
187 - reservation plugin more robust
188
189 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
190 - pass device to bwlimit
191
192 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
193 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
194
195 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
196 - Catch all exceptions for sfa plugin
197
198 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
199 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
200
201 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
202 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
203
204 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
205 - plugins/sliverauth.py improvements
206
207 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
208 - Disable sfagids plugin
209
210 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
211 - Re-tag nodemanager to include conflicted commits
212
213 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
214 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
215 - sfagids plugin deleted
216 - band-aid patch for lack of GetSliceFamily removed
217
218 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
219
220 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
221 - revert curlwrapper to former forking-curl version
222 - fixes in the omf plugin for ssh key location and node hrn
223 - set umask 0022 in tools.daemon
224
225 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
226 - configure omf-resctl for keys
227
228 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
229 - fix key generation
230
231 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
232 - name changes and fix typos
233
234 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
235 - remove config and options parameters from start function
236
237 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
238 - working version of reservable nodes
239 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
240 - dismantled the -s|--startup option (no convincing need for that)
241 - simpler and more robust init.d/nm
242 - initscript content management through replace_file_with_string
243 - sliverauth uses replace_file_with_string
244 - curlwrapper has a debug mode
245
246 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
247 - pretty-printing/normalized python code - hopefully neutral
248
249 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
250 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
251 - that triggers /etc/init.d/vinit.slice if present and executable
252 - (2) install the slice-provided initscript (as per the initscript tag) as
253 - /etc/init.d/vinit.slice
254 - (3) as a result the initscript are now triggered by rc as part of the
255 - standard vserver .. start, properly attached to the vserver,
256 - and properly killed upon vserver .. stop
257 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
258
259 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
260 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
261 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
262 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
263 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
264 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
265 - cleanup: nodemanger now is a class; however plugins are still dumb modules
266 - cleanup: does not depend on obsolete Set
267
268 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
269 - tagging before RC
270
271 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
272 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
273 - Added some precautions to the slice id-saving code
274 - Added log message to code that records the slice id
275
276 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
277 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
278 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
279 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
280
281 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
282 - fix log_call in plugins/drl.py
283
284 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
285 - protect against nodes in migrated PLC's not having the hrn tag yet
286
287 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
288 - new omf-resctl and drl plugins
289 - specialaccount optimized to overwrite authorized keys only upon changes
290 - codemux plugin has support for a new 'ip' setting
291 - mainloop to display ordered modules&plugins at all times
292
293 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
294 - modules and plugins have a priority
295 - specialaccounts appears soon in the priority chain
296 - logger.log_call logs process output, and has a timeout
297 - vuser{add,del} run through bash -x
298 - nm initscript has support for 'service nm restartverbose'
299 - logs reviewed for consistency
300 - use hashlib module instead of sha when available
301
302 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
303 - first working version of 5.0:
304 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
305 - nodefamily is 3-fold with pldistro-fcdistro-arch
306 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
307 - (in addition to the 'vref' tag that's still exposed too)
308 - logging reviewed for more convenience
309 - support for 'service nm restartdebug'
310 - make sync knows how to publish uncommitted code on a test node
311
312 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
313 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
314
315 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
316 - support for f10 and f12 in the vref slice tag
317
318 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
319 - build on fedora12
320 - uses slicename 'sfacm' instead of 'genicw'
321
322 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
323 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
324 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
325 - days ago.
326
327 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
328 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
329 - self-contained. With this change, they will be able to refer to the attributes associated with a
330 - slice.
331
332 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
333 - fix for syntax error
334
335 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
336 - -fixed problem with sioc import at the build side
337 - -bwlimit.set() now accepts the device and does not asume that it is eth0
338
339 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
340 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
341
342 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
343 - The seed for random previously was the meaning of life (i.e., 42) but
344 - that resulted in a not so random choice for the hmac.  This
345 - implementation now uses a random.seed that is based on the current
346 - time.
347
348 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
349 - Minor fix such that sliverauth.py makes a more specific call to
350 - GetSliceTags that include that specific tagname it is looking for.
351
352 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
353 - Fix bug that prevented 'OVERRIDES' for working correctly.
354
355 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
356 - Increase disk limits to 10G per sliver
357 - Sanity check slice for home directory before starting (hack)
358 - Check codemux arguments
359
360 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
361 - * Fix Delegation
362 - * Move plcapi in plugin-api GetSlivers() calls.
363 - * Persistent Authcheck and resync session when auth failure
364
365 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
366 - Disabling sliverauth module.  Not ready for deployment.
367
368 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
369 - Fixing overrides semantics.
370
371 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
372 - Generalized plugins
373 - Fixed initscript start up bug.
374
375 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
376 - * Fix delegation authentication problem
377 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
378
379 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
380 - * Rerun initscripts when slice goes from disabled to enabled.
381
382 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
383 - * Update session key when out of synch with PLC
384 - * PLCDefaults uses tagname
385
386 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
387 - log invokations of vsys
388
389 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
390
391 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
392
393 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
394 - Codemux supports multiple hosts mapping to single slice
395 - Fixed bug in delegation support where tickets delivered weren't
396   being passed to sm.deliver_ticket().
397 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
398 - Codemux now configured via slice attribute (host,port)
399 - Support for multiple vserver reference images (including different archs)
400 - Mom BW emails are sent to list defined by MyPLC's config
401 - Sirius BW loans honored correctly.  Fixed.
402 - BW totals preserved for dynamic slices so as not to game the system.
403 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
404 - Configures vsys via vsys slice attribute {name: vsys, value: script}
405 - CPU reservations are now calculated via percentages instead of shares
406 - BW totals preserved for dynamic slices
407 - Closes bug where node cap sets off bw slice alarms for all slices.
408
409 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
410 - Switched to SVN.
411
412 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
413 - Initial build.