Simple module for toggling network namespaces based on slice attributes
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.7
10 %define taglevel 37.1.trellis
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # Old Node Manager
29 Obsoletes: sidewinder, sidewinder-common
30
31 # vuseradd, vuserdel
32 # Requires: vserver-%{slicefamily}
33 Requires: util-vserver >= 0.30.208-17
34
35 # vserver.py
36 Requires: util-vserver-python
37
38 # Signed tickets
39 Requires: gnupg
40
41 # Contact API server
42 Requires: curl
43
44 # Uses function decorators
45 Requires: python >= 2.4
46
47 %description
48 The PlanetLab Node Manager manages all aspects of PlanetLab node and
49 slice management once the node has been initialized and configured by
50 the Boot Manager. It periodically contacts its management authority
51 for configuration updates. It provides an XML-RPC API for performing
52 local operations on slices.
53
54 %prep
55 %setup -q
56
57 %build
58 %{__make} %{?_smp_mflags}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
63
64 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
65 install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
66 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
67 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
68
69 %post
70 chkconfig --add conf_files
71 chkconfig conf_files on
72 chkconfig --add nm
73 chkconfig nm on
74 chkconfig --add fuse-pl
75 chkconfig fuse-pl on
76 if [ "$PL_BOOTCD" != "1" ] ; then
77         service nm restart
78         service fuse-pl restart
79 fi
80
81
82 %preun
83 # 0 = erase, 1 = upgrade
84 if [ $1 -eq 0 ] ; then
85     chkconfig fuse-pl off
86     chkconfig --del fuse-pl
87     chkconfig nm off
88     chkconfig --del nm
89     chkconfig conf_files off
90     chkconfig --del conf_files
91 fi
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(-,root,root,-)
98 %doc
99 %dir %{_datadir}/NodeManager
100 %{_datadir}/NodeManager/*
101 %{_bindir}/forward_api_calls
102 %{_initrddir}/nm
103 %{_initrddir}/conf_files
104 %{_initrddir}/fuse-pl
105 %{_sysconfdir}/logrotate.d/nm
106
107 %changelog
108 * Tue Sep 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-37
109 - Slices are created 1 at a time to avoid race conditions.
110
111 * Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-36
112 - Internet2 clique flow classification is now setup by NM.
113
114 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-35
115 - Clique network shares don't exist.  Removed from bwmon.
116
117 * Fri Sep 12 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-34
118 - * Fixed slice restart via xmlrpc to actually set resources
119 - * Reverted bwmon to check current min/max limits before manipulating HTB.
120
121 * Wed Sep 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-33
122 - bwmon now has enable/disable flag to control throttling.
123
124 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-32
125 - always log message when expected vserver reference is missing
126
127 * Mon Aug 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-31
128 - Emails were only being sent of high bandwidth caps were being exceeded.  Fixed.
129
130 * Thu Aug 21 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-30
131 - bwmon:  Only mention the limit the slice went over.  Not both it and the second limit.
132
133 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-29
134 - Fixed KeyError in logging.
135
136 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-28
137 - Fixed syntax error in notify function call.  Also fixed values in email message and logging.
138
139 * Mon Aug 18 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-27
140 - Fix the FUSE initscript.
141
142 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-26
143 - FUSE support.
144
145 * Wed Aug 13 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-25
146 - Removed thread created for each sliver (!!!).
147 - Slivers now spawned out of main thread.
148 - This closes the Delegation bug and closes the recent rash of NM instabilities due to queue overflows. [ticket: 384]
149
150 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-24
151 - * Update bandwidth related attributes on every NM sync.  Bwlimit will check if values have changed.
152 - * Vsys supports local_ scripts and NM will disregard them.
153
154 * Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-23
155 - After removing the fork() to the slice's uid when writing .ssh/authorized_keys, .ssh had the wrong owner/group.  Fixed.
156
157 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-22
158 - Small change.  Change uid to slice owner of authorized_keys.
159
160 * Wed Jul 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-21
161 - Slices with initscripts kept restarting.  Fixed.
162 - Also removed unnecessary fork just to write .ssh/authorized keys for every slice.
163
164 * Tue Jul 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-20
165 - * Check slice is_running() every cycle.  If not, assume damaged and restart.
166
167 * Mon Jul 07 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-19
168 - chrooting is not thread-safe.
169
170 * Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-18
171 - Log disk init AFTER acquiring disk semaphore.
172
173 * Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-17
174 - unconditionnally passes node_id and slicefamily to conf_file scripts
175 - correctly set personality a sliver creation time (not yet used by util-vserver-pl though)
176
177 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-16
178
179 - enables a vsys slice attribute to end with 'a', 'c', or 'l' characters without
180 - NM going bonkers.
181
182
183 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-15
184
185 - enable restart if vsys.conf changes also.
186
187
188 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-14
189
190 - the _restart flag for vsys was getting lost when looking across multiple
191 - vservers.  adding the 'or' should preserve any 'True' returns from
192 - createVsysDir()
193
194
195 * Tue Jun 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-13
196
197 - Time out curl when no response for 90 seconds.
198
199
200 * Fri Jun 13 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-12
201 - Patch designed to work around the vsys-fail-to-restart problem with
202 - non-existent directories, and the vuseradd-fail-to-work on directories that
203 - do exist.  
204
205 - This patch will work in conjunction with the new vsys patch.
206
207
208 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-10
209 - fixed doc build by locating locally installed DTDs at build-time
210
211 * Fri May 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-9
212 - * Reverted vserver start to forking before VServer.start to avoid defunct procs.* House keeping in various places.
213
214 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-8
215 - merge changes for myplc-docs from trunk
216
217 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-7
218
219 - Set vcVHI_CONTEXT as slice_id for fprobe-ulog to mark packets with.
220
221
222 * Wed Apr 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-5 NodeManager-1.7-6
223
224 - * Codemux will use PLC_API_HOST when PLC_PLANETFLOW_HOST isn't defined.
225
226
227 * Fri Apr 04 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-4 NodeManager-1.7-5
228 - * vdu limitting when NM restarts and slices are re-init'ed
229 - * CoDemux config parser update.  Now tolerates spaces.
230
231 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
232 - Codemux supports multiple hosts mapping to single slice
233 - Fixed bug in delegation support where tickets delivered weren't
234   being passed to sm.deliver_ticket().
235 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
236 - Codemux now configured via slice attribute (host,port)
237 - Support for multiple vserver reference images (including different archs)
238 - Mom BW emails are sent to list defined by MyPLC's config
239 - Sirius BW loans honored correctly.  Fixed.
240 - BW totals preserved for dynamic slices so as not to game the system.
241 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
242 - Configures vsys via vsys slice attribute {name: vsys, value: script}
243 - CPU reservations are now calculated via percentages instead of shares
244 - BW totals preserved for dynamic slices
245 - Closes bug where node cap sets off bw slice alarms for all slices.
246
247 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
248 - Switched to SVN.
249
250 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
251 - Initial build.