Capture exceptions when spawning other processes.
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.7
10 %define taglevel 45
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 BuildArch: noarch
29
30 # Old Node Manager
31 Obsoletes: sidewinder, sidewinder-common
32
33 # vuseradd, vuserdel
34 Requires: vserver-%{slicefamily}
35 Requires: util-vserver >= 0.30.208-17
36
37 # vserver.py
38 Requires: util-vserver-python
39
40 # Signed tickets
41 Requires: gnupg
42
43 # Contact API server
44 Requires: curl
45
46 # Uses function decorators
47 Requires: python >= 2.4
48
49 # sioc/plnet
50 Requires: pyplnet = 4.2
51
52 %description
53 The PlanetLab Node Manager manages all aspects of PlanetLab node and
54 slice management once the node has been initialized and configured by
55 the Boot Manager. It periodically contacts its management authority
56 for configuration updates. It provides an XML-RPC API for performing
57 local operations on slices.
58
59 %prep
60 %setup -q
61
62 %build
63 %{__make} %{?_smp_mflags}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
68
69 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
70 install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
71 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
72 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
73
74 %post
75 chkconfig --add conf_files
76 chkconfig conf_files on
77 chkconfig --add nm
78 chkconfig nm on
79 chkconfig --add fuse-pl
80 chkconfig fuse-pl on
81 if [ "$PL_BOOTCD" != "1" ] ; then
82         service nm restart
83         service fuse-pl restart
84 fi
85
86
87 %preun
88 # 0 = erase, 1 = upgrade
89 if [ $1 -eq 0 ] ; then
90     chkconfig fuse-pl off
91     chkconfig --del fuse-pl
92     chkconfig nm off
93     chkconfig --del nm
94     chkconfig conf_files off
95     chkconfig --del conf_files
96 fi
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(-,root,root,-)
103 %{_datadir}/NodeManager/
104 %{_bindir}/forward_api_calls
105 %{_initrddir}/nm
106 %{_initrddir}/conf_files
107 %{_initrddir}/fuse-pl
108 %{_sysconfdir}/logrotate.d/nm
109
110 %changelog
111 * Mon Mar 02 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-45
112 - Allowing controller accounts to use unique GIDs can overwrite the default "slice" group.  Controllers now use the "slice" GID instead of unique GIDs.
113
114 * Thu Feb 26 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-44
115 - Delegation code optimization
116 - Fixed some comments
117
118 * Mon Feb 02 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-43
119 - BUGFIX:  Extra logging was causing the main thread to die when the API was unavailable (which happens nightly due to db cleanup job).  Fixed.
120
121 * Fri Jan 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-42
122 - * Can add or remove BW limits from PLC w/o reboots.
123
124 * Fri Jan 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-41
125 - Syntax fix.
126
127 * Fri Jan 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-40
128 - * Ensure RSPEC update on all account types per epoch.
129 - * BUGFIX:  HTBs were never being created when default slice's overrides weren'tset.
130
131 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-39
132 - Supports disabling of HTBs from PLC.
133
134 * Wed Dec 03 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-38
135 - Add support for plugins.
136 - Move network code to a separate module.
137 - Add AdminTicket API.
138 - Add support for sysctl slice attributes.
139
140 * Tue Sep 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-37
141 - Slices are created 1 at a time to avoid race conditions.
142
143 * Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-36
144 - Internet2 clique flow classification is now setup by NM.
145
146 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-35
147 - Clique network shares don't exist.  Removed from bwmon.
148
149 * Fri Sep 12 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-34
150 - * Fixed slice restart via xmlrpc to actually set resources
151 - * Reverted bwmon to check current min/max limits before manipulating HTB.
152
153 * Wed Sep 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-33
154 - bwmon now has enable/disable flag to control throttling.
155
156 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-32
157 - always log message when expected vserver reference is missing
158
159 * Mon Aug 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-31
160 - Emails were only being sent of high bandwidth caps were being exceeded.  Fixed.
161
162 * Thu Aug 21 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-30
163 - bwmon:  Only mention the limit the slice went over.  Not both it and the second limit.
164
165 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-29
166 - Fixed KeyError in logging.
167
168 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-28
169 - Fixed syntax error in notify function call.  Also fixed values in email message and logging.
170
171 * Mon Aug 18 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-27
172 - Fix the FUSE initscript.
173
174 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-26
175 - FUSE support.
176
177 * Wed Aug 13 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-25
178 - Removed thread created for each sliver (!!!).
179 - Slivers now spawned out of main thread.
180 - This closes the Delegation bug and closes the recent rash of NM instabilities due to queue overflows. [ticket: 384]
181
182 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-24
183 - * Update bandwidth related attributes on every NM sync.  Bwlimit will check if values have changed.
184 - * Vsys supports local_ scripts and NM will disregard them.
185
186 * Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-23
187 - After removing the fork() to the slice's uid when writing .ssh/authorized_keys, .ssh had the wrong owner/group.  Fixed.
188
189 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-22
190 - Small change.  Change uid to slice owner of authorized_keys.
191
192 * Wed Jul 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-21
193 - Slices with initscripts kept restarting.  Fixed.
194 - Also removed unnecessary fork just to write .ssh/authorized keys for every slice.
195
196 * Tue Jul 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-20
197 - * Check slice is_running() every cycle.  If not, assume damaged and restart.
198
199 * Mon Jul 07 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-19
200 - chrooting is not thread-safe.
201
202 * Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-18
203 - Log disk init AFTER acquiring disk semaphore.
204
205 * Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-17
206 - unconditionnally passes node_id and slicefamily to conf_file scripts
207 - correctly set personality a sliver creation time (not yet used by util-vserver-pl though)
208
209 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-16
210
211 - enables a vsys slice attribute to end with 'a', 'c', or 'l' characters without
212 - NM going bonkers.
213
214
215 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-15
216
217 - enable restart if vsys.conf changes also.
218
219
220 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-14
221
222 - the _restart flag for vsys was getting lost when looking across multiple
223 - vservers.  adding the 'or' should preserve any 'True' returns from
224 - createVsysDir()
225
226
227 * Tue Jun 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-13
228
229 - Time out curl when no response for 90 seconds.
230
231
232 * Fri Jun 13 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-12
233 - Patch designed to work around the vsys-fail-to-restart problem with
234 - non-existent directories, and the vuseradd-fail-to-work on directories that
235 - do exist.  
236
237 - This patch will work in conjunction with the new vsys patch.
238
239
240 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-10
241 - fixed doc build by locating locally installed DTDs at build-time
242
243 * Fri May 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-9
244 - * Reverted vserver start to forking before VServer.start to avoid defunct procs.* House keeping in various places.
245
246 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-8
247 - merge changes for myplc-docs from trunk
248
249 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-7
250
251 - Set vcVHI_CONTEXT as slice_id for fprobe-ulog to mark packets with.
252
253
254 * Wed Apr 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-5 NodeManager-1.7-6
255
256 - * Codemux will use PLC_API_HOST when PLC_PLANETFLOW_HOST isn't defined.
257
258
259 * Fri Apr 04 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-4 NodeManager-1.7-5
260 - * vdu limitting when NM restarts and slices are re-init'ed
261 - * CoDemux config parser update.  Now tolerates spaces.
262
263 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
264 - Codemux supports multiple hosts mapping to single slice
265 - Fixed bug in delegation support where tickets delivered weren't
266   being passed to sm.deliver_ticket().
267 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
268 - Codemux now configured via slice attribute (host,port)
269 - Support for multiple vserver reference images (including different archs)
270 - Mom BW emails are sent to list defined by MyPLC's config
271 - Sirius BW loans honored correctly.  Fixed.
272 - BW totals preserved for dynamic slices so as not to game the system.
273 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
274 - Configures vsys via vsys slice attribute {name: vsys, value: script}
275 - CPU reservations are now calculated via percentages instead of shares
276 - BW totals preserved for dynamic slices
277 - Closes bug where node cap sets off bw slice alarms for all slices.
278
279 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
280 - Switched to SVN.
281
282 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
283 - Initial build.