978280db1c4303f62f99da31a4ba6db03793a833
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.8
10 %define taglevel 23
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # Old Node Manager
32 Obsoletes: sidewinder, sidewinder-common
33
34 # vuseradd, vuserdel
35 Requires: vserver-%{slicefamily}
36 Requires: util-vserver >= 0.30.208-17
37
38 # vserver.py
39 Requires: util-vserver-python > 0.3-16
40
41 # Signed tickets
42 Requires: gnupg
43
44 # Contact API server
45 Requires: curl
46
47 # Uses function decorators
48 Requires: python >= 2.4
49
50 # sioc/plnet
51 Requires: pyplnet >= 4.3
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59
60 %prep
61 %setup -q
62
63 %build
64 %{__make} %{?_smp_mflags}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
69
70 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
71 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
72 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
73
74 install -D -m 644 logrotate/nm $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
75
76 %post
77 chkconfig --add conf_files
78 chkconfig conf_files on
79 chkconfig --add nm
80 chkconfig nm on
81 chkconfig --add fuse-pl
82 chkconfig fuse-pl on
83 if [ "$PL_BOOTCD" != "1" ] ; then
84         service nm restart
85         service fuse-pl restart
86 fi
87
88
89 %preun
90 # 0 = erase, 1 = upgrade
91 if [ $1 -eq 0 ] ; then
92     chkconfig fuse-pl off
93     chkconfig --del fuse-pl
94     chkconfig nm off
95     chkconfig --del nm
96     chkconfig conf_files off
97     chkconfig --del conf_files
98 fi
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(-,root,root,-)
105 %{_datadir}/NodeManager/
106 %{_bindir}/forward_api_calls
107 %{_initrddir}/
108 %{_sysconfdir}/logrotate.d/nm
109
110 %changelog
111 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
112 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
113
114 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
115 - support for f10 and f12 in the vref slice tag
116
117 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
118 - build on fedora12
119 - uses slicename 'sfacm' instead of 'genicw'
120
121 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
122 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
123 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
124 - days ago.
125
126 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
127 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
128 - self-contained. With this change, they will be able to refer to the attributes associated with a
129 - slice.
130
131 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
132 - fix for syntax error
133
134 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
135 - -fixed problem with sioc import at the build side
136 - -bwlimit.set() now accepts the device and does not asume that it is eth0
137
138 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
139 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
140
141 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
142 - The seed for random previously was the meaning of life (i.e., 42) but
143 - that resulted in a not so random choice for the hmac.  This
144 - implementation now uses a random.seed that is based on the current
145 - time.
146
147 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
148 - Minor fix such that sliverauth.py makes a more specific call to
149 - GetSliceTags that include that specific tagname it is looking for.
150
151 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
152 - Fix bug that prevented 'OVERRIDES' for working correctly.
153
154 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
155 - Increase disk limits to 10G per sliver
156 - Sanity check slice for home directory before starting (hack)
157 - Check codemux arguments
158
159 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
160 - * Fix Delegation
161 - * Move plcapi in plugin-api GetSlivers() calls.
162 - * Persistent Authcheck and resync session when auth failure
163
164 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
165 - Disabling sliverauth module.  Not ready for deployment.
166
167 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
168 - Fixing overrides semantics.
169
170 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
171 - Generalized plugins
172 - Fixed initscript start up bug.
173
174 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
175 - * Fix delegation authentication problem
176 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
177
178 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
179 - * Rerun initscripts when slice goes from disabled to enabled.
180
181 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
182 - * Update session key when out of synch with PLC
183 - * PLCDefaults uses tagname
184
185 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
186 - log invokations of vsys
187
188 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
189
190 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
191
192 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
193 - Codemux supports multiple hosts mapping to single slice
194 - Fixed bug in delegation support where tickets delivered weren't
195   being passed to sm.deliver_ticket().
196 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
197 - Codemux now configured via slice attribute (host,port)
198 - Support for multiple vserver reference images (including different archs)
199 - Mom BW emails are sent to list defined by MyPLC's config
200 - Sirius BW loans honored correctly.  Fixed.
201 - BW totals preserved for dynamic slices so as not to game the system.
202 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
203 - Configures vsys via vsys slice attribute {name: vsys, value: script}
204 - CPU reservations are now calculated via percentages instead of shares
205 - BW totals preserved for dynamic slices
206 - Closes bug where node cap sets off bw slice alarms for all slices.
207
208 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
209 - Switched to SVN.
210
211 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
212 - Initial build.