Fixes for devices other than eth0
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.0
5 %define taglevel 26
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # old name
27 #Obsoletes: sidewinder, sidewinder-common
28
29 # Uses function decorators
30 Requires: python >= 2.4
31 # connecting PLC
32 Requires: python-pycurl
33 # Signed tickets
34 Requires: gnupg
35 # vuseradd, vuserdel
36 Requires: vserver-%{slicefamily}
37 # our interface to the vserver patch
38 Requires: util-vserver >= 0.30.208-17
39 # vserver.py
40 Requires: util-vserver-python > 0.3-16
41 # sioc/plnet
42 Requires: pyplnet >= 4.3
43
44 %description
45 The PlanetLab Node Manager manages all aspects of PlanetLab node and
46 slice management once the node has been initialized and configured by
47 the Boot Manager. It periodically contacts its management authority
48 for configuration updates. It provides an XML-RPC API for performing
49 local operations on slices.
50
51 %prep
52 %setup -q
53
54 %build
55 # make manages the C and Python stuff
56 %{__make} %{?_smp_mflags}
57
58 %install
59 # make manages the C and Python stuff
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
62
63 # install the sliver initscript (that triggers the slice initscript if any)
64 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
67
68 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
69 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
70 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
71
72 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
73
74 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132
133 %changelog
134 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
135 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
136
137 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
138 - Catch all exceptions for sfa plugin
139
140 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
141 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
142
143 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
144 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
145
146 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
147 - plugins/sliverauth.py improvements
148
149 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
150 - Disable sfagids plugin
151
152 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
153 - Re-tag nodemanager to include conflicted commits
154
155 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
156 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
157 - sfagids plugin deleted
158 - band-aid patch for lack of GetSliceFamily removed
159
160 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
161
162 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
163 - revert curlwrapper to former forking-curl version
164 - fixes in the omf plugin for ssh key location and node hrn
165 - set umask 0022 in tools.daemon
166
167 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
168 - configure omf-resctl for keys
169
170 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
171 - fix key generation
172
173 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
174 - name changes and fix typos
175
176 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
177 - remove config and options parameters from start function
178
179 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
180 - working version of reservable nodes
181 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
182 - dismantled the -s|--startup option (no convincing need for that)
183 - simpler and more robust init.d/nm
184 - initscript content management through replace_file_with_string
185 - sliverauth uses replace_file_with_string
186 - curlwrapper has a debug mode
187
188 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
189 - pretty-printing/normalized python code - hopefully neutral
190
191 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
192 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
193 - that triggers /etc/init.d/vinit.slice if present and executable
194 - (2) install the slice-provided initscript (as per the initscript tag) as
195 - /etc/init.d/vinit.slice
196 - (3) as a result the initscript are now triggered by rc as part of the
197 - standard vserver .. start, properly attached to the vserver,
198 - and properly killed upon vserver .. stop
199 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
200
201 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
202 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
203 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
204 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
205 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
206 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
207 - cleanup: nodemanger now is a class; however plugins are still dumb modules
208 - cleanup: does not depend on obsolete Set
209
210 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
211 - tagging before RC
212
213 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
214 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
215 - Added some precautions to the slice id-saving code
216 - Added log message to code that records the slice id
217
218 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
219 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
220 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
221 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
222
223 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
224 - fix log_call in plugins/drl.py
225
226 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
227 - protect against nodes in migrated PLC's not having the hrn tag yet
228
229 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
230 - new omf-resctl and drl plugins
231 - specialaccount optimized to overwrite authorized keys only upon changes
232 - codemux plugin has support for a new 'ip' setting
233 - mainloop to display ordered modules&plugins at all times
234
235 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
236 - modules and plugins have a priority
237 - specialaccounts appears soon in the priority chain
238 - logger.log_call logs process output, and has a timeout
239 - vuser{add,del} run through bash -x
240 - nm initscript has support for 'service nm restartverbose'
241 - logs reviewed for consistency
242 - use hashlib module instead of sha when available
243
244 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
245 - first working version of 5.0:
246 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
247 - nodefamily is 3-fold with pldistro-fcdistro-arch
248 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
249 - (in addition to the 'vref' tag that's still exposed too)
250 - logging reviewed for more convenience
251 - support for 'service nm restartdebug'
252 - make sync knows how to publish uncommitted code on a test node
253
254 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
255 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
256
257 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
258 - support for f10 and f12 in the vref slice tag
259
260 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
261 - build on fedora12
262 - uses slicename 'sfacm' instead of 'genicw'
263
264 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
265 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
266 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
267 - days ago.
268
269 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
270 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
271 - self-contained. With this change, they will be able to refer to the attributes associated with a
272 - slice.
273
274 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
275 - fix for syntax error
276
277 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
278 - -fixed problem with sioc import at the build side
279 - -bwlimit.set() now accepts the device and does not asume that it is eth0
280
281 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
282 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
283
284 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
285 - The seed for random previously was the meaning of life (i.e., 42) but
286 - that resulted in a not so random choice for the hmac.  This
287 - implementation now uses a random.seed that is based on the current
288 - time.
289
290 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
291 - Minor fix such that sliverauth.py makes a more specific call to
292 - GetSliceTags that include that specific tagname it is looking for.
293
294 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
295 - Fix bug that prevented 'OVERRIDES' for working correctly.
296
297 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
298 - Increase disk limits to 10G per sliver
299 - Sanity check slice for home directory before starting (hack)
300 - Check codemux arguments
301
302 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
303 - * Fix Delegation
304 - * Move plcapi in plugin-api GetSlivers() calls.
305 - * Persistent Authcheck and resync session when auth failure
306
307 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
308 - Disabling sliverauth module.  Not ready for deployment.
309
310 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
311 - Fixing overrides semantics.
312
313 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
314 - Generalized plugins
315 - Fixed initscript start up bug.
316
317 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
318 - * Fix delegation authentication problem
319 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
320
321 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
322 - * Rerun initscripts when slice goes from disabled to enabled.
323
324 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
325 - * Update session key when out of synch with PLC
326 - * PLCDefaults uses tagname
327
328 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
329 - log invokations of vsys
330
331 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
332
333 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
334
335 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
336 - Codemux supports multiple hosts mapping to single slice
337 - Fixed bug in delegation support where tickets delivered weren't
338   being passed to sm.deliver_ticket().
339 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
340 - Codemux now configured via slice attribute (host,port)
341 - Support for multiple vserver reference images (including different archs)
342 - Mom BW emails are sent to list defined by MyPLC's config
343 - Sirius BW loans honored correctly.  Fixed.
344 - BW totals preserved for dynamic slices so as not to game the system.
345 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
346 - Configures vsys via vsys slice attribute {name: vsys, value: script}
347 - CPU reservations are now calculated via percentages instead of shares
348 - BW totals preserved for dynamic slices
349 - Closes bug where node cap sets off bw slice alarms for all slices.
350
351 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
352 - Switched to SVN.
353
354 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
355 - Initial build.
356
357 %define module_current_branch 1.8