use networks key if interfaces is missing. Band-aid for short period of time as old...
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 2.0
10 %define taglevel 22
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # old name
32 #Obsoletes: sidewinder, sidewinder-common
33
34 # Uses function decorators
35 Requires: python >= 2.4
36 # connecting PLC
37 Requires: python-pycurl
38 # Signed tickets
39 Requires: gnupg
40 # vuseradd, vuserdel
41 Requires: vserver-%{slicefamily}
42 # our interface to the vserver patch
43 Requires: util-vserver >= 0.30.208-17
44 # vserver.py
45 Requires: util-vserver-python > 0.3-16
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48
49 %description
50 The PlanetLab Node Manager manages all aspects of PlanetLab node and
51 slice management once the node has been initialized and configured by
52 the Boot Manager. It periodically contacts its management authority
53 for configuration updates. It provides an XML-RPC API for performing
54 local operations on slices.
55
56 %prep
57 %setup -q
58
59 %build
60 # make manages the C and Python stuff
61 %{__make} %{?_smp_mflags}
62
63 %install
64 # make manages the C and Python stuff
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
67
68 # install the sliver initscript (that triggers the slice initscript if any)
69 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
70 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
71 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
72
73 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
74 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
75 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
76
77 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
78
79 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
80
81 ##########
82 %post
83 # tmp - handle file renamings; old names are from 2.0-8
84 renamings="
85 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
86 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
87 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
88 /var/log/nm@/var/log/nodemanager
89 /var/log/nm.daemon@/var/log/nodemanager.daemon
90 /var/run/nm.pid@/var/run/nodemanager.pid
91 /tmp/sliver_mgr.api@/tmp/nodemanager.api
92 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
93 "
94 for renaming in $renamings; do
95   old=$(echo $renaming | cut -d@ -f1)
96   new=$(echo $renaming | cut -d@ -f2)
97   newdir=$(dirname $new)
98   if [ -e "$old" -a ! -e "$new" ] ; then
99       mkdir -p $newdir
100       mv -f $old $new
101   fi
102 done
103 #
104 chkconfig --add conf_files
105 chkconfig conf_files on
106 chkconfig --add nm
107 chkconfig nm on
108 chkconfig --add fuse-pl
109 chkconfig fuse-pl on
110 if [ "$PL_BOOTCD" != "1" ] ; then
111         service nm restart
112         service fuse-pl restart
113 fi
114
115 ##########
116 %preun
117 # 0 = erase, 1 = upgrade
118 if [ $1 -eq 0 ] ; then
119     chkconfig fuse-pl off
120     chkconfig --del fuse-pl
121     chkconfig nm off
122     chkconfig --del nm
123     chkconfig conf_files off
124     chkconfig --del conf_files
125 fi
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(-,root,root,-)
132 %{_datadir}/NodeManager/
133 %{_bindir}/forward_api_calls
134 %{_initrddir}/
135 %{_sysconfdir}/logrotate.d/nodemanager
136 /var/lib/
137
138 %changelog
139 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
140 - plugins/sliverauth.py improvements
141
142 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
143 - Disable sfagids plugin
144
145 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
146 - Re-tag nodemanager to include conflicted commits
147
148 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
149 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
150 - sfagids plugin deleted
151 - band-aid patch for lack of GetSliceFamily removed
152
153 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
154
155 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
156 - revert curlwrapper to former forking-curl version
157 - fixes in the omf plugin for ssh key location and node hrn
158 - set umask 0022 in tools.daemon
159
160 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
161 - configure omf-resctl for keys
162
163 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
164 - fix key generation
165
166 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
167 - name changes and fix typos
168
169 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
170 - remove config and options parameters from start function
171
172 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
173 - working version of reservable nodes
174 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
175 - dismantled the -s|--startup option (no convincing need for that)
176 - simpler and more robust init.d/nm
177 - initscript content management through replace_file_with_string
178 - sliverauth uses replace_file_with_string
179 - curlwrapper has a debug mode
180
181 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
182 - pretty-printing/normalized python code - hopefully neutral
183
184 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
185 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
186 - that triggers /etc/init.d/vinit.slice if present and executable
187 - (2) install the slice-provided initscript (as per the initscript tag) as
188 - /etc/init.d/vinit.slice
189 - (3) as a result the initscript are now triggered by rc as part of the
190 - standard vserver .. start, properly attached to the vserver,
191 - and properly killed upon vserver .. stop
192 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
193
194 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
195 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
196 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
197 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
198 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
199 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
200 - cleanup: nodemanger now is a class; however plugins are still dumb modules
201 - cleanup: does not depend on obsolete Set
202
203 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
204 - tagging before RC
205
206 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
207 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
208 - Added some precautions to the slice id-saving code
209 - Added log message to code that records the slice id
210
211 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
212 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
213 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
214 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
215
216 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
217 - fix log_call in plugins/drl.py
218
219 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
220 - protect against nodes in migrated PLC's not having the hrn tag yet
221
222 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
223 - new omf-resctl and drl plugins
224 - specialaccount optimized to overwrite authorized keys only upon changes
225 - codemux plugin has support for a new 'ip' setting
226 - mainloop to display ordered modules&plugins at all times
227
228 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
229 - modules and plugins have a priority
230 - specialaccounts appears soon in the priority chain
231 - logger.log_call logs process output, and has a timeout
232 - vuser{add,del} run through bash -x
233 - nm initscript has support for 'service nm restartverbose'
234 - logs reviewed for consistency
235 - use hashlib module instead of sha when available
236
237 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
238 - first working version of 5.0:
239 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
240 - nodefamily is 3-fold with pldistro-fcdistro-arch
241 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
242 - (in addition to the 'vref' tag that's still exposed too)
243 - logging reviewed for more convenience
244 - support for 'service nm restartdebug'
245 - make sync knows how to publish uncommitted code on a test node
246
247 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
248 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
249
250 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
251 - support for f10 and f12 in the vref slice tag
252
253 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
254 - build on fedora12
255 - uses slicename 'sfacm' instead of 'genicw'
256
257 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
258 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
259 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
260 - days ago.
261
262 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
263 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
264 - self-contained. With this change, they will be able to refer to the attributes associated with a
265 - slice.
266
267 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
268 - fix for syntax error
269
270 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
271 - -fixed problem with sioc import at the build side
272 - -bwlimit.set() now accepts the device and does not asume that it is eth0
273
274 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
275 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
276
277 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
278 - The seed for random previously was the meaning of life (i.e., 42) but
279 - that resulted in a not so random choice for the hmac.  This
280 - implementation now uses a random.seed that is based on the current
281 - time.
282
283 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
284 - Minor fix such that sliverauth.py makes a more specific call to
285 - GetSliceTags that include that specific tagname it is looking for.
286
287 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
288 - Fix bug that prevented 'OVERRIDES' for working correctly.
289
290 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
291 - Increase disk limits to 10G per sliver
292 - Sanity check slice for home directory before starting (hack)
293 - Check codemux arguments
294
295 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
296 - * Fix Delegation
297 - * Move plcapi in plugin-api GetSlivers() calls.
298 - * Persistent Authcheck and resync session when auth failure
299
300 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
301 - Disabling sliverauth module.  Not ready for deployment.
302
303 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
304 - Fixing overrides semantics.
305
306 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
307 - Generalized plugins
308 - Fixed initscript start up bug.
309
310 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
311 - * Fix delegation authentication problem
312 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
313
314 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
315 - * Rerun initscripts when slice goes from disabled to enabled.
316
317 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
318 - * Update session key when out of synch with PLC
319 - * PLCDefaults uses tagname
320
321 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
322 - log invokations of vsys
323
324 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
325
326 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
327
328 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
329 - Codemux supports multiple hosts mapping to single slice
330 - Fixed bug in delegation support where tickets delivered weren't
331   being passed to sm.deliver_ticket().
332 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
333 - Codemux now configured via slice attribute (host,port)
334 - Support for multiple vserver reference images (including different archs)
335 - Mom BW emails are sent to list defined by MyPLC's config
336 - Sirius BW loans honored correctly.  Fixed.
337 - BW totals preserved for dynamic slices so as not to game the system.
338 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
339 - Configures vsys via vsys slice attribute {name: vsys, value: script}
340 - CPU reservations are now calculated via percentages instead of shares
341 - BW totals preserved for dynamic slices
342 - Closes bug where node cap sets off bw slice alarms for all slices.
343
344 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
345 - Switched to SVN.
346
347 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
348 - Initial build.
349
350 %define module_current_branch 1.8