Setting tag nodemanager-2.1-3
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.1
5 %define taglevel 3
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # old name
28 #Obsoletes: sidewinder, sidewinder-common
29
30 # Uses function decorators
31 Requires: python >= 2.4
32 # connecting PLC
33 Requires: python-pycurl
34 # Signed tickets
35 Requires: gnupg
36 # vserver-sliceimage or lxc-sliceimage to be added explicitly in nodeimage.pkgs
37 # we do need the slice images in any case
38 Requires: sliceimage-%{slicefamily}
39 # our interface to the vserver patch
40 #Requires: util-vserver >= 0.30.208-17
41 # vserver.py
42 #Requires: util-vserver-python > 0.3-16
43 # sioc/plnet
44 Requires: pyplnet >= 4.3
45
46 %description
47 The PlanetLab Node Manager manages all aspects of PlanetLab node and
48 slice management once the node has been initialized and configured by
49 the Boot Manager. It periodically contacts its management authority
50 for configuration updates. It provides an XML-RPC API for performing
51 local operations on slices.
52
53 %prep
54 %setup -q
55
56 %build
57 # make manages the C and Python stuff
58 %{__make} %{?_smp_mflags}
59
60 %install
61 # make manages the C and Python stuff
62 rm -rf $RPM_BUILD_ROOT
63 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
64 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
65
66 # install the sliver initscript (that triggers the slice initscript if any)
67 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
68 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
69 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
70
71 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
72 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
73 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
74
75 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
76
77 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
78 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
79 install -D -m 644 bwlimitlxc.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/bwlimitlxc.py
80
81 ##########
82 %post
83 # tmp - handle file renamings; old names are from 2.0-8
84 renamings="
85 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
86 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
87 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
88 /var/log/nm@/var/log/nodemanager
89 /var/log/nm.daemon@/var/log/nodemanager.daemon
90 /var/run/nm.pid@/var/run/nodemanager.pid
91 /tmp/sliver_mgr.api@/tmp/nodemanager.api
92 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
93 "
94 for renaming in $renamings; do
95   old=$(echo $renaming | cut -d@ -f1)
96   new=$(echo $renaming | cut -d@ -f2)
97   newdir=$(dirname $new)
98   if [ -e "$old" -a ! -e "$new" ] ; then
99       mkdir -p $newdir
100       mv -f $old $new
101   fi
102 done
103 #
104 chkconfig --add conf_files
105 chkconfig conf_files on
106 chkconfig --add nm
107 chkconfig nm on
108 chkconfig --add fuse-pl
109 chkconfig fuse-pl on
110 if [ "$PL_BOOTCD" != "1" ] ; then
111         service nm restart
112         service fuse-pl restart
113 fi
114
115 ##########
116 %preun
117 # 0 = erase, 1 = upgrade
118 if [ $1 -eq 0 ] ; then
119     chkconfig fuse-pl off
120     chkconfig --del fuse-pl
121     chkconfig nm off
122     chkconfig --del nm
123     chkconfig conf_files off
124     chkconfig --del conf_files
125 fi
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(-,root,root,-)
132 %{_datadir}/NodeManager/
133 %{_bindir}/forward_api_calls
134 %{_initrddir}/
135 %{_sysconfdir}/logrotate.d/nodemanager
136 /var/lib/
137 /bin/sshsh
138 %{python_sitearch}/bwlimitlxc.py*
139
140 %changelog
141 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
142 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
143 - purpose being to be able to run this branch on vserver nodes as well
144
145 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
146 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
147 - passes tests with lxc but won't build against vs due to conflict
148 - as bwlimit.py also ships with util-vserver-pl
149
150 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
151 - refactoring: isolate initscript functionality
152 - aimed at making initscript implementation with lxc straightforward
153 - show stack trace when module loading fails
154 - accounts.py renamed into account.py for consistency
155
156 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
157 - /var/log/nodemanager shows duration of mainloop
158
159 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
160 - first working draft for dealing with libvirt/lxc on f16 nodes
161 - not expected to work with mainline nodes (use 2.0 for that for now)
162
163 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
164 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
165
166 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
167 - Added memory scheduling to core scheduler
168 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
169
170 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
171 - tweaked log policy for the core scheduler
172 - curlwrapper has an optional verbose mode
173
174 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
175 - fixes for hmac and omf_control tags
176 - optional besteffort flag to core scheduler
177 - logrotate entry for /var/log/nodemanager.daemon
178 - a template for bash initscripts
179
180 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
181 - rename initscript_body into initscript_code
182 - fix generic vinit for broken bash syntax &>>
183
184 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
185 - new initscript_body slice tag, with stop and restart
186 - generic vinit script live updated
187 - new coresched module
188 - protect against non-existing vsys scripts
189 - use Config. instead of globals
190
191 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
192 - more robust reservation plugin
193
194 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
195 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
196 - reservation plugin more robust
197
198 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
199 - pass device to bwlimit
200
201 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
202 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
203
204 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
205 - Catch all exceptions for sfa plugin
206
207 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
208 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
209
210 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
211 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
212
213 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
214 - plugins/sliverauth.py improvements
215
216 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
217 - Disable sfagids plugin
218
219 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
220 - Re-tag nodemanager to include conflicted commits
221
222 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
223 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
224 - sfagids plugin deleted
225 - band-aid patch for lack of GetSliceFamily removed
226
227 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
228
229 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
230 - revert curlwrapper to former forking-curl version
231 - fixes in the omf plugin for ssh key location and node hrn
232 - set umask 0022 in tools.daemon
233
234 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
235 - configure omf-resctl for keys
236
237 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
238 - fix key generation
239
240 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
241 - name changes and fix typos
242
243 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
244 - remove config and options parameters from start function
245
246 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
247 - working version of reservable nodes
248 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
249 - dismantled the -s|--startup option (no convincing need for that)
250 - simpler and more robust init.d/nm
251 - initscript content management through replace_file_with_string
252 - sliverauth uses replace_file_with_string
253 - curlwrapper has a debug mode
254
255 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
256 - pretty-printing/normalized python code - hopefully neutral
257
258 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
259 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
260 - that triggers /etc/init.d/vinit.slice if present and executable
261 - (2) install the slice-provided initscript (as per the initscript tag) as
262 - /etc/init.d/vinit.slice
263 - (3) as a result the initscript are now triggered by rc as part of the
264 - standard vserver .. start, properly attached to the vserver,
265 - and properly killed upon vserver .. stop
266 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
267
268 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
269 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
270 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
271 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
272 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
273 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
274 - cleanup: nodemanger now is a class; however plugins are still dumb modules
275 - cleanup: does not depend on obsolete Set
276
277 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
278 - tagging before RC
279
280 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
281 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
282 - Added some precautions to the slice id-saving code
283 - Added log message to code that records the slice id
284
285 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
286 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
287 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
288 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
289
290 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
291 - fix log_call in plugins/drl.py
292
293 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
294 - protect against nodes in migrated PLC's not having the hrn tag yet
295
296 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
297 - new omf-resctl and drl plugins
298 - specialaccount optimized to overwrite authorized keys only upon changes
299 - codemux plugin has support for a new 'ip' setting
300 - mainloop to display ordered modules&plugins at all times
301
302 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
303 - modules and plugins have a priority
304 - specialaccounts appears soon in the priority chain
305 - logger.log_call logs process output, and has a timeout
306 - vuser{add,del} run through bash -x
307 - nm initscript has support for 'service nm restartverbose'
308 - logs reviewed for consistency
309 - use hashlib module instead of sha when available
310
311 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
312 - first working version of 5.0:
313 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
314 - nodefamily is 3-fold with pldistro-fcdistro-arch
315 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
316 - (in addition to the 'vref' tag that's still exposed too)
317 - logging reviewed for more convenience
318 - support for 'service nm restartdebug'
319 - make sync knows how to publish uncommitted code on a test node
320
321 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
322 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
323
324 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
325 - support for f10 and f12 in the vref slice tag
326
327 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
328 - build on fedora12
329 - uses slicename 'sfacm' instead of 'genicw'
330
331 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
332 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
333 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
334 - days ago.
335
336 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
337 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
338 - self-contained. With this change, they will be able to refer to the attributes associated with a
339 - slice.
340
341 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
342 - fix for syntax error
343
344 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
345 - -fixed problem with sioc import at the build side
346 - -bwlimit.set() now accepts the device and does not asume that it is eth0
347
348 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
349 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
350
351 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
352 - The seed for random previously was the meaning of life (i.e., 42) but
353 - that resulted in a not so random choice for the hmac.  This
354 - implementation now uses a random.seed that is based on the current
355 - time.
356
357 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
358 - Minor fix such that sliverauth.py makes a more specific call to
359 - GetSliceTags that include that specific tagname it is looking for.
360
361 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
362 - Fix bug that prevented 'OVERRIDES' for working correctly.
363
364 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
365 - Increase disk limits to 10G per sliver
366 - Sanity check slice for home directory before starting (hack)
367 - Check codemux arguments
368
369 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
370 - * Fix Delegation
371 - * Move plcapi in plugin-api GetSlivers() calls.
372 - * Persistent Authcheck and resync session when auth failure
373
374 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
375 - Disabling sliverauth module.  Not ready for deployment.
376
377 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
378 - Fixing overrides semantics.
379
380 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
381 - Generalized plugins
382 - Fixed initscript start up bug.
383
384 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
385 - * Fix delegation authentication problem
386 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
387
388 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
389 - * Rerun initscripts when slice goes from disabled to enabled.
390
391 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
392 - * Update session key when out of synch with PLC
393 - * PLCDefaults uses tagname
394
395 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
396 - log invokations of vsys
397
398 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
399
400 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
401
402 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
403 - Codemux supports multiple hosts mapping to single slice
404 - Fixed bug in delegation support where tickets delivered weren't
405   being passed to sm.deliver_ticket().
406 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
407 - Codemux now configured via slice attribute (host,port)
408 - Support for multiple vserver reference images (including different archs)
409 - Mom BW emails are sent to list defined by MyPLC's config
410 - Sirius BW loans honored correctly.  Fixed.
411 - BW totals preserved for dynamic slices so as not to game the system.
412 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
413 - Configures vsys via vsys slice attribute {name: vsys, value: script}
414 - CPU reservations are now calculated via percentages instead of shares
415 - BW totals preserved for dynamic slices
416 - Closes bug where node cap sets off bw slice alarms for all slices.
417
418 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
419 - Switched to SVN.
420
421 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
422 - Initial build.