Fix the 'sshsh' install command.
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.0
5 %define taglevel 33
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # old name
27 #Obsoletes: sidewinder, sidewinder-common
28
29 # Uses function decorators
30 Requires: python >= 2.4
31 # connecting PLC
32 Requires: python-pycurl
33 # Signed tickets
34 Requires: gnupg
35 # vuseradd, vuserdel
36 Requires: vserver-%{slicefamily}
37 # our interface to the vserver patch
38 Requires: util-vserver >= 0.30.208-17
39 # vserver.py
40 Requires: util-vserver-python > 0.3-16
41 # sioc/plnet
42 Requires: pyplnet >= 4.3
43
44 %description
45 The PlanetLab Node Manager manages all aspects of PlanetLab node and
46 slice management once the node has been initialized and configured by
47 the Boot Manager. It periodically contacts its management authority
48 for configuration updates. It provides an XML-RPC API for performing
49 local operations on slices.
50
51 %prep
52 %setup -q
53
54 %build
55 # make manages the C and Python stuff
56 %{__make} %{?_smp_mflags}
57
58 %install
59 # make manages the C and Python stuff
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
62
63 # install the sliver initscript (that triggers the slice initscript if any)
64 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
67
68 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
69 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
70 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
71
72 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
73
74 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
75 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
76
77 ##########
78 %post
79 # tmp - handle file renamings; old names are from 2.0-8
80 renamings="
81 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
82 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
83 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
84 /var/log/nm@/var/log/nodemanager
85 /var/log/nm.daemon@/var/log/nodemanager.daemon
86 /var/run/nm.pid@/var/run/nodemanager.pid
87 /tmp/sliver_mgr.api@/tmp/nodemanager.api
88 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
89 "
90 for renaming in $renamings; do
91   old=$(echo $renaming | cut -d@ -f1)
92   new=$(echo $renaming | cut -d@ -f2)
93   newdir=$(dirname $new)
94   if [ -e "$old" -a ! -e "$new" ] ; then
95       mkdir -p $newdir
96       mv -f $old $new
97   fi
98 done
99 #
100 chkconfig --add conf_files
101 chkconfig conf_files on
102 chkconfig --add nm
103 chkconfig nm on
104 chkconfig --add fuse-pl
105 chkconfig fuse-pl on
106 if [ "$PL_BOOTCD" != "1" ] ; then
107         service nm restart
108         service fuse-pl restart
109 fi
110
111 ##########
112 %preun
113 # 0 = erase, 1 = upgrade
114 if [ $1 -eq 0 ] ; then
115     chkconfig fuse-pl off
116     chkconfig --del fuse-pl
117     chkconfig nm off
118     chkconfig --del nm
119     chkconfig conf_files off
120     chkconfig --del conf_files
121 fi
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(-,root,root,-)
128 %{_datadir}/NodeManager/
129 %{_bindir}/forward_api_calls
130 %{_initrddir}/
131 %{_sysconfdir}/logrotate.d/nodemanager
132 /var/lib/
133 /bin/sshsh
134
135 %changelog
136 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
137 - tweaked log policy for the core scheduler
138 - curlwrapper has an optional verbose mode
139
140 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
141 - fixes for hmac and omf_control tags
142 - optional besteffort flag to core scheduler
143 - logrotate entry for /var/log/nodemanager.daemon
144 - a template for bash initscripts
145
146 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
147 - rename initscript_body into initscript_code
148 - fix generic vinit for broken bash syntax &>>
149
150 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
151 - new initscript_body slice tag, with stop and restart
152 - generic vinit script live updated
153 - new coresched module
154 - protect against non-existing vsys scripts
155 - use Config. instead of globals
156
157 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
158 - more robust reservation plugin
159
160 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
161 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
162 - reservation plugin more robust
163
164 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
165 - pass device to bwlimit
166
167 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
168 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
169
170 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
171 - Catch all exceptions for sfa plugin
172
173 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
174 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
175
176 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
177 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
178
179 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
180 - plugins/sliverauth.py improvements
181
182 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
183 - Disable sfagids plugin
184
185 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
186 - Re-tag nodemanager to include conflicted commits
187
188 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
189 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
190 - sfagids plugin deleted
191 - band-aid patch for lack of GetSliceFamily removed
192
193 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
194
195 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
196 - revert curlwrapper to former forking-curl version
197 - fixes in the omf plugin for ssh key location and node hrn
198 - set umask 0022 in tools.daemon
199
200 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
201 - configure omf-resctl for keys
202
203 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
204 - fix key generation
205
206 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
207 - name changes and fix typos
208
209 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
210 - remove config and options parameters from start function
211
212 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
213 - working version of reservable nodes
214 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
215 - dismantled the -s|--startup option (no convincing need for that)
216 - simpler and more robust init.d/nm
217 - initscript content management through replace_file_with_string
218 - sliverauth uses replace_file_with_string
219 - curlwrapper has a debug mode
220
221 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
222 - pretty-printing/normalized python code - hopefully neutral
223
224 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
225 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
226 - that triggers /etc/init.d/vinit.slice if present and executable
227 - (2) install the slice-provided initscript (as per the initscript tag) as
228 - /etc/init.d/vinit.slice
229 - (3) as a result the initscript are now triggered by rc as part of the
230 - standard vserver .. start, properly attached to the vserver,
231 - and properly killed upon vserver .. stop
232 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
233
234 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
235 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
236 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
237 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
238 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
239 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
240 - cleanup: nodemanger now is a class; however plugins are still dumb modules
241 - cleanup: does not depend on obsolete Set
242
243 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
244 - tagging before RC
245
246 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
247 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
248 - Added some precautions to the slice id-saving code
249 - Added log message to code that records the slice id
250
251 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
252 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
253 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
254 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
255
256 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
257 - fix log_call in plugins/drl.py
258
259 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
260 - protect against nodes in migrated PLC's not having the hrn tag yet
261
262 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
263 - new omf-resctl and drl plugins
264 - specialaccount optimized to overwrite authorized keys only upon changes
265 - codemux plugin has support for a new 'ip' setting
266 - mainloop to display ordered modules&plugins at all times
267
268 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
269 - modules and plugins have a priority
270 - specialaccounts appears soon in the priority chain
271 - logger.log_call logs process output, and has a timeout
272 - vuser{add,del} run through bash -x
273 - nm initscript has support for 'service nm restartverbose'
274 - logs reviewed for consistency
275 - use hashlib module instead of sha when available
276
277 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
278 - first working version of 5.0:
279 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
280 - nodefamily is 3-fold with pldistro-fcdistro-arch
281 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
282 - (in addition to the 'vref' tag that's still exposed too)
283 - logging reviewed for more convenience
284 - support for 'service nm restartdebug'
285 - make sync knows how to publish uncommitted code on a test node
286
287 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
288 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
289
290 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
291 - support for f10 and f12 in the vref slice tag
292
293 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
294 - build on fedora12
295 - uses slicename 'sfacm' instead of 'genicw'
296
297 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
298 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
299 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
300 - days ago.
301
302 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
303 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
304 - self-contained. With this change, they will be able to refer to the attributes associated with a
305 - slice.
306
307 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
308 - fix for syntax error
309
310 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
311 - -fixed problem with sioc import at the build side
312 - -bwlimit.set() now accepts the device and does not asume that it is eth0
313
314 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
315 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
316
317 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
318 - The seed for random previously was the meaning of life (i.e., 42) but
319 - that resulted in a not so random choice for the hmac.  This
320 - implementation now uses a random.seed that is based on the current
321 - time.
322
323 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
324 - Minor fix such that sliverauth.py makes a more specific call to
325 - GetSliceTags that include that specific tagname it is looking for.
326
327 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
328 - Fix bug that prevented 'OVERRIDES' for working correctly.
329
330 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
331 - Increase disk limits to 10G per sliver
332 - Sanity check slice for home directory before starting (hack)
333 - Check codemux arguments
334
335 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
336 - * Fix Delegation
337 - * Move plcapi in plugin-api GetSlivers() calls.
338 - * Persistent Authcheck and resync session when auth failure
339
340 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
341 - Disabling sliverauth module.  Not ready for deployment.
342
343 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
344 - Fixing overrides semantics.
345
346 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
347 - Generalized plugins
348 - Fixed initscript start up bug.
349
350 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
351 - * Fix delegation authentication problem
352 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
353
354 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
355 - * Rerun initscripts when slice goes from disabled to enabled.
356
357 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
358 - * Update session key when out of synch with PLC
359 - * PLCDefaults uses tagname
360
361 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
362 - log invokations of vsys
363
364 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
365
366 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
367
368 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
369 - Codemux supports multiple hosts mapping to single slice
370 - Fixed bug in delegation support where tickets delivered weren't
371   being passed to sm.deliver_ticket().
372 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
373 - Codemux now configured via slice attribute (host,port)
374 - Support for multiple vserver reference images (including different archs)
375 - Mom BW emails are sent to list defined by MyPLC's config
376 - Sirius BW loans honored correctly.  Fixed.
377 - BW totals preserved for dynamic slices so as not to game the system.
378 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
379 - Configures vsys via vsys slice attribute {name: vsys, value: script}
380 - CPU reservations are now calculated via percentages instead of shares
381 - BW totals preserved for dynamic slices
382 - Closes bug where node cap sets off bw slice alarms for all slices.
383
384 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
385 - Switched to SVN.
386
387 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
388 - Initial build.
389
390 %define module_current_branch 1.8