look for the xml template under 2 names so the lxc-reference packaging
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.0
5 %define taglevel 34
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # old name
28 #Obsoletes: sidewinder, sidewinder-common
29
30 # Uses function decorators
31 Requires: python >= 2.4
32 # connecting PLC
33 Requires: python-pycurl
34 # Signed tickets
35 Requires: gnupg
36 # vuseradd, vuserdel
37 #Requires: vserver-%{slicefamily}
38 # our interface to the vserver patch
39 #Requires: util-vserver >= 0.30.208-17
40 # vserver.py
41 #Requires: util-vserver-python > 0.3-16
42 # sioc/plnet
43 Requires: pyplnet >= 4.3
44
45 %description
46 The PlanetLab Node Manager manages all aspects of PlanetLab node and
47 slice management once the node has been initialized and configured by
48 the Boot Manager. It periodically contacts its management authority
49 for configuration updates. It provides an XML-RPC API for performing
50 local operations on slices.
51
52 %prep
53 %setup -q
54
55 %build
56 # make manages the C and Python stuff
57 %{__make} %{?_smp_mflags}
58
59 %install
60 # make manages the C and Python stuff
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
63 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
64
65 # install the sliver initscript (that triggers the slice initscript if any)
66 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
67 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
68 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
69
70 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
71 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
72 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
73
74 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
75
76 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
77 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
78 install -D -m 644 bwlimit.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/bwlimit.py
79
80 ##########
81 %post
82 # tmp - handle file renamings; old names are from 2.0-8
83 renamings="
84 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
85 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
86 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
87 /var/log/nm@/var/log/nodemanager
88 /var/log/nm.daemon@/var/log/nodemanager.daemon
89 /var/run/nm.pid@/var/run/nodemanager.pid
90 /tmp/sliver_mgr.api@/tmp/nodemanager.api
91 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
92 "
93 for renaming in $renamings; do
94   old=$(echo $renaming | cut -d@ -f1)
95   new=$(echo $renaming | cut -d@ -f2)
96   newdir=$(dirname $new)
97   if [ -e "$old" -a ! -e "$new" ] ; then
98       mkdir -p $newdir
99       mv -f $old $new
100   fi
101 done
102 #
103 chkconfig --add conf_files
104 chkconfig conf_files on
105 chkconfig --add nm
106 chkconfig nm on
107 chkconfig --add fuse-pl
108 chkconfig fuse-pl on
109 if [ "$PL_BOOTCD" != "1" ] ; then
110         service nm restart
111         service fuse-pl restart
112 fi
113
114 ##########
115 %preun
116 # 0 = erase, 1 = upgrade
117 if [ $1 -eq 0 ] ; then
118     chkconfig fuse-pl off
119     chkconfig --del fuse-pl
120     chkconfig nm off
121     chkconfig --del nm
122     chkconfig conf_files off
123     chkconfig --del conf_files
124 fi
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(-,root,root,-)
131 %{_datadir}/NodeManager/
132 %{_bindir}/forward_api_calls
133 %{_initrddir}/
134 %{_sysconfdir}/logrotate.d/nodemanager
135 /var/lib/
136 /bin/sshsh
137 %{python_sitearch}/bwlimit.py*
138
139 %changelog
140 * Fri Jan 13 2012 Marco Yuen <marcoy@cs.princeton.edu> - nodemanager-2.0-34
141 - Install bwlimit.py to the python site directory.
142
143 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
144 - Added memory scheduling to core scheduler
145 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
146
147 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
148 - tweaked log policy for the core scheduler
149 - curlwrapper has an optional verbose mode
150
151 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
152 - fixes for hmac and omf_control tags
153 - optional besteffort flag to core scheduler
154 - logrotate entry for /var/log/nodemanager.daemon
155 - a template for bash initscripts
156
157 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
158 - rename initscript_body into initscript_code
159 - fix generic vinit for broken bash syntax &>>
160
161 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
162 - new initscript_body slice tag, with stop and restart
163 - generic vinit script live updated
164 - new coresched module
165 - protect against non-existing vsys scripts
166 - use Config. instead of globals
167
168 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
169 - more robust reservation plugin
170
171 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
172 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
173 - reservation plugin more robust
174
175 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
176 - pass device to bwlimit
177
178 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
179 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
180
181 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
182 - Catch all exceptions for sfa plugin
183
184 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
185 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
186
187 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
188 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
189
190 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
191 - plugins/sliverauth.py improvements
192
193 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
194 - Disable sfagids plugin
195
196 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
197 - Re-tag nodemanager to include conflicted commits
198
199 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
200 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
201 - sfagids plugin deleted
202 - band-aid patch for lack of GetSliceFamily removed
203
204 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
205
206 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
207 - revert curlwrapper to former forking-curl version
208 - fixes in the omf plugin for ssh key location and node hrn
209 - set umask 0022 in tools.daemon
210
211 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
212 - configure omf-resctl for keys
213
214 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
215 - fix key generation
216
217 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
218 - name changes and fix typos
219
220 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
221 - remove config and options parameters from start function
222
223 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
224 - working version of reservable nodes
225 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
226 - dismantled the -s|--startup option (no convincing need for that)
227 - simpler and more robust init.d/nm
228 - initscript content management through replace_file_with_string
229 - sliverauth uses replace_file_with_string
230 - curlwrapper has a debug mode
231
232 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
233 - pretty-printing/normalized python code - hopefully neutral
234
235 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
236 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
237 - that triggers /etc/init.d/vinit.slice if present and executable
238 - (2) install the slice-provided initscript (as per the initscript tag) as
239 - /etc/init.d/vinit.slice
240 - (3) as a result the initscript are now triggered by rc as part of the
241 - standard vserver .. start, properly attached to the vserver,
242 - and properly killed upon vserver .. stop
243 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
244
245 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
246 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
247 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
248 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
249 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
250 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
251 - cleanup: nodemanger now is a class; however plugins are still dumb modules
252 - cleanup: does not depend on obsolete Set
253
254 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
255 - tagging before RC
256
257 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
258 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
259 - Added some precautions to the slice id-saving code
260 - Added log message to code that records the slice id
261
262 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
263 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
264 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
265 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
266
267 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
268 - fix log_call in plugins/drl.py
269
270 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
271 - protect against nodes in migrated PLC's not having the hrn tag yet
272
273 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
274 - new omf-resctl and drl plugins
275 - specialaccount optimized to overwrite authorized keys only upon changes
276 - codemux plugin has support for a new 'ip' setting
277 - mainloop to display ordered modules&plugins at all times
278
279 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
280 - modules and plugins have a priority
281 - specialaccounts appears soon in the priority chain
282 - logger.log_call logs process output, and has a timeout
283 - vuser{add,del} run through bash -x
284 - nm initscript has support for 'service nm restartverbose'
285 - logs reviewed for consistency
286 - use hashlib module instead of sha when available
287
288 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
289 - first working version of 5.0:
290 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
291 - nodefamily is 3-fold with pldistro-fcdistro-arch
292 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
293 - (in addition to the 'vref' tag that's still exposed too)
294 - logging reviewed for more convenience
295 - support for 'service nm restartdebug'
296 - make sync knows how to publish uncommitted code on a test node
297
298 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
299 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
300
301 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
302 - support for f10 and f12 in the vref slice tag
303
304 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
305 - build on fedora12
306 - uses slicename 'sfacm' instead of 'genicw'
307
308 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
309 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
310 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
311 - days ago.
312
313 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
314 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
315 - self-contained. With this change, they will be able to refer to the attributes associated with a
316 - slice.
317
318 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
319 - fix for syntax error
320
321 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
322 - -fixed problem with sioc import at the build side
323 - -bwlimit.set() now accepts the device and does not asume that it is eth0
324
325 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
326 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
327
328 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
329 - The seed for random previously was the meaning of life (i.e., 42) but
330 - that resulted in a not so random choice for the hmac.  This
331 - implementation now uses a random.seed that is based on the current
332 - time.
333
334 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
335 - Minor fix such that sliverauth.py makes a more specific call to
336 - GetSliceTags that include that specific tagname it is looking for.
337
338 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
339 - Fix bug that prevented 'OVERRIDES' for working correctly.
340
341 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
342 - Increase disk limits to 10G per sliver
343 - Sanity check slice for home directory before starting (hack)
344 - Check codemux arguments
345
346 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
347 - * Fix Delegation
348 - * Move plcapi in plugin-api GetSlivers() calls.
349 - * Persistent Authcheck and resync session when auth failure
350
351 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
352 - Disabling sliverauth module.  Not ready for deployment.
353
354 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
355 - Fixing overrides semantics.
356
357 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
358 - Generalized plugins
359 - Fixed initscript start up bug.
360
361 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
362 - * Fix delegation authentication problem
363 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
364
365 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
366 - * Rerun initscripts when slice goes from disabled to enabled.
367
368 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
369 - * Update session key when out of synch with PLC
370 - * PLCDefaults uses tagname
371
372 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
373 - log invokations of vsys
374
375 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
376
377 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
378
379 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
380 - Codemux supports multiple hosts mapping to single slice
381 - Fixed bug in delegation support where tickets delivered weren't
382   being passed to sm.deliver_ticket().
383 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
384 - Codemux now configured via slice attribute (host,port)
385 - Support for multiple vserver reference images (including different archs)
386 - Mom BW emails are sent to list defined by MyPLC's config
387 - Sirius BW loans honored correctly.  Fixed.
388 - BW totals preserved for dynamic slices so as not to game the system.
389 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
390 - Configures vsys via vsys slice attribute {name: vsys, value: script}
391 - CPU reservations are now calculated via percentages instead of shares
392 - BW totals preserved for dynamic slices
393 - Closes bug where node cap sets off bw slice alarms for all slices.
394
395 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
396 - Switched to SVN.
397
398 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
399 - Initial build.
400
401 %define module_current_branch 1.8