Merge branch 'master' into lxc_devel
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.1
5 %define taglevel 1
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # old name
28 #Obsoletes: sidewinder, sidewinder-common
29
30 # Uses function decorators
31 Requires: python >= 2.4
32 # connecting PLC
33 Requires: python-pycurl
34 # Signed tickets
35 Requires: gnupg
36 # vserver-sliceimage or lxc-sliceimage to be added explicitly in nodeimage.pkgs
37 # we do need the slice images in any case
38 Requires: sliceimage-%{slicefamily}
39 # our interface to the vserver patch
40 #Requires: util-vserver >= 0.30.208-17
41 # vserver.py
42 #Requires: util-vserver-python > 0.3-16
43 # sioc/plnet
44 Requires: pyplnet >= 4.3
45
46 %description
47 The PlanetLab Node Manager manages all aspects of PlanetLab node and
48 slice management once the node has been initialized and configured by
49 the Boot Manager. It periodically contacts its management authority
50 for configuration updates. It provides an XML-RPC API for performing
51 local operations on slices.
52
53 %prep
54 %setup -q
55
56 %build
57 # make manages the C and Python stuff
58 %{__make} %{?_smp_mflags}
59
60 %install
61 # make manages the C and Python stuff
62 rm -rf $RPM_BUILD_ROOT
63 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
64 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
65
66 # install the sliver initscript (that triggers the slice initscript if any)
67 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
68 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
69 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
70
71 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
72 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
73 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
74
75 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
76
77 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
78 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
79 install -D -m 644 bwlimit.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/bwlimit.py
80
81 ##########
82 %post
83 # tmp - handle file renamings; old names are from 2.0-8
84 renamings="
85 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
86 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
87 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
88 /var/log/nm@/var/log/nodemanager
89 /var/log/nm.daemon@/var/log/nodemanager.daemon
90 /var/run/nm.pid@/var/run/nodemanager.pid
91 /tmp/sliver_mgr.api@/tmp/nodemanager.api
92 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
93 "
94 for renaming in $renamings; do
95   old=$(echo $renaming | cut -d@ -f1)
96   new=$(echo $renaming | cut -d@ -f2)
97   newdir=$(dirname $new)
98   if [ -e "$old" -a ! -e "$new" ] ; then
99       mkdir -p $newdir
100       mv -f $old $new
101   fi
102 done
103 #
104 chkconfig --add conf_files
105 chkconfig conf_files on
106 chkconfig --add nm
107 chkconfig nm on
108 chkconfig --add fuse-pl
109 chkconfig fuse-pl on
110 if [ "$PL_BOOTCD" != "1" ] ; then
111         service nm restart
112         service fuse-pl restart
113 fi
114
115 ##########
116 %preun
117 # 0 = erase, 1 = upgrade
118 if [ $1 -eq 0 ] ; then
119     chkconfig fuse-pl off
120     chkconfig --del fuse-pl
121     chkconfig nm off
122     chkconfig --del nm
123     chkconfig conf_files off
124     chkconfig --del conf_files
125 fi
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(-,root,root,-)
132 %{_datadir}/NodeManager/
133 %{_bindir}/forward_api_calls
134 %{_initrddir}/
135 %{_sysconfdir}/logrotate.d/nodemanager
136 /var/lib/
137 /bin/sshsh
138 %{python_sitearch}/bwlimit.py*
139
140 %changelog
141 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
142 - first working draft for dealing with libvirt/lxc on f16 nodes
143 - not expected to work with mainline nodes (use 2.0 for that for now)
144
145 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
146 - /var/log/nodemanager shows duration of mainloop
147
148 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
149 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
150
151 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
152 - Added memory scheduling to core scheduler
153 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
154
155 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
156 - tweaked log policy for the core scheduler
157 - curlwrapper has an optional verbose mode
158
159 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
160 - fixes for hmac and omf_control tags
161 - optional besteffort flag to core scheduler
162 - logrotate entry for /var/log/nodemanager.daemon
163 - a template for bash initscripts
164
165 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
166 - rename initscript_body into initscript_code
167 - fix generic vinit for broken bash syntax &>>
168
169 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
170 - new initscript_body slice tag, with stop and restart
171 - generic vinit script live updated
172 - new coresched module
173 - protect against non-existing vsys scripts
174 - use Config. instead of globals
175
176 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
177 - more robust reservation plugin
178
179 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
180 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
181 - reservation plugin more robust
182
183 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
184 - pass device to bwlimit
185
186 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
187 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
188
189 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
190 - Catch all exceptions for sfa plugin
191
192 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
193 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
194
195 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
196 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
197
198 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
199 - plugins/sliverauth.py improvements
200
201 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
202 - Disable sfagids plugin
203
204 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
205 - Re-tag nodemanager to include conflicted commits
206
207 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
208 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
209 - sfagids plugin deleted
210 - band-aid patch for lack of GetSliceFamily removed
211
212 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
213
214 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
215 - revert curlwrapper to former forking-curl version
216 - fixes in the omf plugin for ssh key location and node hrn
217 - set umask 0022 in tools.daemon
218
219 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
220 - configure omf-resctl for keys
221
222 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
223 - fix key generation
224
225 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
226 - name changes and fix typos
227
228 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
229 - remove config and options parameters from start function
230
231 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
232 - working version of reservable nodes
233 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
234 - dismantled the -s|--startup option (no convincing need for that)
235 - simpler and more robust init.d/nm
236 - initscript content management through replace_file_with_string
237 - sliverauth uses replace_file_with_string
238 - curlwrapper has a debug mode
239
240 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
241 - pretty-printing/normalized python code - hopefully neutral
242
243 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
244 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
245 - that triggers /etc/init.d/vinit.slice if present and executable
246 - (2) install the slice-provided initscript (as per the initscript tag) as
247 - /etc/init.d/vinit.slice
248 - (3) as a result the initscript are now triggered by rc as part of the
249 - standard vserver .. start, properly attached to the vserver,
250 - and properly killed upon vserver .. stop
251 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
252
253 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
254 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
255 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
256 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
257 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
258 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
259 - cleanup: nodemanger now is a class; however plugins are still dumb modules
260 - cleanup: does not depend on obsolete Set
261
262 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
263 - tagging before RC
264
265 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
266 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
267 - Added some precautions to the slice id-saving code
268 - Added log message to code that records the slice id
269
270 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
271 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
272 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
273 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
274
275 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
276 - fix log_call in plugins/drl.py
277
278 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
279 - protect against nodes in migrated PLC's not having the hrn tag yet
280
281 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
282 - new omf-resctl and drl plugins
283 - specialaccount optimized to overwrite authorized keys only upon changes
284 - codemux plugin has support for a new 'ip' setting
285 - mainloop to display ordered modules&plugins at all times
286
287 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
288 - modules and plugins have a priority
289 - specialaccounts appears soon in the priority chain
290 - logger.log_call logs process output, and has a timeout
291 - vuser{add,del} run through bash -x
292 - nm initscript has support for 'service nm restartverbose'
293 - logs reviewed for consistency
294 - use hashlib module instead of sha when available
295
296 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
297 - first working version of 5.0:
298 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
299 - nodefamily is 3-fold with pldistro-fcdistro-arch
300 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
301 - (in addition to the 'vref' tag that's still exposed too)
302 - logging reviewed for more convenience
303 - support for 'service nm restartdebug'
304 - make sync knows how to publish uncommitted code on a test node
305
306 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
307 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
308
309 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
310 - support for f10 and f12 in the vref slice tag
311
312 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
313 - build on fedora12
314 - uses slicename 'sfacm' instead of 'genicw'
315
316 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
317 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
318 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
319 - days ago.
320
321 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
322 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
323 - self-contained. With this change, they will be able to refer to the attributes associated with a
324 - slice.
325
326 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
327 - fix for syntax error
328
329 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
330 - -fixed problem with sioc import at the build side
331 - -bwlimit.set() now accepts the device and does not asume that it is eth0
332
333 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
334 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
335
336 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
337 - The seed for random previously was the meaning of life (i.e., 42) but
338 - that resulted in a not so random choice for the hmac.  This
339 - implementation now uses a random.seed that is based on the current
340 - time.
341
342 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
343 - Minor fix such that sliverauth.py makes a more specific call to
344 - GetSliceTags that include that specific tagname it is looking for.
345
346 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
347 - Fix bug that prevented 'OVERRIDES' for working correctly.
348
349 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
350 - Increase disk limits to 10G per sliver
351 - Sanity check slice for home directory before starting (hack)
352 - Check codemux arguments
353
354 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
355 - * Fix Delegation
356 - * Move plcapi in plugin-api GetSlivers() calls.
357 - * Persistent Authcheck and resync session when auth failure
358
359 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
360 - Disabling sliverauth module.  Not ready for deployment.
361
362 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
363 - Fixing overrides semantics.
364
365 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
366 - Generalized plugins
367 - Fixed initscript start up bug.
368
369 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
370 - * Fix delegation authentication problem
371 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
372
373 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
374 - * Rerun initscripts when slice goes from disabled to enabled.
375
376 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
377 - * Update session key when out of synch with PLC
378 - * PLCDefaults uses tagname
379
380 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
381 - log invokations of vsys
382
383 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
384
385 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
386
387 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
388 - Codemux supports multiple hosts mapping to single slice
389 - Fixed bug in delegation support where tickets delivered weren't
390   being passed to sm.deliver_ticket().
391 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
392 - Codemux now configured via slice attribute (host,port)
393 - Support for multiple vserver reference images (including different archs)
394 - Mom BW emails are sent to list defined by MyPLC's config
395 - Sirius BW loans honored correctly.  Fixed.
396 - BW totals preserved for dynamic slices so as not to game the system.
397 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
398 - Configures vsys via vsys slice attribute {name: vsys, value: script}
399 - CPU reservations are now calculated via percentages instead of shares
400 - BW totals preserved for dynamic slices
401 - Closes bug where node cap sets off bw slice alarms for all slices.
402
403 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
404 - Switched to SVN.
405
406 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
407 - Initial build.