d58342c29379000a20d5aefeb77ba54d6567abb3
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 2.0
10 %define taglevel 8
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # Old Node Manager
32 Obsoletes: sidewinder, sidewinder-common
33
34 # vuseradd, vuserdel
35 Requires: vserver-%{slicefamily}
36 Requires: util-vserver >= 0.30.208-17
37
38 # vserver.py
39 Requires: util-vserver-python > 0.3-16
40
41 # Signed tickets
42 Requires: gnupg
43
44 # Uses function decorators
45 Requires: python >= 2.4
46
47 # sioc/plnet
48 Requires: pyplnet >= 4.3
49
50 %description
51 The PlanetLab Node Manager manages all aspects of PlanetLab node and
52 slice management once the node has been initialized and configured by
53 the Boot Manager. It periodically contacts its management authority
54 for configuration updates. It provides an XML-RPC API for performing
55 local operations on slices.
56
57 %prep
58 %setup -q
59
60 %build
61 # make manages the C and Python stuff
62 %{__make} %{?_smp_mflags}
63
64 %install
65 # make manages the C and Python stuff
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
68
69 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
70 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
71 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
72
73 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
74
75 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
76
77 ##########
78 %post
79 # tmp - handle file renamings; old names are from 2.0-8
80 renamings="
81 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.dat
82 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/nodemanager.pickle
83 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
84 /var/log/nm@/var/log/nodemanager
85 /var/log/nm.daemon@/var/log/nodemanager.daemon
86 /var/run/nm.pid@/var/run/nodemanager.pid
87 /tmp/sliver_mgr.api@/tmp/nodemanager.api
88 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
89 "
90 for renaming in $renamings; do
91   old=$(echo $renaming | cut -d@ -f1)
92   new=$(echo $renaming | cut -d@ -f2)
93   newdir=$(dirname $new)
94   if [ -e "$old" -a ! -e "$new" ] ; then
95       mkdir -p $newdir
96       mv -f $old $new
97   fi
98 done
99 #
100 chkconfig --add conf_files
101 chkconfig conf_files on
102 chkconfig --add nm
103 chkconfig nm on
104 chkconfig --add fuse-pl
105 chkconfig fuse-pl on
106 if [ "$PL_BOOTCD" != "1" ] ; then
107         service nm restart
108         service fuse-pl restart
109 fi
110
111 ##########
112 %preun
113 # 0 = erase, 1 = upgrade
114 if [ $1 -eq 0 ] ; then
115     chkconfig fuse-pl off
116     chkconfig --del fuse-pl
117     chkconfig nm off
118     chkconfig --del nm
119     chkconfig conf_files off
120     chkconfig --del conf_files
121 fi
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(-,root,root,-)
128 %{_datadir}/NodeManager/
129 %{_bindir}/forward_api_calls
130 %{_initrddir}/
131 %{_sysconfdir}/logrotate.d/nodemanager
132 /var/lib/
133
134 %changelog
135 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
136 - tagging before RC
137
138 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
139 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
140 - Added some precautions to the slice id-saving code
141 - Added log message to code that records the slice id
142
143 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
144 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
145 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
146 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
147
148 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
149 - fix log_call in plugins/drl.py
150
151 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
152 - protect against nodes in migrated PLC's not having the hrn tag yet
153
154 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
155 - new omf-resctl and drl plugins
156 - specialaccount optimized to overwrite authorized keys only upon changes
157 - codemux plugin has support for a new 'ip' setting
158 - mainloop to display ordered modules&plugins at all times
159
160 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
161 - modules and plugins have a priority
162 - specialaccounts appears soon in the priority chain
163 - logger.log_call logs process output, and has a timeout
164 - vuser{add,del} run through bash -x
165 - nm initscript has support for 'service nm restartverbose'
166 - logs reviewed for consistency
167 - use hashlib module instead of sha when available
168
169 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
170 - first working version of 5.0:
171 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
172 - nodefamily is 3-fold with pldistro-fcdistro-arch
173 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
174 - (in addition to the 'vref' tag that's still exposed too)
175 - logging reviewed for more convenience
176 - support for 'service nm restartdebug'
177 - make sync knows how to publish uncommitted code on a test node
178
179 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
180 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
181
182 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
183 - support for f10 and f12 in the vref slice tag
184
185 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
186 - build on fedora12
187 - uses slicename 'sfacm' instead of 'genicw'
188
189 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
190 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
191 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
192 - days ago.
193
194 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
195 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
196 - self-contained. With this change, they will be able to refer to the attributes associated with a
197 - slice.
198
199 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
200 - fix for syntax error
201
202 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
203 - -fixed problem with sioc import at the build side
204 - -bwlimit.set() now accepts the device and does not asume that it is eth0
205
206 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
207 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
208
209 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
210 - The seed for random previously was the meaning of life (i.e., 42) but
211 - that resulted in a not so random choice for the hmac.  This
212 - implementation now uses a random.seed that is based on the current
213 - time.
214
215 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
216 - Minor fix such that sliverauth.py makes a more specific call to
217 - GetSliceTags that include that specific tagname it is looking for.
218
219 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
220 - Fix bug that prevented 'OVERRIDES' for working correctly.
221
222 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
223 - Increase disk limits to 10G per sliver
224 - Sanity check slice for home directory before starting (hack)
225 - Check codemux arguments
226
227 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
228 - * Fix Delegation
229 - * Move plcapi in plugin-api GetSlivers() calls.
230 - * Persistent Authcheck and resync session when auth failure
231
232 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
233 - Disabling sliverauth module.  Not ready for deployment.
234
235 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
236 - Fixing overrides semantics.
237
238 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
239 - Generalized plugins
240 - Fixed initscript start up bug.
241
242 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
243 - * Fix delegation authentication problem
244 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
245
246 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
247 - * Rerun initscripts when slice goes from disabled to enabled.
248
249 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
250 - * Update session key when out of synch with PLC
251 - * PLCDefaults uses tagname
252
253 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
254 - log invokations of vsys
255
256 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
257
258 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
259
260 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
261 - Codemux supports multiple hosts mapping to single slice
262 - Fixed bug in delegation support where tickets delivered weren't
263   being passed to sm.deliver_ticket().
264 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
265 - Codemux now configured via slice attribute (host,port)
266 - Support for multiple vserver reference images (including different archs)
267 - Mom BW emails are sent to list defined by MyPLC's config
268 - Sirius BW loans honored correctly.  Fixed.
269 - BW totals preserved for dynamic slices so as not to game the system.
270 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
271 - Configures vsys via vsys slice attribute {name: vsys, value: script}
272 - CPU reservations are now calculated via percentages instead of shares
273 - BW totals preserved for dynamic slices
274 - Closes bug where node cap sets off bw slice alarms for all slices.
275
276 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
277 - Switched to SVN.
278
279 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
280 - Initial build.
281
282 %define module_current_branch 1.8