- RPM spec file for new NodeManager package
[nodemanager.git] / NodeManager.spec
1 Summary: PlanetLab Node Manager
2 Name: NodeManager
3 Version: 1.1
4 Release: 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
5 License: PlanetLab
6 Group: System Environment/Daemons
7 URL: http://cvs.planet-lab.org/cvs/NodeManager
8 Source0: %{name}-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11 # Old Node Manager
12 Obsoletes: sidewinder, sidewinder-common
13
14 # vuseradd, vuserdel
15 Requires: vserver-reference
16 Requires: util-vserver
17
18 # vserver.py
19 Requires: util-vserver-python
20
21 # Signed tickets
22 Requires: gnupg
23
24 # Contact API server
25 Requires: curl
26
27 # Uses function decorators
28 Requires: python >= 2.4
29
30 %description
31 The PlanetLab Node Manager manages all aspects of PlanetLab node and
32 slice management once the node has been initialized and configured by
33 the Boot Manager. It periodically contacts its management authority
34 for configuration updates. It provides an XML-RPC API for performing
35 local operations on slices.
36
37 %prep
38 %setup -q
39
40 %build
41 %{__make} %{?_smp_mflags}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
46
47 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
48 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(-,root,root,-)
55 %doc
56 %dir %{_datadir}/NodeManager
57 %{_datadir}/NodeManager/*
58 %{_bindir}/forward_api_calls
59 %{_initrddir}/nm
60 %{_sysconfdir}/logrotate.d/nm
61
62 %changelog
63 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
64 - Initial build.