f7bcfdc8cbdc535324a6e2767859eef62d7e0568
[nodemanager.git] / NodeManager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name NodeManager
4 %define version 2.1
5 %define taglevel 2
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # old name
28 #Obsoletes: sidewinder, sidewinder-common
29
30 # Uses function decorators
31 Requires: python >= 2.4
32 # connecting PLC
33 Requires: python-pycurl
34 # Signed tickets
35 Requires: gnupg
36 # vserver-sliceimage or lxc-sliceimage to be added explicitly in nodeimage.pkgs
37 # we do need the slice images in any case
38 Requires: sliceimage-%{slicefamily}
39 # our interface to the vserver patch
40 #Requires: util-vserver >= 0.30.208-17
41 # vserver.py
42 #Requires: util-vserver-python > 0.3-16
43 # sioc/plnet
44 Requires: pyplnet >= 4.3
45
46 %description
47 The PlanetLab Node Manager manages all aspects of PlanetLab node and
48 slice management once the node has been initialized and configured by
49 the Boot Manager. It periodically contacts its management authority
50 for configuration updates. It provides an XML-RPC API for performing
51 local operations on slices.
52
53 %prep
54 %setup -q
55
56 %build
57 # make manages the C and Python stuff
58 %{__make} %{?_smp_mflags}
59
60 %install
61 # make manages the C and Python stuff
62 rm -rf $RPM_BUILD_ROOT
63 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
64 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
65
66 # install the sliver initscript (that triggers the slice initscript if any)
67 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
68 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
69 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
70
71 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
72 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
73 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
74
75 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
76
77 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
78 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
79 install -D -m 644 bwlimit.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/bwlimit.py
80
81 ##########
82 %post
83 # tmp - handle file renamings; old names are from 2.0-8
84 renamings="
85 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
86 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
87 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
88 /var/log/nm@/var/log/nodemanager
89 /var/log/nm.daemon@/var/log/nodemanager.daemon
90 /var/run/nm.pid@/var/run/nodemanager.pid
91 /tmp/sliver_mgr.api@/tmp/nodemanager.api
92 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
93 "
94 for renaming in $renamings; do
95   old=$(echo $renaming | cut -d@ -f1)
96   new=$(echo $renaming | cut -d@ -f2)
97   newdir=$(dirname $new)
98   if [ -e "$old" -a ! -e "$new" ] ; then
99       mkdir -p $newdir
100       mv -f $old $new
101   fi
102 done
103 #
104 chkconfig --add conf_files
105 chkconfig conf_files on
106 chkconfig --add nm
107 chkconfig nm on
108 chkconfig --add fuse-pl
109 chkconfig fuse-pl on
110 if [ "$PL_BOOTCD" != "1" ] ; then
111         service nm restart
112         service fuse-pl restart
113 fi
114
115 ##########
116 %preun
117 # 0 = erase, 1 = upgrade
118 if [ $1 -eq 0 ] ; then
119     chkconfig fuse-pl off
120     chkconfig --del fuse-pl
121     chkconfig nm off
122     chkconfig --del nm
123     chkconfig conf_files off
124     chkconfig --del conf_files
125 fi
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(-,root,root,-)
132 %{_datadir}/NodeManager/
133 %{_bindir}/forward_api_calls
134 %{_initrddir}/
135 %{_sysconfdir}/logrotate.d/nodemanager
136 /var/lib/
137 /bin/sshsh
138 %{python_sitearch}/bwlimit.py*
139
140 %changelog
141 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
142 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
143 - passes tests with lxc but won't build against vs due to conflict
144 - as bwlimit.py also ships with util-vserver-pl
145
146 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
147 - refactoring: isolate initscript functionality
148 - aimed at making initscript implementation with lxc straightforward
149 - show stack trace when module loading fails
150 - accounts.py renamed into account.py for consistency
151
152 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
153 - /var/log/nodemanager shows duration of mainloop
154
155 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
156 - first working draft for dealing with libvirt/lxc on f16 nodes
157 - not expected to work with mainline nodes (use 2.0 for that for now)
158
159 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
160 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
161
162 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
163 - Added memory scheduling to core scheduler
164 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
165
166 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
167 - tweaked log policy for the core scheduler
168 - curlwrapper has an optional verbose mode
169
170 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
171 - fixes for hmac and omf_control tags
172 - optional besteffort flag to core scheduler
173 - logrotate entry for /var/log/nodemanager.daemon
174 - a template for bash initscripts
175
176 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
177 - rename initscript_body into initscript_code
178 - fix generic vinit for broken bash syntax &>>
179
180 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
181 - new initscript_body slice tag, with stop and restart
182 - generic vinit script live updated
183 - new coresched module
184 - protect against non-existing vsys scripts
185 - use Config. instead of globals
186
187 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
188 - more robust reservation plugin
189
190 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
191 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
192 - reservation plugin more robust
193
194 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
195 - pass device to bwlimit
196
197 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
198 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
199
200 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
201 - Catch all exceptions for sfa plugin
202
203 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
204 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
205
206 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
207 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
208
209 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
210 - plugins/sliverauth.py improvements
211
212 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
213 - Disable sfagids plugin
214
215 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
216 - Re-tag nodemanager to include conflicted commits
217
218 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
219 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
220 - sfagids plugin deleted
221 - band-aid patch for lack of GetSliceFamily removed
222
223 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
224
225 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
226 - revert curlwrapper to former forking-curl version
227 - fixes in the omf plugin for ssh key location and node hrn
228 - set umask 0022 in tools.daemon
229
230 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
231 - configure omf-resctl for keys
232
233 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
234 - fix key generation
235
236 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
237 - name changes and fix typos
238
239 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
240 - remove config and options parameters from start function
241
242 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
243 - working version of reservable nodes
244 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
245 - dismantled the -s|--startup option (no convincing need for that)
246 - simpler and more robust init.d/nm
247 - initscript content management through replace_file_with_string
248 - sliverauth uses replace_file_with_string
249 - curlwrapper has a debug mode
250
251 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
252 - pretty-printing/normalized python code - hopefully neutral
253
254 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
255 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
256 - that triggers /etc/init.d/vinit.slice if present and executable
257 - (2) install the slice-provided initscript (as per the initscript tag) as
258 - /etc/init.d/vinit.slice
259 - (3) as a result the initscript are now triggered by rc as part of the
260 - standard vserver .. start, properly attached to the vserver,
261 - and properly killed upon vserver .. stop
262 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
263
264 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
265 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
266 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
267 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
268 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
269 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
270 - cleanup: nodemanger now is a class; however plugins are still dumb modules
271 - cleanup: does not depend on obsolete Set
272
273 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
274 - tagging before RC
275
276 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
277 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
278 - Added some precautions to the slice id-saving code
279 - Added log message to code that records the slice id
280
281 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
282 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
283 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
284 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
285
286 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
287 - fix log_call in plugins/drl.py
288
289 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
290 - protect against nodes in migrated PLC's not having the hrn tag yet
291
292 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
293 - new omf-resctl and drl plugins
294 - specialaccount optimized to overwrite authorized keys only upon changes
295 - codemux plugin has support for a new 'ip' setting
296 - mainloop to display ordered modules&plugins at all times
297
298 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
299 - modules and plugins have a priority
300 - specialaccounts appears soon in the priority chain
301 - logger.log_call logs process output, and has a timeout
302 - vuser{add,del} run through bash -x
303 - nm initscript has support for 'service nm restartverbose'
304 - logs reviewed for consistency
305 - use hashlib module instead of sha when available
306
307 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
308 - first working version of 5.0:
309 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
310 - nodefamily is 3-fold with pldistro-fcdistro-arch
311 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
312 - (in addition to the 'vref' tag that's still exposed too)
313 - logging reviewed for more convenience
314 - support for 'service nm restartdebug'
315 - make sync knows how to publish uncommitted code on a test node
316
317 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
318 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
319
320 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
321 - support for f10 and f12 in the vref slice tag
322
323 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
324 - build on fedora12
325 - uses slicename 'sfacm' instead of 'genicw'
326
327 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
328 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
329 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
330 - days ago.
331
332 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
333 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
334 - self-contained. With this change, they will be able to refer to the attributes associated with a
335 - slice.
336
337 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
338 - fix for syntax error
339
340 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
341 - -fixed problem with sioc import at the build side
342 - -bwlimit.set() now accepts the device and does not asume that it is eth0
343
344 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
345 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
346
347 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
348 - The seed for random previously was the meaning of life (i.e., 42) but
349 - that resulted in a not so random choice for the hmac.  This
350 - implementation now uses a random.seed that is based on the current
351 - time.
352
353 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
354 - Minor fix such that sliverauth.py makes a more specific call to
355 - GetSliceTags that include that specific tagname it is looking for.
356
357 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
358 - Fix bug that prevented 'OVERRIDES' for working correctly.
359
360 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
361 - Increase disk limits to 10G per sliver
362 - Sanity check slice for home directory before starting (hack)
363 - Check codemux arguments
364
365 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
366 - * Fix Delegation
367 - * Move plcapi in plugin-api GetSlivers() calls.
368 - * Persistent Authcheck and resync session when auth failure
369
370 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
371 - Disabling sliverauth module.  Not ready for deployment.
372
373 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
374 - Fixing overrides semantics.
375
376 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
377 - Generalized plugins
378 - Fixed initscript start up bug.
379
380 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
381 - * Fix delegation authentication problem
382 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
383
384 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
385 - * Rerun initscripts when slice goes from disabled to enabled.
386
387 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
388 - * Update session key when out of synch with PLC
389 - * PLCDefaults uses tagname
390
391 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
392 - log invokations of vsys
393
394 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
395
396 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
397
398 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
399 - Codemux supports multiple hosts mapping to single slice
400 - Fixed bug in delegation support where tickets delivered weren't
401   being passed to sm.deliver_ticket().
402 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
403 - Codemux now configured via slice attribute (host,port)
404 - Support for multiple vserver reference images (including different archs)
405 - Mom BW emails are sent to list defined by MyPLC's config
406 - Sirius BW loans honored correctly.  Fixed.
407 - BW totals preserved for dynamic slices so as not to game the system.
408 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
409 - Configures vsys via vsys slice attribute {name: vsys, value: script}
410 - CPU reservations are now calculated via percentages instead of shares
411 - BW totals preserved for dynamic slices
412 - Closes bug where node cap sets off bw slice alarms for all slices.
413
414 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
415 - Switched to SVN.
416
417 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
418 - Initial build.