Use pyplnet.
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 1.7
10 %define taglevel 37
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 BuildArch: noarch
29
30 # Old Node Manager
31 Obsoletes: sidewinder, sidewinder-common
32
33 # vuseradd, vuserdel
34 Requires: vserver-%{slicefamily}
35 Requires: util-vserver >= 0.30.208-17
36
37 # vserver.py
38 Requires: util-vserver-python
39
40 # Signed tickets
41 Requires: gnupg
42
43 # Contact API server
44 Requires: curl
45
46 # Uses function decorators
47 Requires: python >= 2.4
48
49 # sioc/plnet
50 Requires: pyplnet = 4.2
51
52 %description
53 The PlanetLab Node Manager manages all aspects of PlanetLab node and
54 slice management once the node has been initialized and configured by
55 the Boot Manager. It periodically contacts its management authority
56 for configuration updates. It provides an XML-RPC API for performing
57 local operations on slices.
58
59 %prep
60 %setup -q
61
62 %build
63 %{__make} %{?_smp_mflags}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
68
69 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
70 install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
71 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
72 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
73
74 %post
75 chkconfig --add conf_files
76 chkconfig conf_files on
77 chkconfig --add nm
78 chkconfig nm on
79 chkconfig --add fuse-pl
80 chkconfig fuse-pl on
81 if [ "$PL_BOOTCD" != "1" ] ; then
82         service nm restart
83         service fuse-pl restart
84 fi
85
86
87 %preun
88 # 0 = erase, 1 = upgrade
89 if [ $1 -eq 0 ] ; then
90     chkconfig fuse-pl off
91     chkconfig --del fuse-pl
92     chkconfig nm off
93     chkconfig --del nm
94     chkconfig conf_files off
95     chkconfig --del conf_files
96 fi
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(-,root,root,-)
103 %{_datadir}/NodeManager/
104 %{_bindir}/forward_api_calls
105 %{_initrddir}/nm
106 %{_initrddir}/conf_files
107 %{_initrddir}/fuse-pl
108 %{_sysconfdir}/logrotate.d/nm
109
110 %changelog
111 * Tue Sep 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-37
112 - Slices are created 1 at a time to avoid race conditions.
113
114 * Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-36
115 - Internet2 clique flow classification is now setup by NM.
116
117 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-35
118 - Clique network shares don't exist.  Removed from bwmon.
119
120 * Fri Sep 12 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-34
121 - * Fixed slice restart via xmlrpc to actually set resources
122 - * Reverted bwmon to check current min/max limits before manipulating HTB.
123
124 * Wed Sep 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-33
125 - bwmon now has enable/disable flag to control throttling.
126
127 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-32
128 - always log message when expected vserver reference is missing
129
130 * Mon Aug 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-31
131 - Emails were only being sent of high bandwidth caps were being exceeded.  Fixed.
132
133 * Thu Aug 21 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-30
134 - bwmon:  Only mention the limit the slice went over.  Not both it and the second limit.
135
136 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-29
137 - Fixed KeyError in logging.
138
139 * Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-28
140 - Fixed syntax error in notify function call.  Also fixed values in email message and logging.
141
142 * Mon Aug 18 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-27
143 - Fix the FUSE initscript.
144
145 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-26
146 - FUSE support.
147
148 * Wed Aug 13 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-25
149 - Removed thread created for each sliver (!!!).
150 - Slivers now spawned out of main thread.
151 - This closes the Delegation bug and closes the recent rash of NM instabilities due to queue overflows. [ticket: 384]
152
153 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-24
154 - * Update bandwidth related attributes on every NM sync.  Bwlimit will check if values have changed.
155 - * Vsys supports local_ scripts and NM will disregard them.
156
157 * Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-23
158 - After removing the fork() to the slice's uid when writing .ssh/authorized_keys, .ssh had the wrong owner/group.  Fixed.
159
160 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-22
161 - Small change.  Change uid to slice owner of authorized_keys.
162
163 * Wed Jul 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-21
164 - Slices with initscripts kept restarting.  Fixed.
165 - Also removed unnecessary fork just to write .ssh/authorized keys for every slice.
166
167 * Tue Jul 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-20
168 - * Check slice is_running() every cycle.  If not, assume damaged and restart.
169
170 * Mon Jul 07 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-19
171 - chrooting is not thread-safe.
172
173 * Fri Jun 27 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-18
174 - Log disk init AFTER acquiring disk semaphore.
175
176 * Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-17
177 - unconditionnally passes node_id and slicefamily to conf_file scripts
178 - correctly set personality a sliver creation time (not yet used by util-vserver-pl though)
179
180 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-16
181
182 - enables a vsys slice attribute to end with 'a', 'c', or 'l' characters without
183 - NM going bonkers.
184
185
186 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-15
187
188 - enable restart if vsys.conf changes also.
189
190
191 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-14
192
193 - the _restart flag for vsys was getting lost when looking across multiple
194 - vservers.  adding the 'or' should preserve any 'True' returns from
195 - createVsysDir()
196
197
198 * Tue Jun 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-13
199
200 - Time out curl when no response for 90 seconds.
201
202
203 * Fri Jun 13 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.7-12
204 - Patch designed to work around the vsys-fail-to-restart problem with
205 - non-existent directories, and the vuseradd-fail-to-work on directories that
206 - do exist.  
207
208 - This patch will work in conjunction with the new vsys patch.
209
210
211 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-10
212 - fixed doc build by locating locally installed DTDs at build-time
213
214 * Fri May 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-9
215 - * Reverted vserver start to forking before VServer.start to avoid defunct procs.* House keeping in various places.
216
217 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-8
218 - merge changes for myplc-docs from trunk
219
220 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-7
221
222 - Set vcVHI_CONTEXT as slice_id for fprobe-ulog to mark packets with.
223
224
225 * Wed Apr 09 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-5 NodeManager-1.7-6
226
227 - * Codemux will use PLC_API_HOST when PLC_PLANETFLOW_HOST isn't defined.
228
229
230 * Fri Apr 04 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-4 NodeManager-1.7-5
231 - * vdu limitting when NM restarts and slices are re-init'ed
232 - * CoDemux config parser update.  Now tolerates spaces.
233
234 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
235 - Codemux supports multiple hosts mapping to single slice
236 - Fixed bug in delegation support where tickets delivered weren't
237   being passed to sm.deliver_ticket().
238 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
239 - Codemux now configured via slice attribute (host,port)
240 - Support for multiple vserver reference images (including different archs)
241 - Mom BW emails are sent to list defined by MyPLC's config
242 - Sirius BW loans honored correctly.  Fixed.
243 - BW totals preserved for dynamic slices so as not to game the system.
244 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
245 - Configures vsys via vsys slice attribute {name: vsys, value: script}
246 - CPU reservations are now calculated via percentages instead of shares
247 - BW totals preserved for dynamic slices
248 - Closes bug where node cap sets off bw slice alarms for all slices.
249
250 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
251 - Switched to SVN.
252
253 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
254 - Initial build.