Bump release
[nodemanager.git] / NodeManager.spec
1 Summary: PlanetLab Node Manager
2 Name: NodeManager
3 Version: 1.1
4 Release: 3%{?pldistro:.%{pldistro}}%{?date:.%{date}}
5 License: PlanetLab
6 Group: System Environment/Daemons
7 URL: http://cvs.planet-lab.org/cvs/NodeManager
8 Source0: %{name}-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11 # Old Node Manager
12 Obsoletes: sidewinder, sidewinder-common
13
14 # vuseradd, vuserdel
15 Requires: vserver-reference
16 Requires: util-vserver
17
18 # vserver.py
19 Requires: util-vserver-python
20
21 # Signed tickets
22 Requires: gnupg
23
24 # Contact API server
25 Requires: curl
26
27 # Uses function decorators
28 Requires: python >= 2.4
29
30 %description
31 The PlanetLab Node Manager manages all aspects of PlanetLab node and
32 slice management once the node has been initialized and configured by
33 the Boot Manager. It periodically contacts its management authority
34 for configuration updates. It provides an XML-RPC API for performing
35 local operations on slices.
36
37 %prep
38 %setup -q
39
40 %build
41 %{__make} %{?_smp_mflags}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
46
47 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
48 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
49 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
50
51 %post
52 chkconfig --add conf_files
53 chkconfig conf_files on
54 chkconfig --add nm
55 chkconfig nm on
56
57 %preun
58 # 0 = erase, 1 = upgrade
59 if [ $1 -eq 0 ] ; then
60     chkconfig nm off
61     chkconfig --del nm
62     chkconfig conf_files off
63     chkconfig --del conf_files
64 fi
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(-,root,root,-)
71 %doc
72 %dir %{_datadir}/NodeManager
73 %{_datadir}/NodeManager/*
74 %{_bindir}/forward_api_calls
75 %{_initrddir}/nm
76 %{_initrddir}/conf_files
77 %{_sysconfdir}/logrotate.d/nm
78
79 %changelog
80 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
81 - Initial build.