Setting tag NodeManager-2.0-9
[nodemanager.git] / NodeManager.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
7
8 %define name NodeManager
9 %define version 2.0
10 %define taglevel 9
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Summary: PlanetLab Node Manager
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: PlanetLab
19 Group: System Environment/Daemons
20 Source0: %{name}-%{version}.tar.gz
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # not possible because of forward_api_calls
29 #BuildArch: noarch
30
31 # old name
32 #Obsoletes: sidewinder, sidewinder-common
33
34 # Uses function decorators
35 Requires: python >= 2.4
36 # connecting PLC
37 Requires: python-pycurl
38 # Signed tickets
39 Requires: gnupg
40 # vuseradd, vuserdel
41 Requires: vserver-%{slicefamily}
42 # our interface to the vserver patch
43 Requires: util-vserver >= 0.30.208-17
44 # vserver.py
45 Requires: util-vserver-python > 0.3-16
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48
49 %description
50 The PlanetLab Node Manager manages all aspects of PlanetLab node and
51 slice management once the node has been initialized and configured by
52 the Boot Manager. It periodically contacts its management authority
53 for configuration updates. It provides an XML-RPC API for performing
54 local operations on slices.
55
56 %prep
57 %setup -q
58
59 %build
60 # make manages the C and Python stuff
61 %{__make} %{?_smp_mflags}
62
63 %install
64 # make manages the C and Python stuff
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
67
68 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
69 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
70 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
71
72 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
73
74 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132
133 %changelog
134 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
135 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
136 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
137 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
138 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
139 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
140 - cleanup: nodemanger now is a class; however plugins are still dumb modules
141 - cleanup: does not depend on obsolete Set
142
143 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
144 - tagging before RC
145
146 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
147 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
148 - Added some precautions to the slice id-saving code
149 - Added log message to code that records the slice id
150
151 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
152 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
153 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
154 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
155
156 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
157 - fix log_call in plugins/drl.py
158
159 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
160 - protect against nodes in migrated PLC's not having the hrn tag yet
161
162 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
163 - new omf-resctl and drl plugins
164 - specialaccount optimized to overwrite authorized keys only upon changes
165 - codemux plugin has support for a new 'ip' setting
166 - mainloop to display ordered modules&plugins at all times
167
168 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
169 - modules and plugins have a priority
170 - specialaccounts appears soon in the priority chain
171 - logger.log_call logs process output, and has a timeout
172 - vuser{add,del} run through bash -x
173 - nm initscript has support for 'service nm restartverbose'
174 - logs reviewed for consistency
175 - use hashlib module instead of sha when available
176
177 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
178 - first working version of 5.0:
179 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
180 - nodefamily is 3-fold with pldistro-fcdistro-arch
181 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
182 - (in addition to the 'vref' tag that's still exposed too)
183 - logging reviewed for more convenience
184 - support for 'service nm restartdebug'
185 - make sync knows how to publish uncommitted code on a test node
186
187 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
188 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
189
190 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
191 - support for f10 and f12 in the vref slice tag
192
193 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
194 - build on fedora12
195 - uses slicename 'sfacm' instead of 'genicw'
196
197 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
198 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
199 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
200 - days ago.
201
202 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
203 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
204 - self-contained. With this change, they will be able to refer to the attributes associated with a
205 - slice.
206
207 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
208 - fix for syntax error
209
210 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
211 - -fixed problem with sioc import at the build side
212 - -bwlimit.set() now accepts the device and does not asume that it is eth0
213
214 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
215 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
216
217 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
218 - The seed for random previously was the meaning of life (i.e., 42) but
219 - that resulted in a not so random choice for the hmac.  This
220 - implementation now uses a random.seed that is based on the current
221 - time.
222
223 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
224 - Minor fix such that sliverauth.py makes a more specific call to
225 - GetSliceTags that include that specific tagname it is looking for.
226
227 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
228 - Fix bug that prevented 'OVERRIDES' for working correctly.
229
230 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
231 - Increase disk limits to 10G per sliver
232 - Sanity check slice for home directory before starting (hack)
233 - Check codemux arguments
234
235 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
236 - * Fix Delegation
237 - * Move plcapi in plugin-api GetSlivers() calls.
238 - * Persistent Authcheck and resync session when auth failure
239
240 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
241 - Disabling sliverauth module.  Not ready for deployment.
242
243 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
244 - Fixing overrides semantics.
245
246 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
247 - Generalized plugins
248 - Fixed initscript start up bug.
249
250 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
251 - * Fix delegation authentication problem
252 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
253
254 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
255 - * Rerun initscripts when slice goes from disabled to enabled.
256
257 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
258 - * Update session key when out of synch with PLC
259 - * PLCDefaults uses tagname
260
261 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
262 - log invokations of vsys
263
264 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
265
266 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
267
268 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
269 - Codemux supports multiple hosts mapping to single slice
270 - Fixed bug in delegation support where tickets delivered weren't
271   being passed to sm.deliver_ticket().
272 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
273 - Codemux now configured via slice attribute (host,port)
274 - Support for multiple vserver reference images (including different archs)
275 - Mom BW emails are sent to list defined by MyPLC's config
276 - Sirius BW loans honored correctly.  Fixed.
277 - BW totals preserved for dynamic slices so as not to game the system.
278 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
279 - Configures vsys via vsys slice attribute {name: vsys, value: script}
280 - CPU reservations are now calculated via percentages instead of shares
281 - BW totals preserved for dynamic slices
282 - Closes bug where node cap sets off bw slice alarms for all slices.
283
284 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
285 - Switched to SVN.
286
287 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
288 - Initial build.
289
290 %define module_current_branch 1.8