Setting tag nodemanager-5.2-1
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 1
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
136 - no-op bump to 5.2 to be in line with the rest of the system
137
138 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
139 - improvements to privatebridge
140
141 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
142 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
143
144 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
145 - fix wrong gre tunnel deleted when topology changes
146
147 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
148 - Update /etc/hosts in slivers from sliver_hostmap tag.
149
150 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
151 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
152 - initial check-in of privatebridge plugin.
153
154 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
155 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
156
157 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
158 - fix slices not deleted properly when they use vsys
159
160 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
161 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
162
163 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
164 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
165
166 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
167 - Bridge virtual interfaces to VLANs
168
169 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
170 - Add support for L2 bridged interfaces with public IPs inside a slice
171
172 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
173 - Support for freezing BestEffort slices for Vicci
174
175 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
176 - Change to use new vsh (wrapper for lxcsu)
177
178 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
179 - add missing import
180 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
181
182 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
183 - tag 2.1-7 was broken for OMF-friendly slices
184 - expose_ssh_dir was erroneously defined on the Worker class
185
186 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
187 - bwlimitlxc now ships with plnode-utils
188
189 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
190 - set LD_PRELOAD for linux-containers nodes
191
192 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
193 - first complete version for vs and lxc - functional but not thoroughly tested though
194
195 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
196 - split packaging in 3 (lib, lxc, vs)
197 - this tag will only work with lxc though
198
199 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
200 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
201
202 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
203 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
204 - purpose being to be able to run this branch on vserver nodes as well
205
206 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
207 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
208 - passes tests with lxc but won't build against vs due to conflict
209 - as bwlimit.py also ships with util-vserver-pl
210
211 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
212 - refactoring: isolate initscript functionality
213 - aimed at making initscript implementation with lxc straightforward
214 - show stack trace when module loading fails
215 - accounts.py renamed into account.py for consistency
216
217 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
218 - /var/log/nodemanager shows duration of mainloop
219
220 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
221 - first working draft for dealing with libvirt/lxc on f16 nodes
222 - not expected to work with mainline nodes (use 2.0 for that for now)
223
224 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
225 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
226
227 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
228 - Added memory scheduling to core scheduler
229 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
230
231 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
232 - tweaked log policy for the core scheduler
233 - curlwrapper has an optional verbose mode
234
235 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
236 - fixes for hmac and omf_control tags
237 - optional besteffort flag to core scheduler
238 - logrotate entry for /var/log/nodemanager.daemon
239 - a template for bash initscripts
240
241 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
242 - rename initscript_body into initscript_code
243 - fix generic vinit for broken bash syntax &>>
244
245 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
246 - new initscript_body slice tag, with stop and restart
247 - generic vinit script live updated
248 - new coresched module
249 - protect against non-existing vsys scripts
250 - use Config. instead of globals
251
252 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
253 - more robust reservation plugin
254
255 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
256 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
257 - reservation plugin more robust
258
259 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
260 - pass device to bwlimit
261
262 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
263 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
264
265 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
266 - Catch all exceptions for sfa plugin
267
268 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
269 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
270
271 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
272 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
273
274 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
275 - plugins/sliverauth.py improvements
276
277 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
278 - Disable sfagids plugin
279
280 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
281 - Re-tag nodemanager to include conflicted commits
282
283 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
284 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
285 - sfagids plugin deleted
286 - band-aid patch for lack of GetSliceFamily removed
287
288 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
289
290 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
291 - revert curlwrapper to former forking-curl version
292 - fixes in the omf plugin for ssh key location and node hrn
293 - set umask 0022 in tools.daemon
294
295 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
296 - configure omf-resctl for keys
297
298 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
299 - fix key generation
300
301 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
302 - name changes and fix typos
303
304 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
305 - remove config and options parameters from start function
306
307 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
308 - working version of reservable nodes
309 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
310 - dismantled the -s|--startup option (no convincing need for that)
311 - simpler and more robust init.d/nm
312 - initscript content management through replace_file_with_string
313 - sliverauth uses replace_file_with_string
314 - curlwrapper has a debug mode
315
316 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
317 - pretty-printing/normalized python code - hopefully neutral
318
319 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
320 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
321 - that triggers /etc/init.d/vinit.slice if present and executable
322 - (2) install the slice-provided initscript (as per the initscript tag) as
323 - /etc/init.d/vinit.slice
324 - (3) as a result the initscript are now triggered by rc as part of the
325 - standard vserver .. start, properly attached to the vserver,
326 - and properly killed upon vserver .. stop
327 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
328
329 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
330 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
331 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
332 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
333 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
334 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
335 - cleanup: nodemanger now is a class; however plugins are still dumb modules
336 - cleanup: does not depend on obsolete Set
337
338 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
339 - tagging before RC
340
341 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
342 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
343 - Added some precautions to the slice id-saving code
344 - Added log message to code that records the slice id
345
346 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
347 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
348 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
349 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
350
351 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
352 - fix log_call in plugins/drl.py
353
354 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
355 - protect against nodes in migrated PLC's not having the hrn tag yet
356
357 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
358 - new omf-resctl and drl plugins
359 - specialaccount optimized to overwrite authorized keys only upon changes
360 - codemux plugin has support for a new 'ip' setting
361 - mainloop to display ordered modules&plugins at all times
362
363 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
364 - modules and plugins have a priority
365 - specialaccounts appears soon in the priority chain
366 - logger.log_call logs process output, and has a timeout
367 - vuser{add,del} run through bash -x
368 - nm initscript has support for 'service nm restartverbose'
369 - logs reviewed for consistency
370 - use hashlib module instead of sha when available
371
372 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
373 - first working version of 5.0:
374 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
375 - nodefamily is 3-fold with pldistro-fcdistro-arch
376 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
377 - (in addition to the 'vref' tag that's still exposed too)
378 - logging reviewed for more convenience
379 - support for 'service nm restartdebug'
380 - make sync knows how to publish uncommitted code on a test node
381
382 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
383 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
384
385 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
386 - support for f10 and f12 in the vref slice tag
387
388 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
389 - build on fedora12
390 - uses slicename 'sfacm' instead of 'genicw'
391
392 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
393 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
394 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
395 - days ago.
396
397 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
398 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
399 - self-contained. With this change, they will be able to refer to the attributes associated with a
400 - slice.
401
402 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
403 - fix for syntax error
404
405 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
406 - -fixed problem with sioc import at the build side
407 - -bwlimit.set() now accepts the device and does not asume that it is eth0
408
409 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
410 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
411
412 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
413 - The seed for random previously was the meaning of life (i.e., 42) but
414 - that resulted in a not so random choice for the hmac.  This
415 - implementation now uses a random.seed that is based on the current
416 - time.
417
418 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
419 - Minor fix such that sliverauth.py makes a more specific call to
420 - GetSliceTags that include that specific tagname it is looking for.
421
422 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
423 - Fix bug that prevented 'OVERRIDES' for working correctly.
424
425 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
426 - Increase disk limits to 10G per sliver
427 - Sanity check slice for home directory before starting (hack)
428 - Check codemux arguments
429
430 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
431 - * Fix Delegation
432 - * Move plcapi in plugin-api GetSlivers() calls.
433 - * Persistent Authcheck and resync session when auth failure
434
435 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
436 - Disabling sliverauth module.  Not ready for deployment.
437
438 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
439 - Fixing overrides semantics.
440
441 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
442 - Generalized plugins
443 - Fixed initscript start up bug.
444
445 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
446 - * Fix delegation authentication problem
447 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
448
449 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
450 - * Rerun initscripts when slice goes from disabled to enabled.
451
452 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
453 - * Update session key when out of synch with PLC
454 - * PLCDefaults uses tagname
455
456 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
457 - log invokations of vsys
458
459 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
460
461 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
462
463 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
464 - Codemux supports multiple hosts mapping to single slice
465 - Fixed bug in delegation support where tickets delivered weren't
466   being passed to sm.deliver_ticket().
467 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
468 - Codemux now configured via slice attribute (host,port)
469 - Support for multiple vserver reference images (including different archs)
470 - Mom BW emails are sent to list defined by MyPLC's config
471 - Sirius BW loans honored correctly.  Fixed.
472 - BW totals preserved for dynamic slices so as not to game the system.
473 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
474 - Configures vsys via vsys slice attribute {name: vsys, value: script}
475 - CPU reservations are now calculated via percentages instead of shares
476 - BW totals preserved for dynamic slices
477 - Closes bug where node cap sets off bw slice alarms for all slices.
478
479 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
480 - Switched to SVN.
481
482 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
483 - Initial build.