01f502a670a2d51c47cd28032481332205c5a06a
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 9
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager Library
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # Uses function decorators
27 Requires: python >= 2.4
28 # connecting PLC
29 Requires: python-pycurl
30 # Signed tickets
31 Requires: gnupg
32 # sioc/plnet
33 Requires: pyplnet >= 4.3
34 # we do need the slice images in any case
35 Requires: sliceimage-%{slicefamily}
36 # for bwlimit
37 Requires: plnode-utils
38
39 %description
40 The PlanetLab Node Manager manages all aspects of PlanetLab node and
41 slice management once the node has been initialized and configured by
42 the Boot Manager. It periodically contacts its management authority
43 for configuration updates. It provides an XML-RPC API for performing
44 local operations on slices.
45 nodemanager-lib only provides a skeleton and needs as a companion
46 either nodemanager-vs or nodemanager-lxc
47
48 # use initscripts or systemd unit files to start installed services
49 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
50 %define make_options WITH_SYSTEMD=true
51 %define initdir /usr/lib/systemd/system
52 %else
53 %define make_options WITH_INIT=true
54 %define initdir %{_initrddir}
55 %endif
56
57 %prep
58 %setup -q
59
60 %build
61 # make manages the C and Python stuff
62 %{__make} %{?_smp_mflags} %{make_options} lib 
63
64 %install
65 # make manages the C and Python stuff
66 rm -rf $RPM_BUILD_ROOT
67 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
68
69 ##########
70 %post
71 # tmp - handle file renamings; old names are from 2.0-8
72 renamings="
73 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
74 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
75 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
76 /var/log/nm@/var/log/nodemanager
77 /var/log/nm.daemon@/var/log/nodemanager.daemon
78 /var/run/nm.pid@/var/run/nodemanager.pid
79 /tmp/sliver_mgr.api@/tmp/nodemanager.api
80 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
81 "
82 for renaming in $renamings; do
83   old=$(echo $renaming | cut -d@ -f1)
84   new=$(echo $renaming | cut -d@ -f2)
85   newdir=$(dirname $new)
86   if [ -e "$old" -a ! -e "$new" ] ; then
87       mkdir -p $newdir
88       mv -f $old $new
89   fi
90 done
91 #
92 chkconfig --add conf_files
93 chkconfig conf_files on
94 chkconfig --add nm
95 chkconfig nm on
96 chkconfig --add fuse-pl
97 chkconfig fuse-pl on
98 if [ "$PL_BOOTCD" != "1" ] ; then
99         service nm restart
100         service fuse-pl restart
101 fi
102
103 ##########
104 %preun
105 # 0 = erase, 1 = upgrade
106 if [ $1 -eq 0 ] ; then
107     chkconfig fuse-pl off
108     chkconfig --del fuse-pl
109     chkconfig nm off
110     chkconfig --del nm
111     chkconfig conf_files off
112     chkconfig --del conf_files
113 fi
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(-,root,root,-)
120 %{_datadir}/NodeManager/
121 %{_bindir}/forward_api_calls
122 %{initdir}/
123 %{_sysconfdir}/logrotate.d/nodemanager
124 /var/lib/nodemanager/
125 /bin/sshsh
126
127 %changelog
128 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
129 - fixes in hostmap, and in interfaces
130 - new vsys_sysctl
131 - privatebridge now comes with nodemanager-lib
132
133 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
134 - omf plugin does not block any longer when running trigger script
135 - log goes into sliver's /var/log instead
136
137 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
138 - new install-scripts target in Makefile
139 - conf_files and fuse-pl initscripts chmod'ed +x
140 - omf_resctl config template tweaked to use _slicename_%_hostname_
141
142 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
143 - make sure to create /etc/planetlab/virt so others can read that
144 - expose get_node_virt() and command_in_slice()
145 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
146 - user's .profile now has right owner
147 - other tweaks in lxc slivers
148
149 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
150 - lxc slice creation: slice user was created with unknown gid - fixed
151 - lxc slice creation: .profile for root and user - fixed
152
153 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
154 - fix umounting of ssh directory when deleting omf-friendly slivers
155 - support for writing cgroups in subsystems other than cpuset
156 - add xid to template match
157 - finer-grained split between -lib -vs and -lxc
158 - first roughly complete omf_resctl for omfv6
159 - minor fix for when getslivers does not have minexemptrate
160
161 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
162 - Fix path, machine arch in slivers
163
164 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
165
166 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
167 - no-op bump to 5.2 to be in line with the rest of the system
168
169 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
170 - improvements to privatebridge
171
172 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
173 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
174
175 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
176 - fix wrong gre tunnel deleted when topology changes
177
178 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
179 - Update /etc/hosts in slivers from sliver_hostmap tag.
180
181 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
182 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
183 - initial check-in of privatebridge plugin.
184
185 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
186 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
187
188 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
189 - fix slices not deleted properly when they use vsys
190
191 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
192 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
193
194 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
195 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
196
197 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
198 - Bridge virtual interfaces to VLANs
199
200 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
201 - Add support for L2 bridged interfaces with public IPs inside a slice
202
203 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
204 - Support for freezing BestEffort slices for Vicci
205
206 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
207 - Change to use new vsh (wrapper for lxcsu)
208
209 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
210 - add missing import
211 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
212
213 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
214 - tag 2.1-7 was broken for OMF-friendly slices
215 - expose_ssh_dir was erroneously defined on the Worker class
216
217 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
218 - bwlimitlxc now ships with plnode-utils
219
220 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
221 - set LD_PRELOAD for linux-containers nodes
222
223 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
224 - first complete version for vs and lxc - functional but not thoroughly tested though
225
226 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
227 - split packaging in 3 (lib, lxc, vs)
228 - this tag will only work with lxc though
229
230 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
231 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
232
233 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
234 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
235 - purpose being to be able to run this branch on vserver nodes as well
236
237 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
238 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
239 - passes tests with lxc but won't build against vs due to conflict
240 - as bwlimit.py also ships with util-vserver-pl
241
242 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
243 - refactoring: isolate initscript functionality
244 - aimed at making initscript implementation with lxc straightforward
245 - show stack trace when module loading fails
246 - accounts.py renamed into account.py for consistency
247
248 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
249 - /var/log/nodemanager shows duration of mainloop
250
251 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
252 - first working draft for dealing with libvirt/lxc on f16 nodes
253 - not expected to work with mainline nodes (use 2.0 for that for now)
254
255 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
256 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
257
258 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
259 - Added memory scheduling to core scheduler
260 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
261
262 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
263 - tweaked log policy for the core scheduler
264 - curlwrapper has an optional verbose mode
265
266 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
267 - fixes for hmac and omf_control tags
268 - optional besteffort flag to core scheduler
269 - logrotate entry for /var/log/nodemanager.daemon
270 - a template for bash initscripts
271
272 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
273 - rename initscript_body into initscript_code
274 - fix generic vinit for broken bash syntax &>>
275
276 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
277 - new initscript_body slice tag, with stop and restart
278 - generic vinit script live updated
279 - new coresched module
280 - protect against non-existing vsys scripts
281 - use Config. instead of globals
282
283 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
284 - more robust reservation plugin
285
286 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
287 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
288 - reservation plugin more robust
289
290 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
291 - pass device to bwlimit
292
293 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
294 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
295
296 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
297 - Catch all exceptions for sfa plugin
298
299 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
300 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
301
302 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
303 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
304
305 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
306 - plugins/sliverauth.py improvements
307
308 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
309 - Disable sfagids plugin
310
311 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
312 - Re-tag nodemanager to include conflicted commits
313
314 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
315 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
316 - sfagids plugin deleted
317 - band-aid patch for lack of GetSliceFamily removed
318
319 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
320
321 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
322 - revert curlwrapper to former forking-curl version
323 - fixes in the omf plugin for ssh key location and node hrn
324 - set umask 0022 in tools.daemon
325
326 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
327 - configure omf-resctl for keys
328
329 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
330 - fix key generation
331
332 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
333 - name changes and fix typos
334
335 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
336 - remove config and options parameters from start function
337
338 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
339 - working version of reservable nodes
340 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
341 - dismantled the -s|--startup option (no convincing need for that)
342 - simpler and more robust init.d/nm
343 - initscript content management through replace_file_with_string
344 - sliverauth uses replace_file_with_string
345 - curlwrapper has a debug mode
346
347 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
348 - pretty-printing/normalized python code - hopefully neutral
349
350 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
351 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
352 - that triggers /etc/init.d/vinit.slice if present and executable
353 - (2) install the slice-provided initscript (as per the initscript tag) as
354 - /etc/init.d/vinit.slice
355 - (3) as a result the initscript are now triggered by rc as part of the
356 - standard vserver .. start, properly attached to the vserver,
357 - and properly killed upon vserver .. stop
358 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
359
360 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
361 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
362 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
363 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
364 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
365 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
366 - cleanup: nodemanger now is a class; however plugins are still dumb modules
367 - cleanup: does not depend on obsolete Set
368
369 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
370 - tagging before RC
371
372 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
373 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
374 - Added some precautions to the slice id-saving code
375 - Added log message to code that records the slice id
376
377 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
378 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
379 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
380 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
381
382 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
383 - fix log_call in plugins/drl.py
384
385 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
386 - protect against nodes in migrated PLC's not having the hrn tag yet
387
388 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
389 - new omf-resctl and drl plugins
390 - specialaccount optimized to overwrite authorized keys only upon changes
391 - codemux plugin has support for a new 'ip' setting
392 - mainloop to display ordered modules&plugins at all times
393
394 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
395 - modules and plugins have a priority
396 - specialaccounts appears soon in the priority chain
397 - logger.log_call logs process output, and has a timeout
398 - vuser{add,del} run through bash -x
399 - nm initscript has support for 'service nm restartverbose'
400 - logs reviewed for consistency
401 - use hashlib module instead of sha when available
402
403 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
404 - first working version of 5.0:
405 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
406 - nodefamily is 3-fold with pldistro-fcdistro-arch
407 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
408 - (in addition to the 'vref' tag that's still exposed too)
409 - logging reviewed for more convenience
410 - support for 'service nm restartdebug'
411 - make sync knows how to publish uncommitted code on a test node
412
413 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
414 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
415
416 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
417 - support for f10 and f12 in the vref slice tag
418
419 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
420 - build on fedora12
421 - uses slicename 'sfacm' instead of 'genicw'
422
423 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
424 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
425 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
426 - days ago.
427
428 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
429 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
430 - self-contained. With this change, they will be able to refer to the attributes associated with a
431 - slice.
432
433 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
434 - fix for syntax error
435
436 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
437 - -fixed problem with sioc import at the build side
438 - -bwlimit.set() now accepts the device and does not asume that it is eth0
439
440 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
441 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
442
443 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
444 - The seed for random previously was the meaning of life (i.e., 42) but
445 - that resulted in a not so random choice for the hmac.  This
446 - implementation now uses a random.seed that is based on the current
447 - time.
448
449 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
450 - Minor fix such that sliverauth.py makes a more specific call to
451 - GetSliceTags that include that specific tagname it is looking for.
452
453 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
454 - Fix bug that prevented 'OVERRIDES' for working correctly.
455
456 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
457 - Increase disk limits to 10G per sliver
458 - Sanity check slice for home directory before starting (hack)
459 - Check codemux arguments
460
461 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
462 - * Fix Delegation
463 - * Move plcapi in plugin-api GetSlivers() calls.
464 - * Persistent Authcheck and resync session when auth failure
465
466 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
467 - Disabling sliverauth module.  Not ready for deployment.
468
469 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
470 - Fixing overrides semantics.
471
472 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
473 - Generalized plugins
474 - Fixed initscript start up bug.
475
476 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
477 - * Fix delegation authentication problem
478 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
479
480 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
481 - * Rerun initscripts when slice goes from disabled to enabled.
482
483 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
484 - * Update session key when out of synch with PLC
485 - * PLCDefaults uses tagname
486
487 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
488 - log invokations of vsys
489
490 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
491
492 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
493
494 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
495 - Codemux supports multiple hosts mapping to single slice
496 - Fixed bug in delegation support where tickets delivered weren't
497   being passed to sm.deliver_ticket().
498
499 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
500 - Codemux now configured via slice attribute (host,port)
501 - Support for multiple vserver reference images (including different archs)
502 - Mom BW emails are sent to list defined by MyPLC's config
503 - Sirius BW loans honored correctly.  Fixed.
504 - BW totals preserved for dynamic slices so as not to game the system.
505
506 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
507 - Configures vsys via vsys slice attribute {name: vsys, value: script}
508 - CPU reservations are now calculated via percentages instead of shares
509 - BW totals preserved for dynamic slices
510 - Closes bug where node cap sets off bw slice alarms for all slices.
511
512 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
513 - Switched to SVN.
514
515 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
516 - Initial build.