fix comment
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 2.1
5 %define taglevel 18
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
136 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
137 - initial check-in of privatebridge plugin.
138
139 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
140 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
141
142 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
143 - fix slices not deleted properly when they use vsys
144
145 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
146 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
147
148 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
149 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
150
151 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
152 - Bridge virtual interfaces to VLANs
153
154 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
155 - Add support for L2 bridged interfaces with public IPs inside a slice
156
157 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
158 - Support for freezing BestEffort slices for Vicci
159
160 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
161 - Change to use new vsh (wrapper for lxcsu)
162
163 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
164 - add missing import
165 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
166
167 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
168 - tag 2.1-7 was broken for OMF-friendly slices
169 - expose_ssh_dir was erroneously defined on the Worker class
170
171 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
172 - bwlimitlxc now ships with plnode-utils
173
174 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
175 - set LD_PRELOAD for linux-containers nodes
176
177 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
178 - first complete version for vs and lxc - functional but not thoroughly tested though
179
180 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
181 - split packaging in 3 (lib, lxc, vs)
182 - this tag will only work with lxc though
183
184 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
185 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
186
187 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
188 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
189 - purpose being to be able to run this branch on vserver nodes as well
190
191 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
192 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
193 - passes tests with lxc but won't build against vs due to conflict
194 - as bwlimit.py also ships with util-vserver-pl
195
196 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
197 - refactoring: isolate initscript functionality
198 - aimed at making initscript implementation with lxc straightforward
199 - show stack trace when module loading fails
200 - accounts.py renamed into account.py for consistency
201
202 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
203 - /var/log/nodemanager shows duration of mainloop
204
205 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
206 - first working draft for dealing with libvirt/lxc on f16 nodes
207 - not expected to work with mainline nodes (use 2.0 for that for now)
208
209 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
210 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
211
212 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
213 - Added memory scheduling to core scheduler
214 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
215
216 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
217 - tweaked log policy for the core scheduler
218 - curlwrapper has an optional verbose mode
219
220 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
221 - fixes for hmac and omf_control tags
222 - optional besteffort flag to core scheduler
223 - logrotate entry for /var/log/nodemanager.daemon
224 - a template for bash initscripts
225
226 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
227 - rename initscript_body into initscript_code
228 - fix generic vinit for broken bash syntax &>>
229
230 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
231 - new initscript_body slice tag, with stop and restart
232 - generic vinit script live updated
233 - new coresched module
234 - protect against non-existing vsys scripts
235 - use Config. instead of globals
236
237 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
238 - more robust reservation plugin
239
240 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
241 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
242 - reservation plugin more robust
243
244 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
245 - pass device to bwlimit
246
247 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
248 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
249
250 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
251 - Catch all exceptions for sfa plugin
252
253 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
254 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
255
256 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
257 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
258
259 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
260 - plugins/sliverauth.py improvements
261
262 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
263 - Disable sfagids plugin
264
265 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
266 - Re-tag nodemanager to include conflicted commits
267
268 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
269 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
270 - sfagids plugin deleted
271 - band-aid patch for lack of GetSliceFamily removed
272
273 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
274
275 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
276 - revert curlwrapper to former forking-curl version
277 - fixes in the omf plugin for ssh key location and node hrn
278 - set umask 0022 in tools.daemon
279
280 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
281 - configure omf-resctl for keys
282
283 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
284 - fix key generation
285
286 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
287 - name changes and fix typos
288
289 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
290 - remove config and options parameters from start function
291
292 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
293 - working version of reservable nodes
294 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
295 - dismantled the -s|--startup option (no convincing need for that)
296 - simpler and more robust init.d/nm
297 - initscript content management through replace_file_with_string
298 - sliverauth uses replace_file_with_string
299 - curlwrapper has a debug mode
300
301 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
302 - pretty-printing/normalized python code - hopefully neutral
303
304 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
305 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
306 - that triggers /etc/init.d/vinit.slice if present and executable
307 - (2) install the slice-provided initscript (as per the initscript tag) as
308 - /etc/init.d/vinit.slice
309 - (3) as a result the initscript are now triggered by rc as part of the
310 - standard vserver .. start, properly attached to the vserver,
311 - and properly killed upon vserver .. stop
312 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
313
314 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
315 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
316 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
317 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
318 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
319 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
320 - cleanup: nodemanger now is a class; however plugins are still dumb modules
321 - cleanup: does not depend on obsolete Set
322
323 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
324 - tagging before RC
325
326 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
327 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
328 - Added some precautions to the slice id-saving code
329 - Added log message to code that records the slice id
330
331 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
332 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
333 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
334 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
335
336 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
337 - fix log_call in plugins/drl.py
338
339 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
340 - protect against nodes in migrated PLC's not having the hrn tag yet
341
342 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
343 - new omf-resctl and drl plugins
344 - specialaccount optimized to overwrite authorized keys only upon changes
345 - codemux plugin has support for a new 'ip' setting
346 - mainloop to display ordered modules&plugins at all times
347
348 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
349 - modules and plugins have a priority
350 - specialaccounts appears soon in the priority chain
351 - logger.log_call logs process output, and has a timeout
352 - vuser{add,del} run through bash -x
353 - nm initscript has support for 'service nm restartverbose'
354 - logs reviewed for consistency
355 - use hashlib module instead of sha when available
356
357 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
358 - first working version of 5.0:
359 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
360 - nodefamily is 3-fold with pldistro-fcdistro-arch
361 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
362 - (in addition to the 'vref' tag that's still exposed too)
363 - logging reviewed for more convenience
364 - support for 'service nm restartdebug'
365 - make sync knows how to publish uncommitted code on a test node
366
367 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
368 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
369
370 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
371 - support for f10 and f12 in the vref slice tag
372
373 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
374 - build on fedora12
375 - uses slicename 'sfacm' instead of 'genicw'
376
377 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
378 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
379 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
380 - days ago.
381
382 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
383 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
384 - self-contained. With this change, they will be able to refer to the attributes associated with a
385 - slice.
386
387 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
388 - fix for syntax error
389
390 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
391 - -fixed problem with sioc import at the build side
392 - -bwlimit.set() now accepts the device and does not asume that it is eth0
393
394 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
395 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
396
397 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
398 - The seed for random previously was the meaning of life (i.e., 42) but
399 - that resulted in a not so random choice for the hmac.  This
400 - implementation now uses a random.seed that is based on the current
401 - time.
402
403 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
404 - Minor fix such that sliverauth.py makes a more specific call to
405 - GetSliceTags that include that specific tagname it is looking for.
406
407 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
408 - Fix bug that prevented 'OVERRIDES' for working correctly.
409
410 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
411 - Increase disk limits to 10G per sliver
412 - Sanity check slice for home directory before starting (hack)
413 - Check codemux arguments
414
415 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
416 - * Fix Delegation
417 - * Move plcapi in plugin-api GetSlivers() calls.
418 - * Persistent Authcheck and resync session when auth failure
419
420 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
421 - Disabling sliverauth module.  Not ready for deployment.
422
423 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
424 - Fixing overrides semantics.
425
426 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
427 - Generalized plugins
428 - Fixed initscript start up bug.
429
430 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
431 - * Fix delegation authentication problem
432 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
433
434 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
435 - * Rerun initscripts when slice goes from disabled to enabled.
436
437 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
438 - * Update session key when out of synch with PLC
439 - * PLCDefaults uses tagname
440
441 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
442 - log invokations of vsys
443
444 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
445
446 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
447
448 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
449 - Codemux supports multiple hosts mapping to single slice
450 - Fixed bug in delegation support where tickets delivered weren't
451   being passed to sm.deliver_ticket().
452 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
453 - Codemux now configured via slice attribute (host,port)
454 - Support for multiple vserver reference images (including different archs)
455 - Mom BW emails are sent to list defined by MyPLC's config
456 - Sirius BW loans honored correctly.  Fixed.
457 - BW totals preserved for dynamic slices so as not to game the system.
458 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
459 - Configures vsys via vsys slice attribute {name: vsys, value: script}
460 - CPU reservations are now calculated via percentages instead of shares
461 - BW totals preserved for dynamic slices
462 - Closes bug where node cap sets off bw slice alarms for all slices.
463
464 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
465 - Switched to SVN.
466
467 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
468 - Initial build.