2b8bc80e45c86da909030ad44c14bb10df347285
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 2.1
5 %define taglevel 6
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37
38 %description
39 The PlanetLab Node Manager manages all aspects of PlanetLab node and
40 slice management once the node has been initialized and configured by
41 the Boot Manager. It periodically contacts its management authority
42 for configuration updates. It provides an XML-RPC API for performing
43 local operations on slices.
44 nodemanager-lib only provides a skeleton and needs as a companion
45 either nodemanager-vs or nodemanager-lxc
46
47 %prep
48 %setup -q
49
50 %build
51 # make manages the C and Python stuff
52 %{__make} %{?_smp_mflags} lib
53
54 %install
55 # make manages the C and Python stuff
56 rm -rf $RPM_BUILD_ROOT
57 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
58 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
59
60 # install the sliver initscript (that triggers the slice initscript if any)
61 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
62 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
63 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64
65 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
66 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
67 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
68
69 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
70
71 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
72 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
73 install -D -m 644 bwlimitlxc.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/bwlimitlxc.py
74
75 ##########
76 %post
77 # tmp - handle file renamings; old names are from 2.0-8
78 renamings="
79 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
80 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
81 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
82 /var/log/nm@/var/log/nodemanager
83 /var/log/nm.daemon@/var/log/nodemanager.daemon
84 /var/run/nm.pid@/var/run/nodemanager.pid
85 /tmp/sliver_mgr.api@/tmp/nodemanager.api
86 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
87 "
88 for renaming in $renamings; do
89   old=$(echo $renaming | cut -d@ -f1)
90   new=$(echo $renaming | cut -d@ -f2)
91   newdir=$(dirname $new)
92   if [ -e "$old" -a ! -e "$new" ] ; then
93       mkdir -p $newdir
94       mv -f $old $new
95   fi
96 done
97 #
98 chkconfig --add conf_files
99 chkconfig conf_files on
100 chkconfig --add nm
101 chkconfig nm on
102 chkconfig --add fuse-pl
103 chkconfig fuse-pl on
104 if [ "$PL_BOOTCD" != "1" ] ; then
105         service nm restart
106         service fuse-pl restart
107 fi
108
109 ##########
110 %preun
111 # 0 = erase, 1 = upgrade
112 if [ $1 -eq 0 ] ; then
113     chkconfig fuse-pl off
114     chkconfig --del fuse-pl
115     chkconfig nm off
116     chkconfig --del nm
117     chkconfig conf_files off
118     chkconfig --del conf_files
119 fi
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(-,root,root,-)
126 %{_datadir}/NodeManager/
127 %{_bindir}/forward_api_calls
128 %{_initrddir}/
129 %{_sysconfdir}/logrotate.d/nodemanager
130 /var/lib/
131 /bin/sshsh
132 %{python_sitearch}/bwlimitlxc.py*
133
134 %changelog
135 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
136 - set LD_PRELOAD for linux-containers nodes
137
138 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
139 - first complete version for vs and lxc - functional but not thoroughly tested though
140
141 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
142 - split packaging in 3 (lib, lxc, vs)
143 - this tag will only work with lxc though
144
145 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
146 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
147
148 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
149 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
150 - purpose being to be able to run this branch on vserver nodes as well
151
152 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
153 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
154 - passes tests with lxc but won't build against vs due to conflict
155 - as bwlimit.py also ships with util-vserver-pl
156
157 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
158 - refactoring: isolate initscript functionality
159 - aimed at making initscript implementation with lxc straightforward
160 - show stack trace when module loading fails
161 - accounts.py renamed into account.py for consistency
162
163 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
164 - /var/log/nodemanager shows duration of mainloop
165
166 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
167 - first working draft for dealing with libvirt/lxc on f16 nodes
168 - not expected to work with mainline nodes (use 2.0 for that for now)
169
170 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
171 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
172
173 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
174 - Added memory scheduling to core scheduler
175 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
176
177 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
178 - tweaked log policy for the core scheduler
179 - curlwrapper has an optional verbose mode
180
181 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
182 - fixes for hmac and omf_control tags
183 - optional besteffort flag to core scheduler
184 - logrotate entry for /var/log/nodemanager.daemon
185 - a template for bash initscripts
186
187 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
188 - rename initscript_body into initscript_code
189 - fix generic vinit for broken bash syntax &>>
190
191 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
192 - new initscript_body slice tag, with stop and restart
193 - generic vinit script live updated
194 - new coresched module
195 - protect against non-existing vsys scripts
196 - use Config. instead of globals
197
198 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
199 - more robust reservation plugin
200
201 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
202 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
203 - reservation plugin more robust
204
205 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
206 - pass device to bwlimit
207
208 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
209 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
210
211 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
212 - Catch all exceptions for sfa plugin
213
214 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
215 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
216
217 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
218 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
219
220 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
221 - plugins/sliverauth.py improvements
222
223 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
224 - Disable sfagids plugin
225
226 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
227 - Re-tag nodemanager to include conflicted commits
228
229 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
230 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
231 - sfagids plugin deleted
232 - band-aid patch for lack of GetSliceFamily removed
233
234 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
235
236 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
237 - revert curlwrapper to former forking-curl version
238 - fixes in the omf plugin for ssh key location and node hrn
239 - set umask 0022 in tools.daemon
240
241 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
242 - configure omf-resctl for keys
243
244 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
245 - fix key generation
246
247 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
248 - name changes and fix typos
249
250 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
251 - remove config and options parameters from start function
252
253 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
254 - working version of reservable nodes
255 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
256 - dismantled the -s|--startup option (no convincing need for that)
257 - simpler and more robust init.d/nm
258 - initscript content management through replace_file_with_string
259 - sliverauth uses replace_file_with_string
260 - curlwrapper has a debug mode
261
262 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
263 - pretty-printing/normalized python code - hopefully neutral
264
265 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
266 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
267 - that triggers /etc/init.d/vinit.slice if present and executable
268 - (2) install the slice-provided initscript (as per the initscript tag) as
269 - /etc/init.d/vinit.slice
270 - (3) as a result the initscript are now triggered by rc as part of the
271 - standard vserver .. start, properly attached to the vserver,
272 - and properly killed upon vserver .. stop
273 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
274
275 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
276 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
277 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
278 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
279 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
280 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
281 - cleanup: nodemanger now is a class; however plugins are still dumb modules
282 - cleanup: does not depend on obsolete Set
283
284 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
285 - tagging before RC
286
287 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
288 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
289 - Added some precautions to the slice id-saving code
290 - Added log message to code that records the slice id
291
292 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
293 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
294 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
295 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
296
297 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
298 - fix log_call in plugins/drl.py
299
300 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
301 - protect against nodes in migrated PLC's not having the hrn tag yet
302
303 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
304 - new omf-resctl and drl plugins
305 - specialaccount optimized to overwrite authorized keys only upon changes
306 - codemux plugin has support for a new 'ip' setting
307 - mainloop to display ordered modules&plugins at all times
308
309 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
310 - modules and plugins have a priority
311 - specialaccounts appears soon in the priority chain
312 - logger.log_call logs process output, and has a timeout
313 - vuser{add,del} run through bash -x
314 - nm initscript has support for 'service nm restartverbose'
315 - logs reviewed for consistency
316 - use hashlib module instead of sha when available
317
318 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
319 - first working version of 5.0:
320 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
321 - nodefamily is 3-fold with pldistro-fcdistro-arch
322 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
323 - (in addition to the 'vref' tag that's still exposed too)
324 - logging reviewed for more convenience
325 - support for 'service nm restartdebug'
326 - make sync knows how to publish uncommitted code on a test node
327
328 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
329 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
330
331 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
332 - support for f10 and f12 in the vref slice tag
333
334 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
335 - build on fedora12
336 - uses slicename 'sfacm' instead of 'genicw'
337
338 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
339 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
340 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
341 - days ago.
342
343 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
344 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
345 - self-contained. With this change, they will be able to refer to the attributes associated with a
346 - slice.
347
348 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
349 - fix for syntax error
350
351 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
352 - -fixed problem with sioc import at the build side
353 - -bwlimit.set() now accepts the device and does not asume that it is eth0
354
355 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
356 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
357
358 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
359 - The seed for random previously was the meaning of life (i.e., 42) but
360 - that resulted in a not so random choice for the hmac.  This
361 - implementation now uses a random.seed that is based on the current
362 - time.
363
364 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
365 - Minor fix such that sliverauth.py makes a more specific call to
366 - GetSliceTags that include that specific tagname it is looking for.
367
368 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
369 - Fix bug that prevented 'OVERRIDES' for working correctly.
370
371 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
372 - Increase disk limits to 10G per sliver
373 - Sanity check slice for home directory before starting (hack)
374 - Check codemux arguments
375
376 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
377 - * Fix Delegation
378 - * Move plcapi in plugin-api GetSlivers() calls.
379 - * Persistent Authcheck and resync session when auth failure
380
381 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
382 - Disabling sliverauth module.  Not ready for deployment.
383
384 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
385 - Fixing overrides semantics.
386
387 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
388 - Generalized plugins
389 - Fixed initscript start up bug.
390
391 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
392 - * Fix delegation authentication problem
393 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
394
395 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
396 - * Rerun initscripts when slice goes from disabled to enabled.
397
398 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
399 - * Update session key when out of synch with PLC
400 - * PLCDefaults uses tagname
401
402 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
403 - log invokations of vsys
404
405 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
406
407 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
408
409 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
410 - Codemux supports multiple hosts mapping to single slice
411 - Fixed bug in delegation support where tickets delivered weren't
412   being passed to sm.deliver_ticket().
413 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
414 - Codemux now configured via slice attribute (host,port)
415 - Support for multiple vserver reference images (including different archs)
416 - Mom BW emails are sent to list defined by MyPLC's config
417 - Sirius BW loans honored correctly.  Fixed.
418 - BW totals preserved for dynamic slices so as not to game the system.
419 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
420 - Configures vsys via vsys slice attribute {name: vsys, value: script}
421 - CPU reservations are now calculated via percentages instead of shares
422 - BW totals preserved for dynamic slices
423 - Closes bug where node cap sets off bw slice alarms for all slices.
424
425 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
426 - Switched to SVN.
427
428 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
429 - Initial build.