install for sytemd *or* init
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 9
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ########## use initscripts or systemd unit files to start installed services
10 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
11 %define make_options WITH_SYSTEMD=true
12 %define initdir /usr/lib/systemd/system
13 %else
14 %define make_options WITH_INIT=true
15 %define initdir %{_initrddir}
16 %endif
17
18 Summary: PlanetLab Node Manager Library
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: PlanetLab
23 Group: System Environment/Daemons
24 Source0: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27 Vendor: PlanetLab
28 Packager: PlanetLab Central <support@planet-lab.org>
29 Distribution: PlanetLab %{plrelease}
30 URL: %{SCMURL}
31
32 # not possible because of forward_api_calls
33 #BuildArch: noarch
34
35 # make sure we can invoke systemctl in post install script
36 %if "%{initdir}" != "%{_initrddir}"
37 Requires: systemd
38 %endif
39
40 # Uses function decorators
41 Requires: python >= 2.7
42 # connecting PLC
43 Requires: python-pycurl
44 # Signed tickets
45 Requires: gnupg
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48 # we do need the slice images in any case
49 Requires: sliceimage-%{slicefamily}
50 # for bwlimit
51 Requires: plnode-utils
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59 nodemanager-lib only provides a skeleton and needs as a companion
60 either nodemanager-vs or nodemanager-lxc
61
62 ##############################
63 %prep
64 %setup -q
65
66 %build
67 # make manages the C and Python stuff
68 %{__make} %{?_smp_mflags} %{make_options} lib 
69
70 %install
71 # make manages the C and Python stuff
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
74
75 ##############################
76 %post
77 ########## traditional init
78 %if "%{initdir}" == "%{_initrddir}"
79 ##########
80 chkconfig --add conf_files
81 chkconfig conf_files on
82 chkconfig --add nm
83 chkconfig nm on
84 chkconfig --add fuse-pl
85 chkconfig fuse-pl on
86 if [ "$PL_BOOTCD" != "1" ] ; then
87     service nm restart
88     service fuse-pl restart
89 fi
90 ##########
91 %else
92 ########## systemd
93 systemctl enable nm.service
94 systemctl enable conf_files.service
95 # empty
96 #systemctl enable fuse-pl.service
97 if [ "$PL_BOOTCD" != "1" ] ; then
98     systemctl restart nm.service
99 #    systemctl restart fuse-pl.service
100 fi
101 ##########
102 %endif
103
104 ##############################
105 %preun
106 # 0 = erase, 1 = upgrade
107 ########## traditional init
108 %if "%{initdir}" == "%{_initrddir}"
109 ##########
110 if [ $1 -eq 0 ] ; then
111     chkconfig fuse-pl off
112     chkconfig --del fuse-pl
113     chkconfig nm off
114     chkconfig --del nm
115     chkconfig conf_files off
116     chkconfig --del conf_files
117 fi
118 ##########
119 %else
120 ########## systemd
121 if [ $1 -eq 0 ] ; then
122 #    systemctl disable fuse-pl.service
123     systemctl disable conf_files.service
124     systemctl disable nm.service
125 fi
126 ##########
127 %endif
128
129 ##############################
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(-,root,root,-)
135 %{_datadir}/NodeManager/
136 %{_bindir}/forward_api_calls
137 %{initdir}/
138 %{_sysconfdir}/logrotate.d/nodemanager
139 /var/lib/nodemanager/
140 /bin/sshsh
141
142 %changelog
143 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
144 - fixes in hostmap, and in interfaces
145 - new vsys_sysctl
146 - privatebridge now comes with nodemanager-lib
147
148 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
149 - omf plugin does not block any longer when running trigger script
150 - log goes into sliver's /var/log instead
151
152 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
153 - new install-scripts target in Makefile
154 - conf_files and fuse-pl initscripts chmod'ed +x
155 - omf_resctl config template tweaked to use _slicename_%_hostname_
156
157 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
158 - make sure to create /etc/planetlab/virt so others can read that
159 - expose get_node_virt() and command_in_slice()
160 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
161 - user's .profile now has right owner
162 - other tweaks in lxc slivers
163
164 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
165 - lxc slice creation: slice user was created with unknown gid - fixed
166 - lxc slice creation: .profile for root and user - fixed
167
168 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
169 - fix umounting of ssh directory when deleting omf-friendly slivers
170 - support for writing cgroups in subsystems other than cpuset
171 - add xid to template match
172 - finer-grained split between -lib -vs and -lxc
173 - first roughly complete omf_resctl for omfv6
174 - minor fix for when getslivers does not have minexemptrate
175
176 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
177 - Fix path, machine arch in slivers
178
179 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
180
181 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
182 - no-op bump to 5.2 to be in line with the rest of the system
183
184 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
185 - improvements to privatebridge
186
187 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
188 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
189
190 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
191 - fix wrong gre tunnel deleted when topology changes
192
193 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
194 - Update /etc/hosts in slivers from sliver_hostmap tag.
195
196 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
197 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
198 - initial check-in of privatebridge plugin.
199
200 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
201 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
202
203 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
204 - fix slices not deleted properly when they use vsys
205
206 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
207 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
208
209 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
210 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
211
212 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
213 - Bridge virtual interfaces to VLANs
214
215 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
216 - Add support for L2 bridged interfaces with public IPs inside a slice
217
218 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
219 - Support for freezing BestEffort slices for Vicci
220
221 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
222 - Change to use new vsh (wrapper for lxcsu)
223
224 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
225 - add missing import
226 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
227
228 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
229 - tag 2.1-7 was broken for OMF-friendly slices
230 - expose_ssh_dir was erroneously defined on the Worker class
231
232 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
233 - bwlimitlxc now ships with plnode-utils
234
235 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
236 - set LD_PRELOAD for linux-containers nodes
237
238 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
239 - first complete version for vs and lxc - functional but not thoroughly tested though
240
241 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
242 - split packaging in 3 (lib, lxc, vs)
243 - this tag will only work with lxc though
244
245 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
246 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
247
248 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
249 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
250 - purpose being to be able to run this branch on vserver nodes as well
251
252 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
253 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
254 - passes tests with lxc but won't build against vs due to conflict
255 - as bwlimit.py also ships with util-vserver-pl
256
257 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
258 - refactoring: isolate initscript functionality
259 - aimed at making initscript implementation with lxc straightforward
260 - show stack trace when module loading fails
261 - accounts.py renamed into account.py for consistency
262
263 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
264 - /var/log/nodemanager shows duration of mainloop
265
266 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
267 - first working draft for dealing with libvirt/lxc on f16 nodes
268 - not expected to work with mainline nodes (use 2.0 for that for now)
269
270 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
271 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
272
273 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
274 - Added memory scheduling to core scheduler
275 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
276
277 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
278 - tweaked log policy for the core scheduler
279 - curlwrapper has an optional verbose mode
280
281 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
282 - fixes for hmac and omf_control tags
283 - optional besteffort flag to core scheduler
284 - logrotate entry for /var/log/nodemanager.daemon
285 - a template for bash initscripts
286
287 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
288 - rename initscript_body into initscript_code
289 - fix generic vinit for broken bash syntax &>>
290
291 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
292 - new initscript_body slice tag, with stop and restart
293 - generic vinit script live updated
294 - new coresched module
295 - protect against non-existing vsys scripts
296 - use Config. instead of globals
297
298 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
299 - more robust reservation plugin
300
301 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
302 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
303 - reservation plugin more robust
304
305 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
306 - pass device to bwlimit
307
308 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
309 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
310
311 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
312 - Catch all exceptions for sfa plugin
313
314 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
315 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
316
317 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
318 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
319
320 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
321 - plugins/sliverauth.py improvements
322
323 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
324 - Disable sfagids plugin
325
326 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
327 - Re-tag nodemanager to include conflicted commits
328
329 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
330 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
331 - sfagids plugin deleted
332 - band-aid patch for lack of GetSliceFamily removed
333
334 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
335
336 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
337 - revert curlwrapper to former forking-curl version
338 - fixes in the omf plugin for ssh key location and node hrn
339 - set umask 0022 in tools.daemon
340
341 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
342 - configure omf-resctl for keys
343
344 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
345 - fix key generation
346
347 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
348 - name changes and fix typos
349
350 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
351 - remove config and options parameters from start function
352
353 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
354 - working version of reservable nodes
355 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
356 - dismantled the -s|--startup option (no convincing need for that)
357 - simpler and more robust init.d/nm
358 - initscript content management through replace_file_with_string
359 - sliverauth uses replace_file_with_string
360 - curlwrapper has a debug mode
361
362 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
363 - pretty-printing/normalized python code - hopefully neutral
364
365 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
366 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
367 - that triggers /etc/init.d/vinit.slice if present and executable
368 - (2) install the slice-provided initscript (as per the initscript tag) as
369 - /etc/init.d/vinit.slice
370 - (3) as a result the initscript are now triggered by rc as part of the
371 - standard vserver .. start, properly attached to the vserver,
372 - and properly killed upon vserver .. stop
373 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
374
375 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
376 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
377 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
378 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
379 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
380 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
381 - cleanup: nodemanger now is a class; however plugins are still dumb modules
382 - cleanup: does not depend on obsolete Set
383
384 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
385 - tagging before RC
386
387 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
388 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
389 - Added some precautions to the slice id-saving code
390 - Added log message to code that records the slice id
391
392 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
393 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
394 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
395 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
396
397 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
398 - fix log_call in plugins/drl.py
399
400 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
401 - protect against nodes in migrated PLC's not having the hrn tag yet
402
403 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
404 - new omf-resctl and drl plugins
405 - specialaccount optimized to overwrite authorized keys only upon changes
406 - codemux plugin has support for a new 'ip' setting
407 - mainloop to display ordered modules&plugins at all times
408
409 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
410 - modules and plugins have a priority
411 - specialaccounts appears soon in the priority chain
412 - logger.log_call logs process output, and has a timeout
413 - vuser{add,del} run through bash -x
414 - nm initscript has support for 'service nm restartverbose'
415 - logs reviewed for consistency
416 - use hashlib module instead of sha when available
417
418 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
419 - first working version of 5.0:
420 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
421 - nodefamily is 3-fold with pldistro-fcdistro-arch
422 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
423 - (in addition to the 'vref' tag that's still exposed too)
424 - logging reviewed for more convenience
425 - support for 'service nm restartdebug'
426 - make sync knows how to publish uncommitted code on a test node
427
428 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
429 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
430
431 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
432 - support for f10 and f12 in the vref slice tag
433
434 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
435 - build on fedora12
436 - uses slicename 'sfacm' instead of 'genicw'
437
438 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
439 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
440 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
441 - days ago.
442
443 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
444 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
445 - self-contained. With this change, they will be able to refer to the attributes associated with a
446 - slice.
447
448 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
449 - fix for syntax error
450
451 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
452 - -fixed problem with sioc import at the build side
453 - -bwlimit.set() now accepts the device and does not asume that it is eth0
454
455 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
456 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
457
458 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
459 - The seed for random previously was the meaning of life (i.e., 42) but
460 - that resulted in a not so random choice for the hmac.  This
461 - implementation now uses a random.seed that is based on the current
462 - time.
463
464 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
465 - Minor fix such that sliverauth.py makes a more specific call to
466 - GetSliceTags that include that specific tagname it is looking for.
467
468 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
469 - Fix bug that prevented 'OVERRIDES' for working correctly.
470
471 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
472 - Increase disk limits to 10G per sliver
473 - Sanity check slice for home directory before starting (hack)
474 - Check codemux arguments
475
476 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
477 - * Fix Delegation
478 - * Move plcapi in plugin-api GetSlivers() calls.
479 - * Persistent Authcheck and resync session when auth failure
480
481 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
482 - Disabling sliverauth module.  Not ready for deployment.
483
484 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
485 - Fixing overrides semantics.
486
487 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
488 - Generalized plugins
489 - Fixed initscript start up bug.
490
491 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
492 - * Fix delegation authentication problem
493 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
494
495 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
496 - * Rerun initscripts when slice goes from disabled to enabled.
497
498 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
499 - * Update session key when out of synch with PLC
500 - * PLCDefaults uses tagname
501
502 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
503 - log invokations of vsys
504
505 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
506
507 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
508
509 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
510 - Codemux supports multiple hosts mapping to single slice
511 - Fixed bug in delegation support where tickets delivered weren't
512   being passed to sm.deliver_ticket().
513
514 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
515 - Codemux now configured via slice attribute (host,port)
516 - Support for multiple vserver reference images (including different archs)
517 - Mom BW emails are sent to list defined by MyPLC's config
518 - Sirius BW loans honored correctly.  Fixed.
519 - BW totals preserved for dynamic slices so as not to game the system.
520
521 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
522 - Configures vsys via vsys slice attribute {name: vsys, value: script}
523 - CPU reservations are now calculated via percentages instead of shares
524 - BW totals preserved for dynamic slices
525 - Closes bug where node cap sets off bw slice alarms for all slices.
526
527 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
528 - Switched to SVN.
529
530 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
531 - Initial build.