Setting tag nodemanager-2.1-12
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 2.1
5 %define taglevel 12
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
136 - Add support for L2 bridged interfaces with public IPs inside a slice
137
138 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
139 - Support for freezing BestEffort slices for Vicci
140
141 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
142 - Change to use new vsh (wrapper for lxcsu)
143
144 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
145 - add missing import
146 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
147
148 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
149 - tag 2.1-7 was broken for OMF-friendly slices
150 - expose_ssh_dir was erroneously defined on the Worker class
151
152 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
153 - bwlimitlxc now ships with plnode-utils
154
155 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
156 - set LD_PRELOAD for linux-containers nodes
157
158 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
159 - first complete version for vs and lxc - functional but not thoroughly tested though
160
161 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
162 - split packaging in 3 (lib, lxc, vs)
163 - this tag will only work with lxc though
164
165 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
166 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
167
168 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
169 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
170 - purpose being to be able to run this branch on vserver nodes as well
171
172 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
173 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
174 - passes tests with lxc but won't build against vs due to conflict
175 - as bwlimit.py also ships with util-vserver-pl
176
177 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
178 - refactoring: isolate initscript functionality
179 - aimed at making initscript implementation with lxc straightforward
180 - show stack trace when module loading fails
181 - accounts.py renamed into account.py for consistency
182
183 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
184 - /var/log/nodemanager shows duration of mainloop
185
186 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
187 - first working draft for dealing with libvirt/lxc on f16 nodes
188 - not expected to work with mainline nodes (use 2.0 for that for now)
189
190 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
191 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
192
193 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
194 - Added memory scheduling to core scheduler
195 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
196
197 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
198 - tweaked log policy for the core scheduler
199 - curlwrapper has an optional verbose mode
200
201 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
202 - fixes for hmac and omf_control tags
203 - optional besteffort flag to core scheduler
204 - logrotate entry for /var/log/nodemanager.daemon
205 - a template for bash initscripts
206
207 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
208 - rename initscript_body into initscript_code
209 - fix generic vinit for broken bash syntax &>>
210
211 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
212 - new initscript_body slice tag, with stop and restart
213 - generic vinit script live updated
214 - new coresched module
215 - protect against non-existing vsys scripts
216 - use Config. instead of globals
217
218 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
219 - more robust reservation plugin
220
221 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
222 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
223 - reservation plugin more robust
224
225 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
226 - pass device to bwlimit
227
228 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
229 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
230
231 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
232 - Catch all exceptions for sfa plugin
233
234 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
235 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
236
237 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
238 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
239
240 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
241 - plugins/sliverauth.py improvements
242
243 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
244 - Disable sfagids plugin
245
246 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
247 - Re-tag nodemanager to include conflicted commits
248
249 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
250 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
251 - sfagids plugin deleted
252 - band-aid patch for lack of GetSliceFamily removed
253
254 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
255
256 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
257 - revert curlwrapper to former forking-curl version
258 - fixes in the omf plugin for ssh key location and node hrn
259 - set umask 0022 in tools.daemon
260
261 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
262 - configure omf-resctl for keys
263
264 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
265 - fix key generation
266
267 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
268 - name changes and fix typos
269
270 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
271 - remove config and options parameters from start function
272
273 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
274 - working version of reservable nodes
275 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
276 - dismantled the -s|--startup option (no convincing need for that)
277 - simpler and more robust init.d/nm
278 - initscript content management through replace_file_with_string
279 - sliverauth uses replace_file_with_string
280 - curlwrapper has a debug mode
281
282 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
283 - pretty-printing/normalized python code - hopefully neutral
284
285 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
286 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
287 - that triggers /etc/init.d/vinit.slice if present and executable
288 - (2) install the slice-provided initscript (as per the initscript tag) as
289 - /etc/init.d/vinit.slice
290 - (3) as a result the initscript are now triggered by rc as part of the
291 - standard vserver .. start, properly attached to the vserver,
292 - and properly killed upon vserver .. stop
293 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
294
295 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
296 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
297 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
298 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
299 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
300 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
301 - cleanup: nodemanger now is a class; however plugins are still dumb modules
302 - cleanup: does not depend on obsolete Set
303
304 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
305 - tagging before RC
306
307 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
308 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
309 - Added some precautions to the slice id-saving code
310 - Added log message to code that records the slice id
311
312 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
313 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
314 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
315 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
316
317 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
318 - fix log_call in plugins/drl.py
319
320 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
321 - protect against nodes in migrated PLC's not having the hrn tag yet
322
323 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
324 - new omf-resctl and drl plugins
325 - specialaccount optimized to overwrite authorized keys only upon changes
326 - codemux plugin has support for a new 'ip' setting
327 - mainloop to display ordered modules&plugins at all times
328
329 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
330 - modules and plugins have a priority
331 - specialaccounts appears soon in the priority chain
332 - logger.log_call logs process output, and has a timeout
333 - vuser{add,del} run through bash -x
334 - nm initscript has support for 'service nm restartverbose'
335 - logs reviewed for consistency
336 - use hashlib module instead of sha when available
337
338 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
339 - first working version of 5.0:
340 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
341 - nodefamily is 3-fold with pldistro-fcdistro-arch
342 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
343 - (in addition to the 'vref' tag that's still exposed too)
344 - logging reviewed for more convenience
345 - support for 'service nm restartdebug'
346 - make sync knows how to publish uncommitted code on a test node
347
348 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
349 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
350
351 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
352 - support for f10 and f12 in the vref slice tag
353
354 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
355 - build on fedora12
356 - uses slicename 'sfacm' instead of 'genicw'
357
358 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
359 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
360 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
361 - days ago.
362
363 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
364 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
365 - self-contained. With this change, they will be able to refer to the attributes associated with a
366 - slice.
367
368 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
369 - fix for syntax error
370
371 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
372 - -fixed problem with sioc import at the build side
373 - -bwlimit.set() now accepts the device and does not asume that it is eth0
374
375 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
376 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
377
378 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
379 - The seed for random previously was the meaning of life (i.e., 42) but
380 - that resulted in a not so random choice for the hmac.  This
381 - implementation now uses a random.seed that is based on the current
382 - time.
383
384 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
385 - Minor fix such that sliverauth.py makes a more specific call to
386 - GetSliceTags that include that specific tagname it is looking for.
387
388 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
389 - Fix bug that prevented 'OVERRIDES' for working correctly.
390
391 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
392 - Increase disk limits to 10G per sliver
393 - Sanity check slice for home directory before starting (hack)
394 - Check codemux arguments
395
396 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
397 - * Fix Delegation
398 - * Move plcapi in plugin-api GetSlivers() calls.
399 - * Persistent Authcheck and resync session when auth failure
400
401 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
402 - Disabling sliverauth module.  Not ready for deployment.
403
404 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
405 - Fixing overrides semantics.
406
407 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
408 - Generalized plugins
409 - Fixed initscript start up bug.
410
411 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
412 - * Fix delegation authentication problem
413 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
414
415 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
416 - * Rerun initscripts when slice goes from disabled to enabled.
417
418 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
419 - * Update session key when out of synch with PLC
420 - * PLCDefaults uses tagname
421
422 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
423 - log invokations of vsys
424
425 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
426
427 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
428
429 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
430 - Codemux supports multiple hosts mapping to single slice
431 - Fixed bug in delegation support where tickets delivered weren't
432   being passed to sm.deliver_ticket().
433 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
434 - Codemux now configured via slice attribute (host,port)
435 - Support for multiple vserver reference images (including different archs)
436 - Mom BW emails are sent to list defined by MyPLC's config
437 - Sirius BW loans honored correctly.  Fixed.
438 - BW totals preserved for dynamic slices so as not to game the system.
439 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
440 - Configures vsys via vsys slice attribute {name: vsys, value: script}
441 - CPU reservations are now calculated via percentages instead of shares
442 - BW totals preserved for dynamic slices
443 - Closes bug where node cap sets off bw slice alarms for all slices.
444
445 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
446 - Switched to SVN.
447
448 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
449 - Initial build.