Bump tag level
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 2.1
5 %define taglevel 10.2.openvswitch
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
136 - Change to use new vsh (wrapper for lxcsu)
137
138 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
139 - add missing import
140 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
141
142 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
143 - tag 2.1-7 was broken for OMF-friendly slices
144 - expose_ssh_dir was erroneously defined on the Worker class
145
146 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
147 - bwlimitlxc now ships with plnode-utils
148
149 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
150 - set LD_PRELOAD for linux-containers nodes
151
152 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
153 - first complete version for vs and lxc - functional but not thoroughly tested though
154
155 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
156 - split packaging in 3 (lib, lxc, vs)
157 - this tag will only work with lxc though
158
159 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
160 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
161
162 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
163 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
164 - purpose being to be able to run this branch on vserver nodes as well
165
166 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
167 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
168 - passes tests with lxc but won't build against vs due to conflict
169 - as bwlimit.py also ships with util-vserver-pl
170
171 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
172 - refactoring: isolate initscript functionality
173 - aimed at making initscript implementation with lxc straightforward
174 - show stack trace when module loading fails
175 - accounts.py renamed into account.py for consistency
176
177 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
178 - /var/log/nodemanager shows duration of mainloop
179
180 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
181 - first working draft for dealing with libvirt/lxc on f16 nodes
182 - not expected to work with mainline nodes (use 2.0 for that for now)
183
184 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
185 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
186
187 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
188 - Added memory scheduling to core scheduler
189 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
190
191 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
192 - tweaked log policy for the core scheduler
193 - curlwrapper has an optional verbose mode
194
195 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
196 - fixes for hmac and omf_control tags
197 - optional besteffort flag to core scheduler
198 - logrotate entry for /var/log/nodemanager.daemon
199 - a template for bash initscripts
200
201 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
202 - rename initscript_body into initscript_code
203 - fix generic vinit for broken bash syntax &>>
204
205 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
206 - new initscript_body slice tag, with stop and restart
207 - generic vinit script live updated
208 - new coresched module
209 - protect against non-existing vsys scripts
210 - use Config. instead of globals
211
212 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
213 - more robust reservation plugin
214
215 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
216 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
217 - reservation plugin more robust
218
219 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
220 - pass device to bwlimit
221
222 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
223 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
224
225 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
226 - Catch all exceptions for sfa plugin
227
228 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
229 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
230
231 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
232 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
233
234 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
235 - plugins/sliverauth.py improvements
236
237 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
238 - Disable sfagids plugin
239
240 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
241 - Re-tag nodemanager to include conflicted commits
242
243 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
244 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
245 - sfagids plugin deleted
246 - band-aid patch for lack of GetSliceFamily removed
247
248 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
249
250 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
251 - revert curlwrapper to former forking-curl version
252 - fixes in the omf plugin for ssh key location and node hrn
253 - set umask 0022 in tools.daemon
254
255 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
256 - configure omf-resctl for keys
257
258 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
259 - fix key generation
260
261 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
262 - name changes and fix typos
263
264 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
265 - remove config and options parameters from start function
266
267 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
268 - working version of reservable nodes
269 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
270 - dismantled the -s|--startup option (no convincing need for that)
271 - simpler and more robust init.d/nm
272 - initscript content management through replace_file_with_string
273 - sliverauth uses replace_file_with_string
274 - curlwrapper has a debug mode
275
276 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
277 - pretty-printing/normalized python code - hopefully neutral
278
279 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
280 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
281 - that triggers /etc/init.d/vinit.slice if present and executable
282 - (2) install the slice-provided initscript (as per the initscript tag) as
283 - /etc/init.d/vinit.slice
284 - (3) as a result the initscript are now triggered by rc as part of the
285 - standard vserver .. start, properly attached to the vserver,
286 - and properly killed upon vserver .. stop
287 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
288
289 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
290 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
291 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
292 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
293 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
294 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
295 - cleanup: nodemanger now is a class; however plugins are still dumb modules
296 - cleanup: does not depend on obsolete Set
297
298 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
299 - tagging before RC
300
301 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
302 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
303 - Added some precautions to the slice id-saving code
304 - Added log message to code that records the slice id
305
306 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
307 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
308 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
309 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
310
311 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
312 - fix log_call in plugins/drl.py
313
314 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
315 - protect against nodes in migrated PLC's not having the hrn tag yet
316
317 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
318 - new omf-resctl and drl plugins
319 - specialaccount optimized to overwrite authorized keys only upon changes
320 - codemux plugin has support for a new 'ip' setting
321 - mainloop to display ordered modules&plugins at all times
322
323 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
324 - modules and plugins have a priority
325 - specialaccounts appears soon in the priority chain
326 - logger.log_call logs process output, and has a timeout
327 - vuser{add,del} run through bash -x
328 - nm initscript has support for 'service nm restartverbose'
329 - logs reviewed for consistency
330 - use hashlib module instead of sha when available
331
332 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
333 - first working version of 5.0:
334 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
335 - nodefamily is 3-fold with pldistro-fcdistro-arch
336 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
337 - (in addition to the 'vref' tag that's still exposed too)
338 - logging reviewed for more convenience
339 - support for 'service nm restartdebug'
340 - make sync knows how to publish uncommitted code on a test node
341
342 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
343 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
344
345 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
346 - support for f10 and f12 in the vref slice tag
347
348 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
349 - build on fedora12
350 - uses slicename 'sfacm' instead of 'genicw'
351
352 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
353 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
354 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
355 - days ago.
356
357 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
358 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
359 - self-contained. With this change, they will be able to refer to the attributes associated with a
360 - slice.
361
362 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
363 - fix for syntax error
364
365 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
366 - -fixed problem with sioc import at the build side
367 - -bwlimit.set() now accepts the device and does not asume that it is eth0
368
369 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
370 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
371
372 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
373 - The seed for random previously was the meaning of life (i.e., 42) but
374 - that resulted in a not so random choice for the hmac.  This
375 - implementation now uses a random.seed that is based on the current
376 - time.
377
378 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
379 - Minor fix such that sliverauth.py makes a more specific call to
380 - GetSliceTags that include that specific tagname it is looking for.
381
382 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
383 - Fix bug that prevented 'OVERRIDES' for working correctly.
384
385 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
386 - Increase disk limits to 10G per sliver
387 - Sanity check slice for home directory before starting (hack)
388 - Check codemux arguments
389
390 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
391 - * Fix Delegation
392 - * Move plcapi in plugin-api GetSlivers() calls.
393 - * Persistent Authcheck and resync session when auth failure
394
395 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
396 - Disabling sliverauth module.  Not ready for deployment.
397
398 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
399 - Fixing overrides semantics.
400
401 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
402 - Generalized plugins
403 - Fixed initscript start up bug.
404
405 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
406 - * Fix delegation authentication problem
407 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
408
409 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
410 - * Rerun initscripts when slice goes from disabled to enabled.
411
412 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
413 - * Update session key when out of synch with PLC
414 - * PLCDefaults uses tagname
415
416 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
417 - log invokations of vsys
418
419 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
420
421 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
422
423 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
424 - Codemux supports multiple hosts mapping to single slice
425 - Fixed bug in delegation support where tickets delivered weren't
426   being passed to sm.deliver_ticket().
427 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
428 - Codemux now configured via slice attribute (host,port)
429 - Support for multiple vserver reference images (including different archs)
430 - Mom BW emails are sent to list defined by MyPLC's config
431 - Sirius BW loans honored correctly.  Fixed.
432 - BW totals preserved for dynamic slices so as not to game the system.
433 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
434 - Configures vsys via vsys slice attribute {name: vsys, value: script}
435 - CPU reservations are now calculated via percentages instead of shares
436 - BW totals preserved for dynamic slices
437 - Closes bug where node cap sets off bw slice alarms for all slices.
438
439 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
440 - Switched to SVN.
441
442 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
443 - Initial build.