Setting tag nodemanager-5.2-11
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 11
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ########## use initscripts or systemd unit files to start installed services
10 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
11 %define make_options WITH_SYSTEMD=true
12 %define initdir /usr/lib/systemd/system
13 %else
14 %define make_options WITH_INIT=true
15 %define initdir %{_initrddir}
16 %endif
17
18 Summary: PlanetLab Node Manager Library
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: PlanetLab
23 Group: System Environment/Daemons
24 Source0: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27 Vendor: PlanetLab
28 Packager: PlanetLab Central <support@planet-lab.org>
29 Distribution: PlanetLab %{plrelease}
30 URL: %{SCMURL}
31
32 # not possible because of forward_api_calls
33 #BuildArch: noarch
34
35 # make sure we can invoke systemctl in post install script
36 %if "%{initdir}" != "%{_initrddir}"
37 Requires: systemd
38 %endif
39
40 # Uses function decorators
41 Requires: python >= 2.7
42 # connecting PLC
43 Requires: python-pycurl
44 # Signed tickets
45 Requires: gnupg
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48 # we do need the slice images in any case
49 Requires: sliceimage-%{slicefamily}
50 # for bwlimit
51 Requires: plnode-utils
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59 nodemanager-lib only provides a skeleton and needs as a companion
60 either nodemanager-vs or nodemanager-lxc
61
62 ##############################
63 %prep
64 %setup -q
65
66 %build
67 # make manages the C and Python stuff
68 %{__make} %{?_smp_mflags} %{make_options} lib 
69
70 %install
71 # make manages the C and Python stuff
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
74
75 ##############################
76 %post
77 ########## traditional init
78 %if "%{initdir}" == "%{_initrddir}"
79 ##########
80 chkconfig --add conf_files
81 chkconfig conf_files on
82 chkconfig --add nm
83 chkconfig nm on
84 chkconfig --add fuse-pl
85 chkconfig fuse-pl on
86 if [ "$PL_BOOTCD" != "1" ] ; then
87     service nm restart
88     service fuse-pl restart
89 fi
90 ##########
91 %else
92 ########## systemd
93 systemctl enable nm.service
94 systemctl enable conf_files.service
95 # empty
96 #systemctl enable fuse-pl.service
97 if [ "$PL_BOOTCD" != "1" ] ; then
98     systemctl restart nm.service
99 #    systemctl restart fuse-pl.service
100 fi
101 ##########
102 %endif
103
104 ##############################
105 %preun
106 # 0 = erase, 1 = upgrade
107 ########## traditional init
108 %if "%{initdir}" == "%{_initrddir}"
109 ##########
110 if [ $1 -eq 0 ] ; then
111     chkconfig fuse-pl off
112     chkconfig --del fuse-pl
113     chkconfig nm off
114     chkconfig --del nm
115     chkconfig conf_files off
116     chkconfig --del conf_files
117 fi
118 ##########
119 %else
120 ########## systemd
121 if [ $1 -eq 0 ] ; then
122 #    systemctl disable fuse-pl.service
123     systemctl disable conf_files.service
124     systemctl disable nm.service
125 fi
126 ##########
127 %endif
128
129 ##############################
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(-,root,root,-)
135 %{_datadir}/NodeManager/
136 %{_bindir}/forward_api_calls
137 %{initdir}/
138 %{_sysconfdir}/logrotate.d/nodemanager
139 /var/lib/nodemanager/
140 %config(noreplace) /etc/sysconfig/nodemanager
141
142 %changelog
143 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
144 - ship /etc/sysconfig/nodemanager
145 - trash sshsh
146
147 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
148 - comes with systemd native unit files on >= f18
149 - user-provided initscript gets started through systemd in slivers >= f18
150 - smarter to locate cgroups for various versions of libvirt
151 - nicer log format - and log program termination
152 - tweaks in codemux plugin
153 - bug fixes in libvirt driver, esp. for finding out if domain is running
154
155 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
156 - fixes in hostmap, and in interfaces
157 - new vsys_sysctl
158 - privatebridge now comes with nodemanager-lib
159
160 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
161 - omf plugin does not block any longer when running trigger script
162 - log goes into sliver's /var/log instead
163
164 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
165 - new install-scripts target in Makefile
166 - conf_files and fuse-pl initscripts chmod'ed +x
167 - omf_resctl config template tweaked to use _slicename_%_hostname_
168
169 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
170 - make sure to create /etc/planetlab/virt so others can read that
171 - expose get_node_virt() and command_in_slice()
172 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
173 - user's .profile now has right owner
174 - other tweaks in lxc slivers
175
176 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
177 - lxc slice creation: slice user was created with unknown gid - fixed
178 - lxc slice creation: .profile for root and user - fixed
179
180 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
181 - fix umounting of ssh directory when deleting omf-friendly slivers
182 - support for writing cgroups in subsystems other than cpuset
183 - add xid to template match
184 - finer-grained split between -lib -vs and -lxc
185 - first roughly complete omf_resctl for omfv6
186 - minor fix for when getslivers does not have minexemptrate
187
188 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
189 - Fix path, machine arch in slivers
190
191 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
192
193 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
194 - no-op bump to 5.2 to be in line with the rest of the system
195
196 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
197 - improvements to privatebridge
198
199 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
200 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
201
202 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
203 - fix wrong gre tunnel deleted when topology changes
204
205 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
206 - Update /etc/hosts in slivers from sliver_hostmap tag.
207
208 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
209 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
210 - initial check-in of privatebridge plugin.
211
212 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
213 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
214
215 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
216 - fix slices not deleted properly when they use vsys
217
218 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
219 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
220
221 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
222 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
223
224 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
225 - Bridge virtual interfaces to VLANs
226
227 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
228 - Add support for L2 bridged interfaces with public IPs inside a slice
229
230 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
231 - Support for freezing BestEffort slices for Vicci
232
233 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
234 - Change to use new vsh (wrapper for lxcsu)
235
236 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
237 - add missing import
238 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
239
240 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
241 - tag 2.1-7 was broken for OMF-friendly slices
242 - expose_ssh_dir was erroneously defined on the Worker class
243
244 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
245 - bwlimitlxc now ships with plnode-utils
246
247 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
248 - set LD_PRELOAD for linux-containers nodes
249
250 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
251 - first complete version for vs and lxc - functional but not thoroughly tested though
252
253 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
254 - split packaging in 3 (lib, lxc, vs)
255 - this tag will only work with lxc though
256
257 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
258 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
259
260 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
261 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
262 - purpose being to be able to run this branch on vserver nodes as well
263
264 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
265 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
266 - passes tests with lxc but won't build against vs due to conflict
267 - as bwlimit.py also ships with util-vserver-pl
268
269 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
270 - refactoring: isolate initscript functionality
271 - aimed at making initscript implementation with lxc straightforward
272 - show stack trace when module loading fails
273 - accounts.py renamed into account.py for consistency
274
275 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
276 - /var/log/nodemanager shows duration of mainloop
277
278 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
279 - first working draft for dealing with libvirt/lxc on f16 nodes
280 - not expected to work with mainline nodes (use 2.0 for that for now)
281
282 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
283 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
284
285 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
286 - Added memory scheduling to core scheduler
287 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
288
289 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
290 - tweaked log policy for the core scheduler
291 - curlwrapper has an optional verbose mode
292
293 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
294 - fixes for hmac and omf_control tags
295 - optional besteffort flag to core scheduler
296 - logrotate entry for /var/log/nodemanager.daemon
297 - a template for bash initscripts
298
299 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
300 - rename initscript_body into initscript_code
301 - fix generic vinit for broken bash syntax &>>
302
303 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
304 - new initscript_body slice tag, with stop and restart
305 - generic vinit script live updated
306 - new coresched module
307 - protect against non-existing vsys scripts
308 - use Config. instead of globals
309
310 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
311 - more robust reservation plugin
312
313 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
314 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
315 - reservation plugin more robust
316
317 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
318 - pass device to bwlimit
319
320 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
321 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
322
323 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
324 - Catch all exceptions for sfa plugin
325
326 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
327 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
328
329 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
330 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
331
332 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
333 - plugins/sliverauth.py improvements
334
335 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
336 - Disable sfagids plugin
337
338 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
339 - Re-tag nodemanager to include conflicted commits
340
341 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
342 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
343 - sfagids plugin deleted
344 - band-aid patch for lack of GetSliceFamily removed
345
346 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
347
348 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
349 - revert curlwrapper to former forking-curl version
350 - fixes in the omf plugin for ssh key location and node hrn
351 - set umask 0022 in tools.daemon
352
353 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
354 - configure omf-resctl for keys
355
356 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
357 - fix key generation
358
359 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
360 - name changes and fix typos
361
362 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
363 - remove config and options parameters from start function
364
365 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
366 - working version of reservable nodes
367 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
368 - dismantled the -s|--startup option (no convincing need for that)
369 - simpler and more robust init.d/nm
370 - initscript content management through replace_file_with_string
371 - sliverauth uses replace_file_with_string
372 - curlwrapper has a debug mode
373
374 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
375 - pretty-printing/normalized python code - hopefully neutral
376
377 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
378 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
379 - that triggers /etc/init.d/vinit.slice if present and executable
380 - (2) install the slice-provided initscript (as per the initscript tag) as
381 - /etc/init.d/vinit.slice
382 - (3) as a result the initscript are now triggered by rc as part of the
383 - standard vserver .. start, properly attached to the vserver,
384 - and properly killed upon vserver .. stop
385 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
386
387 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
388 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
389 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
390 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
391 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
392 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
393 - cleanup: nodemanger now is a class; however plugins are still dumb modules
394 - cleanup: does not depend on obsolete Set
395
396 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
397 - tagging before RC
398
399 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
400 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
401 - Added some precautions to the slice id-saving code
402 - Added log message to code that records the slice id
403
404 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
405 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
406 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
407 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
408
409 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
410 - fix log_call in plugins/drl.py
411
412 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
413 - protect against nodes in migrated PLC's not having the hrn tag yet
414
415 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
416 - new omf-resctl and drl plugins
417 - specialaccount optimized to overwrite authorized keys only upon changes
418 - codemux plugin has support for a new 'ip' setting
419 - mainloop to display ordered modules&plugins at all times
420
421 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
422 - modules and plugins have a priority
423 - specialaccounts appears soon in the priority chain
424 - logger.log_call logs process output, and has a timeout
425 - vuser{add,del} run through bash -x
426 - nm initscript has support for 'service nm restartverbose'
427 - logs reviewed for consistency
428 - use hashlib module instead of sha when available
429
430 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
431 - first working version of 5.0:
432 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
433 - nodefamily is 3-fold with pldistro-fcdistro-arch
434 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
435 - (in addition to the 'vref' tag that's still exposed too)
436 - logging reviewed for more convenience
437 - support for 'service nm restartdebug'
438 - make sync knows how to publish uncommitted code on a test node
439
440 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
441 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
442
443 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
444 - support for f10 and f12 in the vref slice tag
445
446 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
447 - build on fedora12
448 - uses slicename 'sfacm' instead of 'genicw'
449
450 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
451 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
452 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
453 - days ago.
454
455 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
456 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
457 - self-contained. With this change, they will be able to refer to the attributes associated with a
458 - slice.
459
460 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
461 - fix for syntax error
462
463 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
464 - -fixed problem with sioc import at the build side
465 - -bwlimit.set() now accepts the device and does not asume that it is eth0
466
467 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
468 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
469
470 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
471 - The seed for random previously was the meaning of life (i.e., 42) but
472 - that resulted in a not so random choice for the hmac.  This
473 - implementation now uses a random.seed that is based on the current
474 - time.
475
476 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
477 - Minor fix such that sliverauth.py makes a more specific call to
478 - GetSliceTags that include that specific tagname it is looking for.
479
480 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
481 - Fix bug that prevented 'OVERRIDES' for working correctly.
482
483 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
484 - Increase disk limits to 10G per sliver
485 - Sanity check slice for home directory before starting (hack)
486 - Check codemux arguments
487
488 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
489 - * Fix Delegation
490 - * Move plcapi in plugin-api GetSlivers() calls.
491 - * Persistent Authcheck and resync session when auth failure
492
493 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
494 - Disabling sliverauth module.  Not ready for deployment.
495
496 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
497 - Fixing overrides semantics.
498
499 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
500 - Generalized plugins
501 - Fixed initscript start up bug.
502
503 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
504 - * Fix delegation authentication problem
505 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
506
507 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
508 - * Rerun initscripts when slice goes from disabled to enabled.
509
510 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
511 - * Update session key when out of synch with PLC
512 - * PLCDefaults uses tagname
513
514 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
515 - log invokations of vsys
516
517 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
518
519 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
520
521 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
522 - Codemux supports multiple hosts mapping to single slice
523 - Fixed bug in delegation support where tickets delivered weren't
524   being passed to sm.deliver_ticket().
525
526 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
527 - Codemux now configured via slice attribute (host,port)
528 - Support for multiple vserver reference images (including different archs)
529 - Mom BW emails are sent to list defined by MyPLC's config
530 - Sirius BW loans honored correctly.  Fixed.
531 - BW totals preserved for dynamic slices so as not to game the system.
532
533 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
534 - Configures vsys via vsys slice attribute {name: vsys, value: script}
535 - CPU reservations are now calculated via percentages instead of shares
536 - BW totals preserved for dynamic slices
537 - Closes bug where node cap sets off bw slice alarms for all slices.
538
539 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
540 - Switched to SVN.
541
542 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
543 - Initial build.