bump to 5.2
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 0
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
136 - improvements to privatebridge
137
138 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
139 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
140
141 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
142 - fix wrong gre tunnel deleted when topology changes
143
144 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
145 - Update /etc/hosts in slivers from sliver_hostmap tag.
146
147 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
148 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
149 - initial check-in of privatebridge plugin.
150
151 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
152 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
153
154 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
155 - fix slices not deleted properly when they use vsys
156
157 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
158 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
159
160 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
161 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
162
163 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
164 - Bridge virtual interfaces to VLANs
165
166 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
167 - Add support for L2 bridged interfaces with public IPs inside a slice
168
169 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
170 - Support for freezing BestEffort slices for Vicci
171
172 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
173 - Change to use new vsh (wrapper for lxcsu)
174
175 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
176 - add missing import
177 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
178
179 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
180 - tag 2.1-7 was broken for OMF-friendly slices
181 - expose_ssh_dir was erroneously defined on the Worker class
182
183 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
184 - bwlimitlxc now ships with plnode-utils
185
186 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
187 - set LD_PRELOAD for linux-containers nodes
188
189 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
190 - first complete version for vs and lxc - functional but not thoroughly tested though
191
192 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
193 - split packaging in 3 (lib, lxc, vs)
194 - this tag will only work with lxc though
195
196 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
197 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
198
199 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
200 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
201 - purpose being to be able to run this branch on vserver nodes as well
202
203 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
204 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
205 - passes tests with lxc but won't build against vs due to conflict
206 - as bwlimit.py also ships with util-vserver-pl
207
208 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
209 - refactoring: isolate initscript functionality
210 - aimed at making initscript implementation with lxc straightforward
211 - show stack trace when module loading fails
212 - accounts.py renamed into account.py for consistency
213
214 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
215 - /var/log/nodemanager shows duration of mainloop
216
217 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
218 - first working draft for dealing with libvirt/lxc on f16 nodes
219 - not expected to work with mainline nodes (use 2.0 for that for now)
220
221 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
222 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
223
224 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
225 - Added memory scheduling to core scheduler
226 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
227
228 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
229 - tweaked log policy for the core scheduler
230 - curlwrapper has an optional verbose mode
231
232 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
233 - fixes for hmac and omf_control tags
234 - optional besteffort flag to core scheduler
235 - logrotate entry for /var/log/nodemanager.daemon
236 - a template for bash initscripts
237
238 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
239 - rename initscript_body into initscript_code
240 - fix generic vinit for broken bash syntax &>>
241
242 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
243 - new initscript_body slice tag, with stop and restart
244 - generic vinit script live updated
245 - new coresched module
246 - protect against non-existing vsys scripts
247 - use Config. instead of globals
248
249 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
250 - more robust reservation plugin
251
252 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
253 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
254 - reservation plugin more robust
255
256 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
257 - pass device to bwlimit
258
259 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
260 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
261
262 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
263 - Catch all exceptions for sfa plugin
264
265 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
266 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
267
268 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
269 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
270
271 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
272 - plugins/sliverauth.py improvements
273
274 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
275 - Disable sfagids plugin
276
277 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
278 - Re-tag nodemanager to include conflicted commits
279
280 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
281 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
282 - sfagids plugin deleted
283 - band-aid patch for lack of GetSliceFamily removed
284
285 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
286
287 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
288 - revert curlwrapper to former forking-curl version
289 - fixes in the omf plugin for ssh key location and node hrn
290 - set umask 0022 in tools.daemon
291
292 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
293 - configure omf-resctl for keys
294
295 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
296 - fix key generation
297
298 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
299 - name changes and fix typos
300
301 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
302 - remove config and options parameters from start function
303
304 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
305 - working version of reservable nodes
306 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
307 - dismantled the -s|--startup option (no convincing need for that)
308 - simpler and more robust init.d/nm
309 - initscript content management through replace_file_with_string
310 - sliverauth uses replace_file_with_string
311 - curlwrapper has a debug mode
312
313 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
314 - pretty-printing/normalized python code - hopefully neutral
315
316 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
317 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
318 - that triggers /etc/init.d/vinit.slice if present and executable
319 - (2) install the slice-provided initscript (as per the initscript tag) as
320 - /etc/init.d/vinit.slice
321 - (3) as a result the initscript are now triggered by rc as part of the
322 - standard vserver .. start, properly attached to the vserver,
323 - and properly killed upon vserver .. stop
324 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
325
326 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
327 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
328 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
329 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
330 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
331 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
332 - cleanup: nodemanger now is a class; however plugins are still dumb modules
333 - cleanup: does not depend on obsolete Set
334
335 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
336 - tagging before RC
337
338 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
339 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
340 - Added some precautions to the slice id-saving code
341 - Added log message to code that records the slice id
342
343 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
344 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
345 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
346 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
347
348 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
349 - fix log_call in plugins/drl.py
350
351 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
352 - protect against nodes in migrated PLC's not having the hrn tag yet
353
354 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
355 - new omf-resctl and drl plugins
356 - specialaccount optimized to overwrite authorized keys only upon changes
357 - codemux plugin has support for a new 'ip' setting
358 - mainloop to display ordered modules&plugins at all times
359
360 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
361 - modules and plugins have a priority
362 - specialaccounts appears soon in the priority chain
363 - logger.log_call logs process output, and has a timeout
364 - vuser{add,del} run through bash -x
365 - nm initscript has support for 'service nm restartverbose'
366 - logs reviewed for consistency
367 - use hashlib module instead of sha when available
368
369 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
370 - first working version of 5.0:
371 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
372 - nodefamily is 3-fold with pldistro-fcdistro-arch
373 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
374 - (in addition to the 'vref' tag that's still exposed too)
375 - logging reviewed for more convenience
376 - support for 'service nm restartdebug'
377 - make sync knows how to publish uncommitted code on a test node
378
379 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
380 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
381
382 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
383 - support for f10 and f12 in the vref slice tag
384
385 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
386 - build on fedora12
387 - uses slicename 'sfacm' instead of 'genicw'
388
389 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
390 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
391 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
392 - days ago.
393
394 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
395 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
396 - self-contained. With this change, they will be able to refer to the attributes associated with a
397 - slice.
398
399 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
400 - fix for syntax error
401
402 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
403 - -fixed problem with sioc import at the build side
404 - -bwlimit.set() now accepts the device and does not asume that it is eth0
405
406 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
407 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
408
409 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
410 - The seed for random previously was the meaning of life (i.e., 42) but
411 - that resulted in a not so random choice for the hmac.  This
412 - implementation now uses a random.seed that is based on the current
413 - time.
414
415 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
416 - Minor fix such that sliverauth.py makes a more specific call to
417 - GetSliceTags that include that specific tagname it is looking for.
418
419 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
420 - Fix bug that prevented 'OVERRIDES' for working correctly.
421
422 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
423 - Increase disk limits to 10G per sliver
424 - Sanity check slice for home directory before starting (hack)
425 - Check codemux arguments
426
427 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
428 - * Fix Delegation
429 - * Move plcapi in plugin-api GetSlivers() calls.
430 - * Persistent Authcheck and resync session when auth failure
431
432 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
433 - Disabling sliverauth module.  Not ready for deployment.
434
435 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
436 - Fixing overrides semantics.
437
438 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
439 - Generalized plugins
440 - Fixed initscript start up bug.
441
442 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
443 - * Fix delegation authentication problem
444 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
445
446 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
447 - * Rerun initscripts when slice goes from disabled to enabled.
448
449 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
450 - * Update session key when out of synch with PLC
451 - * PLCDefaults uses tagname
452
453 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
454 - log invokations of vsys
455
456 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
457
458 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
459
460 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
461 - Codemux supports multiple hosts mapping to single slice
462 - Fixed bug in delegation support where tickets delivered weren't
463   being passed to sm.deliver_ticket().
464 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
465 - Codemux now configured via slice attribute (host,port)
466 - Support for multiple vserver reference images (including different archs)
467 - Mom BW emails are sent to list defined by MyPLC's config
468 - Sirius BW loans honored correctly.  Fixed.
469 - BW totals preserved for dynamic slices so as not to game the system.
470 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
471 - Configures vsys via vsys slice attribute {name: vsys, value: script}
472 - CPU reservations are now calculated via percentages instead of shares
473 - BW totals preserved for dynamic slices
474 - Closes bug where node cap sets off bw slice alarms for all slices.
475
476 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
477 - Switched to SVN.
478
479 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
480 - Initial build.