Setting tag nodemanager-5.2-6
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 6
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
136 - make sure to create /etc/planetlab/virt so others can read that
137 - expose get_node_virt() and command_in_slice()
138 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
139 - user's .profile now has right owner
140 - other tweaks in lxc slivers
141
142 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
143 - lxc slice creation: slice user was created with unknown gid - fixed
144 - lxc slice creation: .profile for root and user - fixed
145
146 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
147 - fix umounting of ssh directory when deleting omf-friendly slivers
148 - support for writing cgroups in subsystems other than cpuset
149 - add xid to template match
150 - finer-grained split between -lib -vs and -lxc
151 - first roughly complete omf_resctl for omfv6
152 - minor fix for when getslivers does not have minexemptrate
153
154 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
155 - Fix path, machine arch in slivers
156
157 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
158
159 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
160 - no-op bump to 5.2 to be in line with the rest of the system
161
162 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
163 - improvements to privatebridge
164
165 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
166 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
167
168 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
169 - fix wrong gre tunnel deleted when topology changes
170
171 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
172 - Update /etc/hosts in slivers from sliver_hostmap tag.
173
174 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
175 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
176 - initial check-in of privatebridge plugin.
177
178 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
179 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
180
181 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
182 - fix slices not deleted properly when they use vsys
183
184 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
185 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
186
187 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
188 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
189
190 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
191 - Bridge virtual interfaces to VLANs
192
193 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
194 - Add support for L2 bridged interfaces with public IPs inside a slice
195
196 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
197 - Support for freezing BestEffort slices for Vicci
198
199 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
200 - Change to use new vsh (wrapper for lxcsu)
201
202 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
203 - add missing import
204 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
205
206 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
207 - tag 2.1-7 was broken for OMF-friendly slices
208 - expose_ssh_dir was erroneously defined on the Worker class
209
210 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
211 - bwlimitlxc now ships with plnode-utils
212
213 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
214 - set LD_PRELOAD for linux-containers nodes
215
216 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
217 - first complete version for vs and lxc - functional but not thoroughly tested though
218
219 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
220 - split packaging in 3 (lib, lxc, vs)
221 - this tag will only work with lxc though
222
223 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
224 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
225
226 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
227 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
228 - purpose being to be able to run this branch on vserver nodes as well
229
230 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
231 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
232 - passes tests with lxc but won't build against vs due to conflict
233 - as bwlimit.py also ships with util-vserver-pl
234
235 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
236 - refactoring: isolate initscript functionality
237 - aimed at making initscript implementation with lxc straightforward
238 - show stack trace when module loading fails
239 - accounts.py renamed into account.py for consistency
240
241 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
242 - /var/log/nodemanager shows duration of mainloop
243
244 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
245 - first working draft for dealing with libvirt/lxc on f16 nodes
246 - not expected to work with mainline nodes (use 2.0 for that for now)
247
248 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
249 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
250
251 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
252 - Added memory scheduling to core scheduler
253 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
254
255 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
256 - tweaked log policy for the core scheduler
257 - curlwrapper has an optional verbose mode
258
259 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
260 - fixes for hmac and omf_control tags
261 - optional besteffort flag to core scheduler
262 - logrotate entry for /var/log/nodemanager.daemon
263 - a template for bash initscripts
264
265 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
266 - rename initscript_body into initscript_code
267 - fix generic vinit for broken bash syntax &>>
268
269 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
270 - new initscript_body slice tag, with stop and restart
271 - generic vinit script live updated
272 - new coresched module
273 - protect against non-existing vsys scripts
274 - use Config. instead of globals
275
276 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
277 - more robust reservation plugin
278
279 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
280 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
281 - reservation plugin more robust
282
283 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
284 - pass device to bwlimit
285
286 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
287 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
288
289 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
290 - Catch all exceptions for sfa plugin
291
292 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
293 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
294
295 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
296 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
297
298 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
299 - plugins/sliverauth.py improvements
300
301 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
302 - Disable sfagids plugin
303
304 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
305 - Re-tag nodemanager to include conflicted commits
306
307 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
308 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
309 - sfagids plugin deleted
310 - band-aid patch for lack of GetSliceFamily removed
311
312 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
313
314 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
315 - revert curlwrapper to former forking-curl version
316 - fixes in the omf plugin for ssh key location and node hrn
317 - set umask 0022 in tools.daemon
318
319 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
320 - configure omf-resctl for keys
321
322 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
323 - fix key generation
324
325 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
326 - name changes and fix typos
327
328 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
329 - remove config and options parameters from start function
330
331 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
332 - working version of reservable nodes
333 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
334 - dismantled the -s|--startup option (no convincing need for that)
335 - simpler and more robust init.d/nm
336 - initscript content management through replace_file_with_string
337 - sliverauth uses replace_file_with_string
338 - curlwrapper has a debug mode
339
340 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
341 - pretty-printing/normalized python code - hopefully neutral
342
343 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
344 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
345 - that triggers /etc/init.d/vinit.slice if present and executable
346 - (2) install the slice-provided initscript (as per the initscript tag) as
347 - /etc/init.d/vinit.slice
348 - (3) as a result the initscript are now triggered by rc as part of the
349 - standard vserver .. start, properly attached to the vserver,
350 - and properly killed upon vserver .. stop
351 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
352
353 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
354 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
355 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
356 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
357 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
358 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
359 - cleanup: nodemanger now is a class; however plugins are still dumb modules
360 - cleanup: does not depend on obsolete Set
361
362 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
363 - tagging before RC
364
365 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
366 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
367 - Added some precautions to the slice id-saving code
368 - Added log message to code that records the slice id
369
370 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
371 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
372 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
373 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
374
375 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
376 - fix log_call in plugins/drl.py
377
378 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
379 - protect against nodes in migrated PLC's not having the hrn tag yet
380
381 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
382 - new omf-resctl and drl plugins
383 - specialaccount optimized to overwrite authorized keys only upon changes
384 - codemux plugin has support for a new 'ip' setting
385 - mainloop to display ordered modules&plugins at all times
386
387 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
388 - modules and plugins have a priority
389 - specialaccounts appears soon in the priority chain
390 - logger.log_call logs process output, and has a timeout
391 - vuser{add,del} run through bash -x
392 - nm initscript has support for 'service nm restartverbose'
393 - logs reviewed for consistency
394 - use hashlib module instead of sha when available
395
396 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
397 - first working version of 5.0:
398 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
399 - nodefamily is 3-fold with pldistro-fcdistro-arch
400 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
401 - (in addition to the 'vref' tag that's still exposed too)
402 - logging reviewed for more convenience
403 - support for 'service nm restartdebug'
404 - make sync knows how to publish uncommitted code on a test node
405
406 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
407 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
408
409 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
410 - support for f10 and f12 in the vref slice tag
411
412 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
413 - build on fedora12
414 - uses slicename 'sfacm' instead of 'genicw'
415
416 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
417 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
418 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
419 - days ago.
420
421 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
422 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
423 - self-contained. With this change, they will be able to refer to the attributes associated with a
424 - slice.
425
426 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
427 - fix for syntax error
428
429 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
430 - -fixed problem with sioc import at the build side
431 - -bwlimit.set() now accepts the device and does not asume that it is eth0
432
433 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
434 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
435
436 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
437 - The seed for random previously was the meaning of life (i.e., 42) but
438 - that resulted in a not so random choice for the hmac.  This
439 - implementation now uses a random.seed that is based on the current
440 - time.
441
442 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
443 - Minor fix such that sliverauth.py makes a more specific call to
444 - GetSliceTags that include that specific tagname it is looking for.
445
446 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
447 - Fix bug that prevented 'OVERRIDES' for working correctly.
448
449 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
450 - Increase disk limits to 10G per sliver
451 - Sanity check slice for home directory before starting (hack)
452 - Check codemux arguments
453
454 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
455 - * Fix Delegation
456 - * Move plcapi in plugin-api GetSlivers() calls.
457 - * Persistent Authcheck and resync session when auth failure
458
459 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
460 - Disabling sliverauth module.  Not ready for deployment.
461
462 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
463 - Fixing overrides semantics.
464
465 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
466 - Generalized plugins
467 - Fixed initscript start up bug.
468
469 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
470 - * Fix delegation authentication problem
471 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
472
473 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
474 - * Rerun initscripts when slice goes from disabled to enabled.
475
476 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
477 - * Update session key when out of synch with PLC
478 - * PLCDefaults uses tagname
479
480 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
481 - log invokations of vsys
482
483 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
484
485 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
486
487 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
488 - Codemux supports multiple hosts mapping to single slice
489 - Fixed bug in delegation support where tickets delivered weren't
490   being passed to sm.deliver_ticket().
491
492 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
493 - Codemux now configured via slice attribute (host,port)
494 - Support for multiple vserver reference images (including different archs)
495 - Mom BW emails are sent to list defined by MyPLC's config
496 - Sirius BW loans honored correctly.  Fixed.
497 - BW totals preserved for dynamic slices so as not to game the system.
498
499 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
500 - Configures vsys via vsys slice attribute {name: vsys, value: script}
501 - CPU reservations are now calculated via percentages instead of shares
502 - BW totals preserved for dynamic slices
503 - Closes bug where node cap sets off bw slice alarms for all slices.
504
505 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
506 - Switched to SVN.
507
508 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
509 - Initial build.