change name of private IPs from slice_name.hostname to pvt.hostname
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 2.1
5 %define taglevel 20
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
136 - fix wrong gre tunnel deleted when topology changes
137
138 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
139 - Update /etc/hosts in slivers from sliver_hostmap tag.
140
141 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
142 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
143 - initial check-in of privatebridge plugin.
144
145 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
146 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
147
148 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
149 - fix slices not deleted properly when they use vsys
150
151 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
152 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
153
154 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
155 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
156
157 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
158 - Bridge virtual interfaces to VLANs
159
160 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
161 - Add support for L2 bridged interfaces with public IPs inside a slice
162
163 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
164 - Support for freezing BestEffort slices for Vicci
165
166 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
167 - Change to use new vsh (wrapper for lxcsu)
168
169 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
170 - add missing import
171 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
172
173 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
174 - tag 2.1-7 was broken for OMF-friendly slices
175 - expose_ssh_dir was erroneously defined on the Worker class
176
177 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
178 - bwlimitlxc now ships with plnode-utils
179
180 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
181 - set LD_PRELOAD for linux-containers nodes
182
183 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
184 - first complete version for vs and lxc - functional but not thoroughly tested though
185
186 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
187 - split packaging in 3 (lib, lxc, vs)
188 - this tag will only work with lxc though
189
190 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
191 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
192
193 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
194 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
195 - purpose being to be able to run this branch on vserver nodes as well
196
197 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
198 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
199 - passes tests with lxc but won't build against vs due to conflict
200 - as bwlimit.py also ships with util-vserver-pl
201
202 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
203 - refactoring: isolate initscript functionality
204 - aimed at making initscript implementation with lxc straightforward
205 - show stack trace when module loading fails
206 - accounts.py renamed into account.py for consistency
207
208 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
209 - /var/log/nodemanager shows duration of mainloop
210
211 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
212 - first working draft for dealing with libvirt/lxc on f16 nodes
213 - not expected to work with mainline nodes (use 2.0 for that for now)
214
215 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
216 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
217
218 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
219 - Added memory scheduling to core scheduler
220 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
221
222 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
223 - tweaked log policy for the core scheduler
224 - curlwrapper has an optional verbose mode
225
226 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
227 - fixes for hmac and omf_control tags
228 - optional besteffort flag to core scheduler
229 - logrotate entry for /var/log/nodemanager.daemon
230 - a template for bash initscripts
231
232 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
233 - rename initscript_body into initscript_code
234 - fix generic vinit for broken bash syntax &>>
235
236 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
237 - new initscript_body slice tag, with stop and restart
238 - generic vinit script live updated
239 - new coresched module
240 - protect against non-existing vsys scripts
241 - use Config. instead of globals
242
243 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
244 - more robust reservation plugin
245
246 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
247 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
248 - reservation plugin more robust
249
250 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
251 - pass device to bwlimit
252
253 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
254 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
255
256 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
257 - Catch all exceptions for sfa plugin
258
259 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
260 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
261
262 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
263 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
264
265 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
266 - plugins/sliverauth.py improvements
267
268 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
269 - Disable sfagids plugin
270
271 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
272 - Re-tag nodemanager to include conflicted commits
273
274 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
275 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
276 - sfagids plugin deleted
277 - band-aid patch for lack of GetSliceFamily removed
278
279 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
280
281 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
282 - revert curlwrapper to former forking-curl version
283 - fixes in the omf plugin for ssh key location and node hrn
284 - set umask 0022 in tools.daemon
285
286 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
287 - configure omf-resctl for keys
288
289 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
290 - fix key generation
291
292 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
293 - name changes and fix typos
294
295 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
296 - remove config and options parameters from start function
297
298 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
299 - working version of reservable nodes
300 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
301 - dismantled the -s|--startup option (no convincing need for that)
302 - simpler and more robust init.d/nm
303 - initscript content management through replace_file_with_string
304 - sliverauth uses replace_file_with_string
305 - curlwrapper has a debug mode
306
307 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
308 - pretty-printing/normalized python code - hopefully neutral
309
310 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
311 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
312 - that triggers /etc/init.d/vinit.slice if present and executable
313 - (2) install the slice-provided initscript (as per the initscript tag) as
314 - /etc/init.d/vinit.slice
315 - (3) as a result the initscript are now triggered by rc as part of the
316 - standard vserver .. start, properly attached to the vserver,
317 - and properly killed upon vserver .. stop
318 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
319
320 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
321 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
322 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
323 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
324 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
325 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
326 - cleanup: nodemanger now is a class; however plugins are still dumb modules
327 - cleanup: does not depend on obsolete Set
328
329 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
330 - tagging before RC
331
332 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
333 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
334 - Added some precautions to the slice id-saving code
335 - Added log message to code that records the slice id
336
337 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
338 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
339 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
340 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
341
342 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
343 - fix log_call in plugins/drl.py
344
345 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
346 - protect against nodes in migrated PLC's not having the hrn tag yet
347
348 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
349 - new omf-resctl and drl plugins
350 - specialaccount optimized to overwrite authorized keys only upon changes
351 - codemux plugin has support for a new 'ip' setting
352 - mainloop to display ordered modules&plugins at all times
353
354 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
355 - modules and plugins have a priority
356 - specialaccounts appears soon in the priority chain
357 - logger.log_call logs process output, and has a timeout
358 - vuser{add,del} run through bash -x
359 - nm initscript has support for 'service nm restartverbose'
360 - logs reviewed for consistency
361 - use hashlib module instead of sha when available
362
363 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
364 - first working version of 5.0:
365 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
366 - nodefamily is 3-fold with pldistro-fcdistro-arch
367 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
368 - (in addition to the 'vref' tag that's still exposed too)
369 - logging reviewed for more convenience
370 - support for 'service nm restartdebug'
371 - make sync knows how to publish uncommitted code on a test node
372
373 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
374 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
375
376 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
377 - support for f10 and f12 in the vref slice tag
378
379 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
380 - build on fedora12
381 - uses slicename 'sfacm' instead of 'genicw'
382
383 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
384 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
385 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
386 - days ago.
387
388 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
389 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
390 - self-contained. With this change, they will be able to refer to the attributes associated with a
391 - slice.
392
393 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
394 - fix for syntax error
395
396 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
397 - -fixed problem with sioc import at the build side
398 - -bwlimit.set() now accepts the device and does not asume that it is eth0
399
400 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
401 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
402
403 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
404 - The seed for random previously was the meaning of life (i.e., 42) but
405 - that resulted in a not so random choice for the hmac.  This
406 - implementation now uses a random.seed that is based on the current
407 - time.
408
409 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
410 - Minor fix such that sliverauth.py makes a more specific call to
411 - GetSliceTags that include that specific tagname it is looking for.
412
413 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
414 - Fix bug that prevented 'OVERRIDES' for working correctly.
415
416 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
417 - Increase disk limits to 10G per sliver
418 - Sanity check slice for home directory before starting (hack)
419 - Check codemux arguments
420
421 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
422 - * Fix Delegation
423 - * Move plcapi in plugin-api GetSlivers() calls.
424 - * Persistent Authcheck and resync session when auth failure
425
426 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
427 - Disabling sliverauth module.  Not ready for deployment.
428
429 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
430 - Fixing overrides semantics.
431
432 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
433 - Generalized plugins
434 - Fixed initscript start up bug.
435
436 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
437 - * Fix delegation authentication problem
438 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
439
440 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
441 - * Rerun initscripts when slice goes from disabled to enabled.
442
443 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
444 - * Update session key when out of synch with PLC
445 - * PLCDefaults uses tagname
446
447 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
448 - log invokations of vsys
449
450 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
451
452 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
453
454 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
455 - Codemux supports multiple hosts mapping to single slice
456 - Fixed bug in delegation support where tickets delivered weren't
457   being passed to sm.deliver_ticket().
458 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
459 - Codemux now configured via slice attribute (host,port)
460 - Support for multiple vserver reference images (including different archs)
461 - Mom BW emails are sent to list defined by MyPLC's config
462 - Sirius BW loans honored correctly.  Fixed.
463 - BW totals preserved for dynamic slices so as not to game the system.
464 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
465 - Configures vsys via vsys slice attribute {name: vsys, value: script}
466 - CPU reservations are now calculated via percentages instead of shares
467 - BW totals preserved for dynamic slices
468 - Closes bug where node cap sets off bw slice alarms for all slices.
469
470 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
471 - Switched to SVN.
472
473 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
474 - Initial build.