Setting tag nodemanager-5.2-12
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 12
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ########## use initscripts or systemd unit files to start installed services
10 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
11 %define make_options WITH_SYSTEMD=true
12 %define initdir /usr/lib/systemd/system
13 %else
14 %define make_options WITH_INIT=true
15 %define initdir %{_initrddir}
16 %endif
17
18 Summary: PlanetLab Node Manager Library
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: PlanetLab
23 Group: System Environment/Daemons
24 Source0: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27 Vendor: PlanetLab
28 Packager: PlanetLab Central <support@planet-lab.org>
29 Distribution: PlanetLab %{plrelease}
30 URL: %{SCMURL}
31
32 # not possible because of forward_api_calls
33 #BuildArch: noarch
34
35 # make sure we can invoke systemctl in post install script
36 %if "%{initdir}" != "%{_initrddir}"
37 Requires: systemd
38 %endif
39
40 # Uses function decorators
41 Requires: python >= 2.7
42 # connecting PLC
43 Requires: python-pycurl
44 # Signed tickets
45 Requires: gnupg
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48 # we do need the slice images in any case
49 Requires: sliceimage-%{slicefamily}
50 # for bwlimit
51 Requires: plnode-utils
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59 nodemanager-lib only provides a skeleton and needs as a companion
60 either nodemanager-vs or nodemanager-lxc
61
62 ##############################
63 %prep
64 %setup -q
65
66 %build
67 # make manages the C and Python stuff
68 %{__make} %{?_smp_mflags} %{make_options} lib 
69
70 %install
71 # make manages the C and Python stuff
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
74
75 ##############################
76 %post
77 ########## traditional init
78 %if "%{initdir}" == "%{_initrddir}"
79 ##########
80 chkconfig --add conf_files
81 chkconfig conf_files on
82 chkconfig --add nm
83 chkconfig nm on
84 chkconfig --add fuse-pl
85 chkconfig fuse-pl on
86 if [ "$PL_BOOTCD" != "1" ] ; then
87     service nm restart
88     service fuse-pl restart
89 fi
90 ##########
91 %else
92 ########## systemd
93 systemctl enable nm.service
94 systemctl enable conf_files.service
95 # empty
96 #systemctl enable fuse-pl.service
97 if [ "$PL_BOOTCD" != "1" ] ; then
98     systemctl restart nm.service
99 #    systemctl restart fuse-pl.service
100 fi
101 ##########
102 %endif
103
104 ##############################
105 %preun
106 # 0 = erase, 1 = upgrade
107 ########## traditional init
108 %if "%{initdir}" == "%{_initrddir}"
109 ##########
110 if [ $1 -eq 0 ] ; then
111     chkconfig fuse-pl off
112     chkconfig --del fuse-pl
113     chkconfig nm off
114     chkconfig --del nm
115     chkconfig conf_files off
116     chkconfig --del conf_files
117 fi
118 ##########
119 %else
120 ########## systemd
121 if [ $1 -eq 0 ] ; then
122 #    systemctl disable fuse-pl.service
123     systemctl disable conf_files.service
124     systemctl disable nm.service
125 fi
126 ##########
127 %endif
128
129 ##############################
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(-,root,root,-)
135 %{_datadir}/NodeManager/
136 %{_bindir}/forward_api_calls
137 %{initdir}/
138 %{_sysconfdir}/logrotate.d/nodemanager
139 /var/lib/nodemanager/
140 %config(noreplace) /etc/sysconfig/nodemanager
141
142 %changelog
143 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
144 - this tag for the first time passes the full range of tests on fedora20
145 - robustified slice teardown wrt vsys
146 - Scott's fix for repairing veth devs
147 - removed sshsh
148 - tools.has_systemctl
149
150 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
151 - ship /etc/sysconfig/nodemanager
152 - trash sshsh
153
154 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
155 - comes with systemd native unit files on >= f18
156 - user-provided initscript gets started through systemd in slivers >= f18
157 - smarter to locate cgroups for various versions of libvirt
158 - nicer log format - and log program termination
159 - tweaks in codemux plugin
160 - bug fixes in libvirt driver, esp. for finding out if domain is running
161
162 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
163 - fixes in hostmap, and in interfaces
164 - new vsys_sysctl
165 - privatebridge now comes with nodemanager-lib
166
167 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
168 - omf plugin does not block any longer when running trigger script
169 - log goes into sliver's /var/log instead
170
171 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
172 - new install-scripts target in Makefile
173 - conf_files and fuse-pl initscripts chmod'ed +x
174 - omf_resctl config template tweaked to use _slicename_%_hostname_
175
176 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
177 - make sure to create /etc/planetlab/virt so others can read that
178 - expose get_node_virt() and command_in_slice()
179 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
180 - user's .profile now has right owner
181 - other tweaks in lxc slivers
182
183 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
184 - lxc slice creation: slice user was created with unknown gid - fixed
185 - lxc slice creation: .profile for root and user - fixed
186
187 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
188 - fix umounting of ssh directory when deleting omf-friendly slivers
189 - support for writing cgroups in subsystems other than cpuset
190 - add xid to template match
191 - finer-grained split between -lib -vs and -lxc
192 - first roughly complete omf_resctl for omfv6
193 - minor fix for when getslivers does not have minexemptrate
194
195 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
196 - Fix path, machine arch in slivers
197
198 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
199
200 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
201 - no-op bump to 5.2 to be in line with the rest of the system
202
203 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
204 - improvements to privatebridge
205
206 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
207 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
208
209 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
210 - fix wrong gre tunnel deleted when topology changes
211
212 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
213 - Update /etc/hosts in slivers from sliver_hostmap tag.
214
215 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
216 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
217 - initial check-in of privatebridge plugin.
218
219 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
220 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
221
222 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
223 - fix slices not deleted properly when they use vsys
224
225 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
226 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
227
228 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
229 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
230
231 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
232 - Bridge virtual interfaces to VLANs
233
234 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
235 - Add support for L2 bridged interfaces with public IPs inside a slice
236
237 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
238 - Support for freezing BestEffort slices for Vicci
239
240 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
241 - Change to use new vsh (wrapper for lxcsu)
242
243 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
244 - add missing import
245 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
246
247 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
248 - tag 2.1-7 was broken for OMF-friendly slices
249 - expose_ssh_dir was erroneously defined on the Worker class
250
251 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
252 - bwlimitlxc now ships with plnode-utils
253
254 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
255 - set LD_PRELOAD for linux-containers nodes
256
257 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
258 - first complete version for vs and lxc - functional but not thoroughly tested though
259
260 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
261 - split packaging in 3 (lib, lxc, vs)
262 - this tag will only work with lxc though
263
264 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
265 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
266
267 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
268 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
269 - purpose being to be able to run this branch on vserver nodes as well
270
271 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
272 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
273 - passes tests with lxc but won't build against vs due to conflict
274 - as bwlimit.py also ships with util-vserver-pl
275
276 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
277 - refactoring: isolate initscript functionality
278 - aimed at making initscript implementation with lxc straightforward
279 - show stack trace when module loading fails
280 - accounts.py renamed into account.py for consistency
281
282 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
283 - /var/log/nodemanager shows duration of mainloop
284
285 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
286 - first working draft for dealing with libvirt/lxc on f16 nodes
287 - not expected to work with mainline nodes (use 2.0 for that for now)
288
289 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
290 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
291
292 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
293 - Added memory scheduling to core scheduler
294 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
295
296 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
297 - tweaked log policy for the core scheduler
298 - curlwrapper has an optional verbose mode
299
300 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
301 - fixes for hmac and omf_control tags
302 - optional besteffort flag to core scheduler
303 - logrotate entry for /var/log/nodemanager.daemon
304 - a template for bash initscripts
305
306 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
307 - rename initscript_body into initscript_code
308 - fix generic vinit for broken bash syntax &>>
309
310 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
311 - new initscript_body slice tag, with stop and restart
312 - generic vinit script live updated
313 - new coresched module
314 - protect against non-existing vsys scripts
315 - use Config. instead of globals
316
317 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
318 - more robust reservation plugin
319
320 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
321 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
322 - reservation plugin more robust
323
324 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
325 - pass device to bwlimit
326
327 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
328 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
329
330 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
331 - Catch all exceptions for sfa plugin
332
333 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
334 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
335
336 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
337 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
338
339 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
340 - plugins/sliverauth.py improvements
341
342 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
343 - Disable sfagids plugin
344
345 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
346 - Re-tag nodemanager to include conflicted commits
347
348 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
349 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
350 - sfagids plugin deleted
351 - band-aid patch for lack of GetSliceFamily removed
352
353 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
354
355 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
356 - revert curlwrapper to former forking-curl version
357 - fixes in the omf plugin for ssh key location and node hrn
358 - set umask 0022 in tools.daemon
359
360 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
361 - configure omf-resctl for keys
362
363 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
364 - fix key generation
365
366 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
367 - name changes and fix typos
368
369 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
370 - remove config and options parameters from start function
371
372 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
373 - working version of reservable nodes
374 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
375 - dismantled the -s|--startup option (no convincing need for that)
376 - simpler and more robust init.d/nm
377 - initscript content management through replace_file_with_string
378 - sliverauth uses replace_file_with_string
379 - curlwrapper has a debug mode
380
381 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
382 - pretty-printing/normalized python code - hopefully neutral
383
384 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
385 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
386 - that triggers /etc/init.d/vinit.slice if present and executable
387 - (2) install the slice-provided initscript (as per the initscript tag) as
388 - /etc/init.d/vinit.slice
389 - (3) as a result the initscript are now triggered by rc as part of the
390 - standard vserver .. start, properly attached to the vserver,
391 - and properly killed upon vserver .. stop
392 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
393
394 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
395 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
396 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
397 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
398 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
399 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
400 - cleanup: nodemanger now is a class; however plugins are still dumb modules
401 - cleanup: does not depend on obsolete Set
402
403 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
404 - tagging before RC
405
406 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
407 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
408 - Added some precautions to the slice id-saving code
409 - Added log message to code that records the slice id
410
411 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
412 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
413 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
414 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
415
416 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
417 - fix log_call in plugins/drl.py
418
419 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
420 - protect against nodes in migrated PLC's not having the hrn tag yet
421
422 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
423 - new omf-resctl and drl plugins
424 - specialaccount optimized to overwrite authorized keys only upon changes
425 - codemux plugin has support for a new 'ip' setting
426 - mainloop to display ordered modules&plugins at all times
427
428 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
429 - modules and plugins have a priority
430 - specialaccounts appears soon in the priority chain
431 - logger.log_call logs process output, and has a timeout
432 - vuser{add,del} run through bash -x
433 - nm initscript has support for 'service nm restartverbose'
434 - logs reviewed for consistency
435 - use hashlib module instead of sha when available
436
437 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
438 - first working version of 5.0:
439 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
440 - nodefamily is 3-fold with pldistro-fcdistro-arch
441 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
442 - (in addition to the 'vref' tag that's still exposed too)
443 - logging reviewed for more convenience
444 - support for 'service nm restartdebug'
445 - make sync knows how to publish uncommitted code on a test node
446
447 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
448 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
449
450 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
451 - support for f10 and f12 in the vref slice tag
452
453 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
454 - build on fedora12
455 - uses slicename 'sfacm' instead of 'genicw'
456
457 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
458 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
459 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
460 - days ago.
461
462 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
463 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
464 - self-contained. With this change, they will be able to refer to the attributes associated with a
465 - slice.
466
467 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
468 - fix for syntax error
469
470 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
471 - -fixed problem with sioc import at the build side
472 - -bwlimit.set() now accepts the device and does not asume that it is eth0
473
474 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
475 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
476
477 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
478 - The seed for random previously was the meaning of life (i.e., 42) but
479 - that resulted in a not so random choice for the hmac.  This
480 - implementation now uses a random.seed that is based on the current
481 - time.
482
483 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
484 - Minor fix such that sliverauth.py makes a more specific call to
485 - GetSliceTags that include that specific tagname it is looking for.
486
487 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
488 - Fix bug that prevented 'OVERRIDES' for working correctly.
489
490 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
491 - Increase disk limits to 10G per sliver
492 - Sanity check slice for home directory before starting (hack)
493 - Check codemux arguments
494
495 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
496 - * Fix Delegation
497 - * Move plcapi in plugin-api GetSlivers() calls.
498 - * Persistent Authcheck and resync session when auth failure
499
500 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
501 - Disabling sliverauth module.  Not ready for deployment.
502
503 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
504 - Fixing overrides semantics.
505
506 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
507 - Generalized plugins
508 - Fixed initscript start up bug.
509
510 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
511 - * Fix delegation authentication problem
512 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
513
514 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
515 - * Rerun initscripts when slice goes from disabled to enabled.
516
517 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
518 - * Update session key when out of synch with PLC
519 - * PLCDefaults uses tagname
520
521 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
522 - log invokations of vsys
523
524 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
525
526 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
527
528 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
529 - Codemux supports multiple hosts mapping to single slice
530 - Fixed bug in delegation support where tickets delivered weren't
531   being passed to sm.deliver_ticket().
532
533 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
534 - Codemux now configured via slice attribute (host,port)
535 - Support for multiple vserver reference images (including different archs)
536 - Mom BW emails are sent to list defined by MyPLC's config
537 - Sirius BW loans honored correctly.  Fixed.
538 - BW totals preserved for dynamic slices so as not to game the system.
539
540 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
541 - Configures vsys via vsys slice attribute {name: vsys, value: script}
542 - CPU reservations are now calculated via percentages instead of shares
543 - BW totals preserved for dynamic slices
544 - Closes bug where node cap sets off bw slice alarms for all slices.
545
546 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
547 - Switched to SVN.
548
549 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
550 - Initial build.