keep both coreshed_vs and coresched_lxc - cgroups in the lxc package
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 2.1
5 %define taglevel 4
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37
38 %description
39 The PlanetLab Node Manager manages all aspects of PlanetLab node and
40 slice management once the node has been initialized and configured by
41 the Boot Manager. It periodically contacts its management authority
42 for configuration updates. It provides an XML-RPC API for performing
43 local operations on slices.
44 nodemanager-lib only provides a skeleton and needs as a companion
45 either nodemanager-vs or nodemanager-lxc
46
47 %prep
48 %setup -q
49
50 %build
51 # make manages the C and Python stuff
52 %{__make} %{?_smp_mflags} lib
53
54 %install
55 # make manages the C and Python stuff
56 rm -rf $RPM_BUILD_ROOT
57 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
58 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
59
60 # install the sliver initscript (that triggers the slice initscript if any)
61 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
62 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
63 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64
65 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
66 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
67 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
68
69 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
70
71 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
72 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
73 install -D -m 644 bwlimitlxc.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/bwlimitlxc.py
74
75 ##########
76 %post
77 # tmp - handle file renamings; old names are from 2.0-8
78 renamings="
79 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
80 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
81 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
82 /var/log/nm@/var/log/nodemanager
83 /var/log/nm.daemon@/var/log/nodemanager.daemon
84 /var/run/nm.pid@/var/run/nodemanager.pid
85 /tmp/sliver_mgr.api@/tmp/nodemanager.api
86 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
87 "
88 for renaming in $renamings; do
89   old=$(echo $renaming | cut -d@ -f1)
90   new=$(echo $renaming | cut -d@ -f2)
91   newdir=$(dirname $new)
92   if [ -e "$old" -a ! -e "$new" ] ; then
93       mkdir -p $newdir
94       mv -f $old $new
95   fi
96 done
97 #
98 chkconfig --add conf_files
99 chkconfig conf_files on
100 chkconfig --add nm
101 chkconfig nm on
102 chkconfig --add fuse-pl
103 chkconfig fuse-pl on
104 if [ "$PL_BOOTCD" != "1" ] ; then
105         service nm restart
106         service fuse-pl restart
107 fi
108
109 ##########
110 %preun
111 # 0 = erase, 1 = upgrade
112 if [ $1 -eq 0 ] ; then
113     chkconfig fuse-pl off
114     chkconfig --del fuse-pl
115     chkconfig nm off
116     chkconfig --del nm
117     chkconfig conf_files off
118     chkconfig --del conf_files
119 fi
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(-,root,root,-)
126 %{_datadir}/NodeManager/
127 %{_bindir}/forward_api_calls
128 %{_initrddir}/
129 %{_sysconfdir}/logrotate.d/nodemanager
130 /var/lib/
131 /bin/sshsh
132 %{python_sitearch}/bwlimitlxc.py*
133
134 %changelog
135 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
136 - split packaging in 3 (lib, lxc, vs)
137 - this tag will only work with lxc though
138
139 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
140 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
141
142 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
143 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
144 - purpose being to be able to run this branch on vserver nodes as well
145
146 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
147 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
148 - passes tests with lxc but won't build against vs due to conflict
149 - as bwlimit.py also ships with util-vserver-pl
150
151 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
152 - refactoring: isolate initscript functionality
153 - aimed at making initscript implementation with lxc straightforward
154 - show stack trace when module loading fails
155 - accounts.py renamed into account.py for consistency
156
157 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
158 - /var/log/nodemanager shows duration of mainloop
159
160 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
161 - first working draft for dealing with libvirt/lxc on f16 nodes
162 - not expected to work with mainline nodes (use 2.0 for that for now)
163
164 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
165 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
166
167 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
168 - Added memory scheduling to core scheduler
169 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
170
171 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
172 - tweaked log policy for the core scheduler
173 - curlwrapper has an optional verbose mode
174
175 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
176 - fixes for hmac and omf_control tags
177 - optional besteffort flag to core scheduler
178 - logrotate entry for /var/log/nodemanager.daemon
179 - a template for bash initscripts
180
181 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
182 - rename initscript_body into initscript_code
183 - fix generic vinit for broken bash syntax &>>
184
185 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
186 - new initscript_body slice tag, with stop and restart
187 - generic vinit script live updated
188 - new coresched module
189 - protect against non-existing vsys scripts
190 - use Config. instead of globals
191
192 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
193 - more robust reservation plugin
194
195 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
196 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
197 - reservation plugin more robust
198
199 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
200 - pass device to bwlimit
201
202 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
203 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
204
205 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
206 - Catch all exceptions for sfa plugin
207
208 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
209 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
210
211 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
212 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
213
214 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
215 - plugins/sliverauth.py improvements
216
217 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
218 - Disable sfagids plugin
219
220 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
221 - Re-tag nodemanager to include conflicted commits
222
223 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
224 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
225 - sfagids plugin deleted
226 - band-aid patch for lack of GetSliceFamily removed
227
228 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
229
230 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
231 - revert curlwrapper to former forking-curl version
232 - fixes in the omf plugin for ssh key location and node hrn
233 - set umask 0022 in tools.daemon
234
235 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
236 - configure omf-resctl for keys
237
238 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
239 - fix key generation
240
241 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
242 - name changes and fix typos
243
244 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
245 - remove config and options parameters from start function
246
247 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
248 - working version of reservable nodes
249 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
250 - dismantled the -s|--startup option (no convincing need for that)
251 - simpler and more robust init.d/nm
252 - initscript content management through replace_file_with_string
253 - sliverauth uses replace_file_with_string
254 - curlwrapper has a debug mode
255
256 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
257 - pretty-printing/normalized python code - hopefully neutral
258
259 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
260 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
261 - that triggers /etc/init.d/vinit.slice if present and executable
262 - (2) install the slice-provided initscript (as per the initscript tag) as
263 - /etc/init.d/vinit.slice
264 - (3) as a result the initscript are now triggered by rc as part of the
265 - standard vserver .. start, properly attached to the vserver,
266 - and properly killed upon vserver .. stop
267 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
268
269 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
270 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
271 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
272 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
273 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
274 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
275 - cleanup: nodemanger now is a class; however plugins are still dumb modules
276 - cleanup: does not depend on obsolete Set
277
278 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
279 - tagging before RC
280
281 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
282 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
283 - Added some precautions to the slice id-saving code
284 - Added log message to code that records the slice id
285
286 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
287 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
288 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
289 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
290
291 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
292 - fix log_call in plugins/drl.py
293
294 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
295 - protect against nodes in migrated PLC's not having the hrn tag yet
296
297 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
298 - new omf-resctl and drl plugins
299 - specialaccount optimized to overwrite authorized keys only upon changes
300 - codemux plugin has support for a new 'ip' setting
301 - mainloop to display ordered modules&plugins at all times
302
303 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
304 - modules and plugins have a priority
305 - specialaccounts appears soon in the priority chain
306 - logger.log_call logs process output, and has a timeout
307 - vuser{add,del} run through bash -x
308 - nm initscript has support for 'service nm restartverbose'
309 - logs reviewed for consistency
310 - use hashlib module instead of sha when available
311
312 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
313 - first working version of 5.0:
314 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
315 - nodefamily is 3-fold with pldistro-fcdistro-arch
316 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
317 - (in addition to the 'vref' tag that's still exposed too)
318 - logging reviewed for more convenience
319 - support for 'service nm restartdebug'
320 - make sync knows how to publish uncommitted code on a test node
321
322 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
323 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
324
325 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
326 - support for f10 and f12 in the vref slice tag
327
328 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
329 - build on fedora12
330 - uses slicename 'sfacm' instead of 'genicw'
331
332 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
333 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
334 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
335 - days ago.
336
337 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
338 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
339 - self-contained. With this change, they will be able to refer to the attributes associated with a
340 - slice.
341
342 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
343 - fix for syntax error
344
345 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
346 - -fixed problem with sioc import at the build side
347 - -bwlimit.set() now accepts the device and does not asume that it is eth0
348
349 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
350 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
351
352 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
353 - The seed for random previously was the meaning of life (i.e., 42) but
354 - that resulted in a not so random choice for the hmac.  This
355 - implementation now uses a random.seed that is based on the current
356 - time.
357
358 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
359 - Minor fix such that sliverauth.py makes a more specific call to
360 - GetSliceTags that include that specific tagname it is looking for.
361
362 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
363 - Fix bug that prevented 'OVERRIDES' for working correctly.
364
365 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
366 - Increase disk limits to 10G per sliver
367 - Sanity check slice for home directory before starting (hack)
368 - Check codemux arguments
369
370 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
371 - * Fix Delegation
372 - * Move plcapi in plugin-api GetSlivers() calls.
373 - * Persistent Authcheck and resync session when auth failure
374
375 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
376 - Disabling sliverauth module.  Not ready for deployment.
377
378 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
379 - Fixing overrides semantics.
380
381 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
382 - Generalized plugins
383 - Fixed initscript start up bug.
384
385 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
386 - * Fix delegation authentication problem
387 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
388
389 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
390 - * Rerun initscripts when slice goes from disabled to enabled.
391
392 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
393 - * Update session key when out of synch with PLC
394 - * PLCDefaults uses tagname
395
396 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
397 - log invokations of vsys
398
399 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
400
401 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
402
403 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
404 - Codemux supports multiple hosts mapping to single slice
405 - Fixed bug in delegation support where tickets delivered weren't
406   being passed to sm.deliver_ticket().
407 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
408 - Codemux now configured via slice attribute (host,port)
409 - Support for multiple vserver reference images (including different archs)
410 - Mom BW emails are sent to list defined by MyPLC's config
411 - Sirius BW loans honored correctly.  Fixed.
412 - BW totals preserved for dynamic slices so as not to game the system.
413 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
414 - Configures vsys via vsys slice attribute {name: vsys, value: script}
415 - CPU reservations are now calculated via percentages instead of shares
416 - BW totals preserved for dynamic slices
417 - Closes bug where node cap sets off bw slice alarms for all slices.
418
419 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
420 - Switched to SVN.
421
422 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
423 - Initial build.