Setting tag nodemanager-5.2-4
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 4
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
136 - fix umounting of ssh directory when deleting omf-friendly slivers
137 - support for writing cgroups in subsystems other than cpuset
138 - add xid to template match
139 - finer-grained split between -lib -vs and -lxc
140 - first roughly complete omf_resctl for omfv6
141 - minor fix for when getslivers does not have minexemptrate
142
143 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
144 - Fix path, machine arch in slivers
145
146 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
147
148 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
149 - no-op bump to 5.2 to be in line with the rest of the system
150
151 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
152 - improvements to privatebridge
153
154 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
155 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
156
157 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
158 - fix wrong gre tunnel deleted when topology changes
159
160 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
161 - Update /etc/hosts in slivers from sliver_hostmap tag.
162
163 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
164 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
165 - initial check-in of privatebridge plugin.
166
167 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
168 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
169
170 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
171 - fix slices not deleted properly when they use vsys
172
173 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
174 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
175
176 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
177 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
178
179 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
180 - Bridge virtual interfaces to VLANs
181
182 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
183 - Add support for L2 bridged interfaces with public IPs inside a slice
184
185 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
186 - Support for freezing BestEffort slices for Vicci
187
188 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
189 - Change to use new vsh (wrapper for lxcsu)
190
191 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
192 - add missing import
193 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
194
195 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
196 - tag 2.1-7 was broken for OMF-friendly slices
197 - expose_ssh_dir was erroneously defined on the Worker class
198
199 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
200 - bwlimitlxc now ships with plnode-utils
201
202 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
203 - set LD_PRELOAD for linux-containers nodes
204
205 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
206 - first complete version for vs and lxc - functional but not thoroughly tested though
207
208 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
209 - split packaging in 3 (lib, lxc, vs)
210 - this tag will only work with lxc though
211
212 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
213 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
214
215 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
216 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
217 - purpose being to be able to run this branch on vserver nodes as well
218
219 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
220 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
221 - passes tests with lxc but won't build against vs due to conflict
222 - as bwlimit.py also ships with util-vserver-pl
223
224 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
225 - refactoring: isolate initscript functionality
226 - aimed at making initscript implementation with lxc straightforward
227 - show stack trace when module loading fails
228 - accounts.py renamed into account.py for consistency
229
230 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
231 - /var/log/nodemanager shows duration of mainloop
232
233 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
234 - first working draft for dealing with libvirt/lxc on f16 nodes
235 - not expected to work with mainline nodes (use 2.0 for that for now)
236
237 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
238 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
239
240 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
241 - Added memory scheduling to core scheduler
242 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
243
244 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
245 - tweaked log policy for the core scheduler
246 - curlwrapper has an optional verbose mode
247
248 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
249 - fixes for hmac and omf_control tags
250 - optional besteffort flag to core scheduler
251 - logrotate entry for /var/log/nodemanager.daemon
252 - a template for bash initscripts
253
254 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
255 - rename initscript_body into initscript_code
256 - fix generic vinit for broken bash syntax &>>
257
258 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
259 - new initscript_body slice tag, with stop and restart
260 - generic vinit script live updated
261 - new coresched module
262 - protect against non-existing vsys scripts
263 - use Config. instead of globals
264
265 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
266 - more robust reservation plugin
267
268 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
269 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
270 - reservation plugin more robust
271
272 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
273 - pass device to bwlimit
274
275 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
276 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
277
278 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
279 - Catch all exceptions for sfa plugin
280
281 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
282 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
283
284 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
285 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
286
287 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
288 - plugins/sliverauth.py improvements
289
290 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
291 - Disable sfagids plugin
292
293 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
294 - Re-tag nodemanager to include conflicted commits
295
296 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
297 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
298 - sfagids plugin deleted
299 - band-aid patch for lack of GetSliceFamily removed
300
301 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
302
303 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
304 - revert curlwrapper to former forking-curl version
305 - fixes in the omf plugin for ssh key location and node hrn
306 - set umask 0022 in tools.daemon
307
308 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
309 - configure omf-resctl for keys
310
311 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
312 - fix key generation
313
314 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
315 - name changes and fix typos
316
317 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
318 - remove config and options parameters from start function
319
320 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
321 - working version of reservable nodes
322 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
323 - dismantled the -s|--startup option (no convincing need for that)
324 - simpler and more robust init.d/nm
325 - initscript content management through replace_file_with_string
326 - sliverauth uses replace_file_with_string
327 - curlwrapper has a debug mode
328
329 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
330 - pretty-printing/normalized python code - hopefully neutral
331
332 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
333 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
334 - that triggers /etc/init.d/vinit.slice if present and executable
335 - (2) install the slice-provided initscript (as per the initscript tag) as
336 - /etc/init.d/vinit.slice
337 - (3) as a result the initscript are now triggered by rc as part of the
338 - standard vserver .. start, properly attached to the vserver,
339 - and properly killed upon vserver .. stop
340 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
341
342 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
343 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
344 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
345 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
346 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
347 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
348 - cleanup: nodemanger now is a class; however plugins are still dumb modules
349 - cleanup: does not depend on obsolete Set
350
351 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
352 - tagging before RC
353
354 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
355 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
356 - Added some precautions to the slice id-saving code
357 - Added log message to code that records the slice id
358
359 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
360 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
361 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
362 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
363
364 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
365 - fix log_call in plugins/drl.py
366
367 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
368 - protect against nodes in migrated PLC's not having the hrn tag yet
369
370 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
371 - new omf-resctl and drl plugins
372 - specialaccount optimized to overwrite authorized keys only upon changes
373 - codemux plugin has support for a new 'ip' setting
374 - mainloop to display ordered modules&plugins at all times
375
376 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
377 - modules and plugins have a priority
378 - specialaccounts appears soon in the priority chain
379 - logger.log_call logs process output, and has a timeout
380 - vuser{add,del} run through bash -x
381 - nm initscript has support for 'service nm restartverbose'
382 - logs reviewed for consistency
383 - use hashlib module instead of sha when available
384
385 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
386 - first working version of 5.0:
387 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
388 - nodefamily is 3-fold with pldistro-fcdistro-arch
389 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
390 - (in addition to the 'vref' tag that's still exposed too)
391 - logging reviewed for more convenience
392 - support for 'service nm restartdebug'
393 - make sync knows how to publish uncommitted code on a test node
394
395 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
396 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
397
398 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
399 - support for f10 and f12 in the vref slice tag
400
401 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
402 - build on fedora12
403 - uses slicename 'sfacm' instead of 'genicw'
404
405 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
406 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
407 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
408 - days ago.
409
410 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
411 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
412 - self-contained. With this change, they will be able to refer to the attributes associated with a
413 - slice.
414
415 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
416 - fix for syntax error
417
418 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
419 - -fixed problem with sioc import at the build side
420 - -bwlimit.set() now accepts the device and does not asume that it is eth0
421
422 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
423 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
424
425 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
426 - The seed for random previously was the meaning of life (i.e., 42) but
427 - that resulted in a not so random choice for the hmac.  This
428 - implementation now uses a random.seed that is based on the current
429 - time.
430
431 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
432 - Minor fix such that sliverauth.py makes a more specific call to
433 - GetSliceTags that include that specific tagname it is looking for.
434
435 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
436 - Fix bug that prevented 'OVERRIDES' for working correctly.
437
438 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
439 - Increase disk limits to 10G per sliver
440 - Sanity check slice for home directory before starting (hack)
441 - Check codemux arguments
442
443 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
444 - * Fix Delegation
445 - * Move plcapi in plugin-api GetSlivers() calls.
446 - * Persistent Authcheck and resync session when auth failure
447
448 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
449 - Disabling sliverauth module.  Not ready for deployment.
450
451 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
452 - Fixing overrides semantics.
453
454 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
455 - Generalized plugins
456 - Fixed initscript start up bug.
457
458 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
459 - * Fix delegation authentication problem
460 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
461
462 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
463 - * Rerun initscripts when slice goes from disabled to enabled.
464
465 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
466 - * Update session key when out of synch with PLC
467 - * PLCDefaults uses tagname
468
469 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
470 - log invokations of vsys
471
472 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
473
474 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
475
476 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
477 - Codemux supports multiple hosts mapping to single slice
478 - Fixed bug in delegation support where tickets delivered weren't
479   being passed to sm.deliver_ticket().
480
481 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
482 - Codemux now configured via slice attribute (host,port)
483 - Support for multiple vserver reference images (including different archs)
484 - Mom BW emails are sent to list defined by MyPLC's config
485 - Sirius BW loans honored correctly.  Fixed.
486 - BW totals preserved for dynamic slices so as not to game the system.
487
488 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
489 - Configures vsys via vsys slice attribute {name: vsys, value: script}
490 - CPU reservations are now calculated via percentages instead of shares
491 - BW totals preserved for dynamic slices
492 - Closes bug where node cap sets off bw slice alarms for all slices.
493
494 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
495 - Switched to SVN.
496
497 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
498 - Initial build.