pushes stuff from systemd/ and not from initscripts anymore
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 9
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager Library
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # Uses function decorators
27 Requires: python >= 2.4
28 # connecting PLC
29 Requires: python-pycurl
30 # Signed tickets
31 Requires: gnupg
32 # sioc/plnet
33 Requires: pyplnet >= 4.3
34 # we do need the slice images in any case
35 Requires: sliceimage-%{slicefamily}
36 # for bwlimit
37 Requires: plnode-utils
38
39 %description
40 The PlanetLab Node Manager manages all aspects of PlanetLab node and
41 slice management once the node has been initialized and configured by
42 the Boot Manager. It periodically contacts its management authority
43 for configuration updates. It provides an XML-RPC API for performing
44 local operations on slices.
45 nodemanager-lib only provides a skeleton and needs as a companion
46 either nodemanager-vs or nodemanager-lxc
47
48 %prep
49 %setup -q
50
51 %build
52 # make manages the C and Python stuff
53 %{__make} %{?_smp_mflags} lib
54
55 %install
56 # make manages the C and Python stuff
57 rm -rf $RPM_BUILD_ROOT
58 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
59
60 # install the sliver initscript (that triggers the slice initscript if any)
61 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
62 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
63 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64
65 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
66 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
67 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
68
69 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
70
71 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
72 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
73
74 ##########
75 %post
76 # tmp - handle file renamings; old names are from 2.0-8
77 renamings="
78 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
79 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
80 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
81 /var/log/nm@/var/log/nodemanager
82 /var/log/nm.daemon@/var/log/nodemanager.daemon
83 /var/run/nm.pid@/var/run/nodemanager.pid
84 /tmp/sliver_mgr.api@/tmp/nodemanager.api
85 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
86 "
87 for renaming in $renamings; do
88   old=$(echo $renaming | cut -d@ -f1)
89   new=$(echo $renaming | cut -d@ -f2)
90   newdir=$(dirname $new)
91   if [ -e "$old" -a ! -e "$new" ] ; then
92       mkdir -p $newdir
93       mv -f $old $new
94   fi
95 done
96 #
97 chkconfig --add conf_files
98 chkconfig conf_files on
99 chkconfig --add nm
100 chkconfig nm on
101 chkconfig --add fuse-pl
102 chkconfig fuse-pl on
103 if [ "$PL_BOOTCD" != "1" ] ; then
104         service nm restart
105         service fuse-pl restart
106 fi
107
108 ##########
109 %preun
110 # 0 = erase, 1 = upgrade
111 if [ $1 -eq 0 ] ; then
112     chkconfig fuse-pl off
113     chkconfig --del fuse-pl
114     chkconfig nm off
115     chkconfig --del nm
116     chkconfig conf_files off
117     chkconfig --del conf_files
118 fi
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files
124 %defattr(-,root,root,-)
125 %{_datadir}/NodeManager/
126 %{_bindir}/forward_api_calls
127 %{_initrddir}/
128 %{_sysconfdir}/logrotate.d/nodemanager
129 /var/lib/
130 /bin/sshsh
131
132 %changelog
133 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
134 - fixes in hostmap, and in interfaces
135 - new vsys_sysctl
136 - privatebridge now comes with nodemanager-lib
137
138 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
139 - omf plugin does not block any longer when running trigger script
140 - log goes into sliver's /var/log instead
141
142 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
143 - new install-scripts target in Makefile
144 - conf_files and fuse-pl initscripts chmod'ed +x
145 - omf_resctl config template tweaked to use _slicename_%_hostname_
146
147 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
148 - make sure to create /etc/planetlab/virt so others can read that
149 - expose get_node_virt() and command_in_slice()
150 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
151 - user's .profile now has right owner
152 - other tweaks in lxc slivers
153
154 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
155 - lxc slice creation: slice user was created with unknown gid - fixed
156 - lxc slice creation: .profile for root and user - fixed
157
158 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
159 - fix umounting of ssh directory when deleting omf-friendly slivers
160 - support for writing cgroups in subsystems other than cpuset
161 - add xid to template match
162 - finer-grained split between -lib -vs and -lxc
163 - first roughly complete omf_resctl for omfv6
164 - minor fix for when getslivers does not have minexemptrate
165
166 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
167 - Fix path, machine arch in slivers
168
169 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
170
171 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
172 - no-op bump to 5.2 to be in line with the rest of the system
173
174 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
175 - improvements to privatebridge
176
177 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
178 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
179
180 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
181 - fix wrong gre tunnel deleted when topology changes
182
183 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
184 - Update /etc/hosts in slivers from sliver_hostmap tag.
185
186 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
187 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
188 - initial check-in of privatebridge plugin.
189
190 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
191 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
192
193 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
194 - fix slices not deleted properly when they use vsys
195
196 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
197 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
198
199 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
200 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
201
202 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
203 - Bridge virtual interfaces to VLANs
204
205 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
206 - Add support for L2 bridged interfaces with public IPs inside a slice
207
208 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
209 - Support for freezing BestEffort slices for Vicci
210
211 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
212 - Change to use new vsh (wrapper for lxcsu)
213
214 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
215 - add missing import
216 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
217
218 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
219 - tag 2.1-7 was broken for OMF-friendly slices
220 - expose_ssh_dir was erroneously defined on the Worker class
221
222 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
223 - bwlimitlxc now ships with plnode-utils
224
225 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
226 - set LD_PRELOAD for linux-containers nodes
227
228 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
229 - first complete version for vs and lxc - functional but not thoroughly tested though
230
231 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
232 - split packaging in 3 (lib, lxc, vs)
233 - this tag will only work with lxc though
234
235 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
236 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
237
238 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
239 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
240 - purpose being to be able to run this branch on vserver nodes as well
241
242 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
243 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
244 - passes tests with lxc but won't build against vs due to conflict
245 - as bwlimit.py also ships with util-vserver-pl
246
247 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
248 - refactoring: isolate initscript functionality
249 - aimed at making initscript implementation with lxc straightforward
250 - show stack trace when module loading fails
251 - accounts.py renamed into account.py for consistency
252
253 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
254 - /var/log/nodemanager shows duration of mainloop
255
256 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
257 - first working draft for dealing with libvirt/lxc on f16 nodes
258 - not expected to work with mainline nodes (use 2.0 for that for now)
259
260 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
261 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
262
263 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
264 - Added memory scheduling to core scheduler
265 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
266
267 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
268 - tweaked log policy for the core scheduler
269 - curlwrapper has an optional verbose mode
270
271 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
272 - fixes for hmac and omf_control tags
273 - optional besteffort flag to core scheduler
274 - logrotate entry for /var/log/nodemanager.daemon
275 - a template for bash initscripts
276
277 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
278 - rename initscript_body into initscript_code
279 - fix generic vinit for broken bash syntax &>>
280
281 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
282 - new initscript_body slice tag, with stop and restart
283 - generic vinit script live updated
284 - new coresched module
285 - protect against non-existing vsys scripts
286 - use Config. instead of globals
287
288 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
289 - more robust reservation plugin
290
291 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
292 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
293 - reservation plugin more robust
294
295 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
296 - pass device to bwlimit
297
298 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
299 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
300
301 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
302 - Catch all exceptions for sfa plugin
303
304 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
305 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
306
307 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
308 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
309
310 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
311 - plugins/sliverauth.py improvements
312
313 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
314 - Disable sfagids plugin
315
316 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
317 - Re-tag nodemanager to include conflicted commits
318
319 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
320 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
321 - sfagids plugin deleted
322 - band-aid patch for lack of GetSliceFamily removed
323
324 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
325
326 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
327 - revert curlwrapper to former forking-curl version
328 - fixes in the omf plugin for ssh key location and node hrn
329 - set umask 0022 in tools.daemon
330
331 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
332 - configure omf-resctl for keys
333
334 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
335 - fix key generation
336
337 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
338 - name changes and fix typos
339
340 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
341 - remove config and options parameters from start function
342
343 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
344 - working version of reservable nodes
345 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
346 - dismantled the -s|--startup option (no convincing need for that)
347 - simpler and more robust init.d/nm
348 - initscript content management through replace_file_with_string
349 - sliverauth uses replace_file_with_string
350 - curlwrapper has a debug mode
351
352 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
353 - pretty-printing/normalized python code - hopefully neutral
354
355 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
356 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
357 - that triggers /etc/init.d/vinit.slice if present and executable
358 - (2) install the slice-provided initscript (as per the initscript tag) as
359 - /etc/init.d/vinit.slice
360 - (3) as a result the initscript are now triggered by rc as part of the
361 - standard vserver .. start, properly attached to the vserver,
362 - and properly killed upon vserver .. stop
363 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
364
365 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
366 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
367 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
368 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
369 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
370 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
371 - cleanup: nodemanger now is a class; however plugins are still dumb modules
372 - cleanup: does not depend on obsolete Set
373
374 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
375 - tagging before RC
376
377 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
378 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
379 - Added some precautions to the slice id-saving code
380 - Added log message to code that records the slice id
381
382 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
383 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
384 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
385 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
386
387 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
388 - fix log_call in plugins/drl.py
389
390 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
391 - protect against nodes in migrated PLC's not having the hrn tag yet
392
393 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
394 - new omf-resctl and drl plugins
395 - specialaccount optimized to overwrite authorized keys only upon changes
396 - codemux plugin has support for a new 'ip' setting
397 - mainloop to display ordered modules&plugins at all times
398
399 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
400 - modules and plugins have a priority
401 - specialaccounts appears soon in the priority chain
402 - logger.log_call logs process output, and has a timeout
403 - vuser{add,del} run through bash -x
404 - nm initscript has support for 'service nm restartverbose'
405 - logs reviewed for consistency
406 - use hashlib module instead of sha when available
407
408 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
409 - first working version of 5.0:
410 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
411 - nodefamily is 3-fold with pldistro-fcdistro-arch
412 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
413 - (in addition to the 'vref' tag that's still exposed too)
414 - logging reviewed for more convenience
415 - support for 'service nm restartdebug'
416 - make sync knows how to publish uncommitted code on a test node
417
418 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
419 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
420
421 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
422 - support for f10 and f12 in the vref slice tag
423
424 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
425 - build on fedora12
426 - uses slicename 'sfacm' instead of 'genicw'
427
428 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
429 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
430 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
431 - days ago.
432
433 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
434 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
435 - self-contained. With this change, they will be able to refer to the attributes associated with a
436 - slice.
437
438 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
439 - fix for syntax error
440
441 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
442 - -fixed problem with sioc import at the build side
443 - -bwlimit.set() now accepts the device and does not asume that it is eth0
444
445 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
446 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
447
448 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
449 - The seed for random previously was the meaning of life (i.e., 42) but
450 - that resulted in a not so random choice for the hmac.  This
451 - implementation now uses a random.seed that is based on the current
452 - time.
453
454 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
455 - Minor fix such that sliverauth.py makes a more specific call to
456 - GetSliceTags that include that specific tagname it is looking for.
457
458 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
459 - Fix bug that prevented 'OVERRIDES' for working correctly.
460
461 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
462 - Increase disk limits to 10G per sliver
463 - Sanity check slice for home directory before starting (hack)
464 - Check codemux arguments
465
466 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
467 - * Fix Delegation
468 - * Move plcapi in plugin-api GetSlivers() calls.
469 - * Persistent Authcheck and resync session when auth failure
470
471 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
472 - Disabling sliverauth module.  Not ready for deployment.
473
474 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
475 - Fixing overrides semantics.
476
477 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
478 - Generalized plugins
479 - Fixed initscript start up bug.
480
481 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
482 - * Fix delegation authentication problem
483 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
484
485 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
486 - * Rerun initscripts when slice goes from disabled to enabled.
487
488 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
489 - * Update session key when out of synch with PLC
490 - * PLCDefaults uses tagname
491
492 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
493 - log invokations of vsys
494
495 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
496
497 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
498
499 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
500 - Codemux supports multiple hosts mapping to single slice
501 - Fixed bug in delegation support where tickets delivered weren't
502   being passed to sm.deliver_ticket().
503
504 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
505 - Codemux now configured via slice attribute (host,port)
506 - Support for multiple vserver reference images (including different archs)
507 - Mom BW emails are sent to list defined by MyPLC's config
508 - Sirius BW loans honored correctly.  Fixed.
509 - BW totals preserved for dynamic slices so as not to game the system.
510
511 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
512 - Configures vsys via vsys slice attribute {name: vsys, value: script}
513 - CPU reservations are now calculated via percentages instead of shares
514 - BW totals preserved for dynamic slices
515 - Closes bug where node cap sets off bw slice alarms for all slices.
516
517 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
518 - Switched to SVN.
519
520 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
521 - Initial build.