sshsh is totally obsolete, since we use lxc-userspace
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 9
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ########## use initscripts or systemd unit files to start installed services
10 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
11 %define make_options WITH_SYSTEMD=true
12 %define initdir /usr/lib/systemd/system
13 %else
14 %define make_options WITH_INIT=true
15 %define initdir %{_initrddir}
16 %endif
17
18 Summary: PlanetLab Node Manager Library
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: PlanetLab
23 Group: System Environment/Daemons
24 Source0: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27 Vendor: PlanetLab
28 Packager: PlanetLab Central <support@planet-lab.org>
29 Distribution: PlanetLab %{plrelease}
30 URL: %{SCMURL}
31
32 # not possible because of forward_api_calls
33 #BuildArch: noarch
34
35 # make sure we can invoke systemctl in post install script
36 %if "%{initdir}" != "%{_initrddir}"
37 Requires: systemd
38 %endif
39
40 # Uses function decorators
41 Requires: python >= 2.7
42 # connecting PLC
43 Requires: python-pycurl
44 # Signed tickets
45 Requires: gnupg
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48 # we do need the slice images in any case
49 Requires: sliceimage-%{slicefamily}
50 # for bwlimit
51 Requires: plnode-utils
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59 nodemanager-lib only provides a skeleton and needs as a companion
60 either nodemanager-vs or nodemanager-lxc
61
62 ##############################
63 %prep
64 %setup -q
65
66 %build
67 # make manages the C and Python stuff
68 %{__make} %{?_smp_mflags} %{make_options} lib 
69
70 %install
71 # make manages the C and Python stuff
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
74
75 ##############################
76 %post
77 ########## traditional init
78 %if "%{initdir}" == "%{_initrddir}"
79 ##########
80 chkconfig --add conf_files
81 chkconfig conf_files on
82 chkconfig --add nm
83 chkconfig nm on
84 chkconfig --add fuse-pl
85 chkconfig fuse-pl on
86 if [ "$PL_BOOTCD" != "1" ] ; then
87     service nm restart
88     service fuse-pl restart
89 fi
90 ##########
91 %else
92 ########## systemd
93 systemctl enable nm.service
94 systemctl enable conf_files.service
95 # empty
96 #systemctl enable fuse-pl.service
97 if [ "$PL_BOOTCD" != "1" ] ; then
98     systemctl restart nm.service
99 #    systemctl restart fuse-pl.service
100 fi
101 ##########
102 %endif
103
104 ##############################
105 %preun
106 # 0 = erase, 1 = upgrade
107 ########## traditional init
108 %if "%{initdir}" == "%{_initrddir}"
109 ##########
110 if [ $1 -eq 0 ] ; then
111     chkconfig fuse-pl off
112     chkconfig --del fuse-pl
113     chkconfig nm off
114     chkconfig --del nm
115     chkconfig conf_files off
116     chkconfig --del conf_files
117 fi
118 ##########
119 %else
120 ########## systemd
121 if [ $1 -eq 0 ] ; then
122 #    systemctl disable fuse-pl.service
123     systemctl disable conf_files.service
124     systemctl disable nm.service
125 fi
126 ##########
127 %endif
128
129 ##############################
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(-,root,root,-)
135 %{_datadir}/NodeManager/
136 %{_bindir}/forward_api_calls
137 %{initdir}/
138 %{_sysconfdir}/logrotate.d/nodemanager
139 /var/lib/nodemanager/
140
141 %changelog
142 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
143 - fixes in hostmap, and in interfaces
144 - new vsys_sysctl
145 - privatebridge now comes with nodemanager-lib
146
147 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
148 - omf plugin does not block any longer when running trigger script
149 - log goes into sliver's /var/log instead
150
151 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
152 - new install-scripts target in Makefile
153 - conf_files and fuse-pl initscripts chmod'ed +x
154 - omf_resctl config template tweaked to use _slicename_%_hostname_
155
156 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
157 - make sure to create /etc/planetlab/virt so others can read that
158 - expose get_node_virt() and command_in_slice()
159 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
160 - user's .profile now has right owner
161 - other tweaks in lxc slivers
162
163 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
164 - lxc slice creation: slice user was created with unknown gid - fixed
165 - lxc slice creation: .profile for root and user - fixed
166
167 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
168 - fix umounting of ssh directory when deleting omf-friendly slivers
169 - support for writing cgroups in subsystems other than cpuset
170 - add xid to template match
171 - finer-grained split between -lib -vs and -lxc
172 - first roughly complete omf_resctl for omfv6
173 - minor fix for when getslivers does not have minexemptrate
174
175 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
176 - Fix path, machine arch in slivers
177
178 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
179
180 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
181 - no-op bump to 5.2 to be in line with the rest of the system
182
183 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
184 - improvements to privatebridge
185
186 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
187 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
188
189 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
190 - fix wrong gre tunnel deleted when topology changes
191
192 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
193 - Update /etc/hosts in slivers from sliver_hostmap tag.
194
195 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
196 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
197 - initial check-in of privatebridge plugin.
198
199 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
200 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
201
202 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
203 - fix slices not deleted properly when they use vsys
204
205 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
206 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
207
208 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
209 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
210
211 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
212 - Bridge virtual interfaces to VLANs
213
214 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
215 - Add support for L2 bridged interfaces with public IPs inside a slice
216
217 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
218 - Support for freezing BestEffort slices for Vicci
219
220 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
221 - Change to use new vsh (wrapper for lxcsu)
222
223 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
224 - add missing import
225 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
226
227 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
228 - tag 2.1-7 was broken for OMF-friendly slices
229 - expose_ssh_dir was erroneously defined on the Worker class
230
231 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
232 - bwlimitlxc now ships with plnode-utils
233
234 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
235 - set LD_PRELOAD for linux-containers nodes
236
237 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
238 - first complete version for vs and lxc - functional but not thoroughly tested though
239
240 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
241 - split packaging in 3 (lib, lxc, vs)
242 - this tag will only work with lxc though
243
244 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
245 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
246
247 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
248 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
249 - purpose being to be able to run this branch on vserver nodes as well
250
251 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
252 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
253 - passes tests with lxc but won't build against vs due to conflict
254 - as bwlimit.py also ships with util-vserver-pl
255
256 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
257 - refactoring: isolate initscript functionality
258 - aimed at making initscript implementation with lxc straightforward
259 - show stack trace when module loading fails
260 - accounts.py renamed into account.py for consistency
261
262 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
263 - /var/log/nodemanager shows duration of mainloop
264
265 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
266 - first working draft for dealing with libvirt/lxc on f16 nodes
267 - not expected to work with mainline nodes (use 2.0 for that for now)
268
269 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
270 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
271
272 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
273 - Added memory scheduling to core scheduler
274 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
275
276 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
277 - tweaked log policy for the core scheduler
278 - curlwrapper has an optional verbose mode
279
280 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
281 - fixes for hmac and omf_control tags
282 - optional besteffort flag to core scheduler
283 - logrotate entry for /var/log/nodemanager.daemon
284 - a template for bash initscripts
285
286 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
287 - rename initscript_body into initscript_code
288 - fix generic vinit for broken bash syntax &>>
289
290 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
291 - new initscript_body slice tag, with stop and restart
292 - generic vinit script live updated
293 - new coresched module
294 - protect against non-existing vsys scripts
295 - use Config. instead of globals
296
297 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
298 - more robust reservation plugin
299
300 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
301 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
302 - reservation plugin more robust
303
304 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
305 - pass device to bwlimit
306
307 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
308 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
309
310 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
311 - Catch all exceptions for sfa plugin
312
313 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
314 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
315
316 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
317 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
318
319 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
320 - plugins/sliverauth.py improvements
321
322 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
323 - Disable sfagids plugin
324
325 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
326 - Re-tag nodemanager to include conflicted commits
327
328 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
329 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
330 - sfagids plugin deleted
331 - band-aid patch for lack of GetSliceFamily removed
332
333 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
334
335 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
336 - revert curlwrapper to former forking-curl version
337 - fixes in the omf plugin for ssh key location and node hrn
338 - set umask 0022 in tools.daemon
339
340 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
341 - configure omf-resctl for keys
342
343 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
344 - fix key generation
345
346 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
347 - name changes and fix typos
348
349 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
350 - remove config and options parameters from start function
351
352 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
353 - working version of reservable nodes
354 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
355 - dismantled the -s|--startup option (no convincing need for that)
356 - simpler and more robust init.d/nm
357 - initscript content management through replace_file_with_string
358 - sliverauth uses replace_file_with_string
359 - curlwrapper has a debug mode
360
361 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
362 - pretty-printing/normalized python code - hopefully neutral
363
364 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
365 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
366 - that triggers /etc/init.d/vinit.slice if present and executable
367 - (2) install the slice-provided initscript (as per the initscript tag) as
368 - /etc/init.d/vinit.slice
369 - (3) as a result the initscript are now triggered by rc as part of the
370 - standard vserver .. start, properly attached to the vserver,
371 - and properly killed upon vserver .. stop
372 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
373
374 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
375 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
376 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
377 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
378 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
379 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
380 - cleanup: nodemanger now is a class; however plugins are still dumb modules
381 - cleanup: does not depend on obsolete Set
382
383 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
384 - tagging before RC
385
386 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
387 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
388 - Added some precautions to the slice id-saving code
389 - Added log message to code that records the slice id
390
391 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
392 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
393 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
394 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
395
396 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
397 - fix log_call in plugins/drl.py
398
399 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
400 - protect against nodes in migrated PLC's not having the hrn tag yet
401
402 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
403 - new omf-resctl and drl plugins
404 - specialaccount optimized to overwrite authorized keys only upon changes
405 - codemux plugin has support for a new 'ip' setting
406 - mainloop to display ordered modules&plugins at all times
407
408 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
409 - modules and plugins have a priority
410 - specialaccounts appears soon in the priority chain
411 - logger.log_call logs process output, and has a timeout
412 - vuser{add,del} run through bash -x
413 - nm initscript has support for 'service nm restartverbose'
414 - logs reviewed for consistency
415 - use hashlib module instead of sha when available
416
417 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
418 - first working version of 5.0:
419 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
420 - nodefamily is 3-fold with pldistro-fcdistro-arch
421 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
422 - (in addition to the 'vref' tag that's still exposed too)
423 - logging reviewed for more convenience
424 - support for 'service nm restartdebug'
425 - make sync knows how to publish uncommitted code on a test node
426
427 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
428 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
429
430 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
431 - support for f10 and f12 in the vref slice tag
432
433 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
434 - build on fedora12
435 - uses slicename 'sfacm' instead of 'genicw'
436
437 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
438 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
439 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
440 - days ago.
441
442 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
443 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
444 - self-contained. With this change, they will be able to refer to the attributes associated with a
445 - slice.
446
447 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
448 - fix for syntax error
449
450 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
451 - -fixed problem with sioc import at the build side
452 - -bwlimit.set() now accepts the device and does not asume that it is eth0
453
454 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
455 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
456
457 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
458 - The seed for random previously was the meaning of life (i.e., 42) but
459 - that resulted in a not so random choice for the hmac.  This
460 - implementation now uses a random.seed that is based on the current
461 - time.
462
463 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
464 - Minor fix such that sliverauth.py makes a more specific call to
465 - GetSliceTags that include that specific tagname it is looking for.
466
467 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
468 - Fix bug that prevented 'OVERRIDES' for working correctly.
469
470 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
471 - Increase disk limits to 10G per sliver
472 - Sanity check slice for home directory before starting (hack)
473 - Check codemux arguments
474
475 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
476 - * Fix Delegation
477 - * Move plcapi in plugin-api GetSlivers() calls.
478 - * Persistent Authcheck and resync session when auth failure
479
480 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
481 - Disabling sliverauth module.  Not ready for deployment.
482
483 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
484 - Fixing overrides semantics.
485
486 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
487 - Generalized plugins
488 - Fixed initscript start up bug.
489
490 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
491 - * Fix delegation authentication problem
492 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
493
494 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
495 - * Rerun initscripts when slice goes from disabled to enabled.
496
497 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
498 - * Update session key when out of synch with PLC
499 - * PLCDefaults uses tagname
500
501 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
502 - log invokations of vsys
503
504 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
505
506 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
507
508 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
509 - Codemux supports multiple hosts mapping to single slice
510 - Fixed bug in delegation support where tickets delivered weren't
511   being passed to sm.deliver_ticket().
512
513 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
514 - Codemux now configured via slice attribute (host,port)
515 - Support for multiple vserver reference images (including different archs)
516 - Mom BW emails are sent to list defined by MyPLC's config
517 - Sirius BW loans honored correctly.  Fixed.
518 - BW totals preserved for dynamic slices so as not to game the system.
519
520 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
521 - Configures vsys via vsys slice attribute {name: vsys, value: script}
522 - CPU reservations are now calculated via percentages instead of shares
523 - BW totals preserved for dynamic slices
524 - Closes bug where node cap sets off bw slice alarms for all slices.
525
526 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
527 - Switched to SVN.
528
529 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
530 - Initial build.